水庫防洪運轉

編號　89-土木防災-教材-09

八十九會計年度

大學校院「土木工程防災」教育改進計畫

教材名稱

淹水預警分析（二）：水庫防洪運轉

執行單位：國立成功大學水利及海洋工程學系

主 持 人：周乃昉

民國八十九年九月二十日


摘要

    本教材以曾文水庫為例，建立本土化之「水庫防洪運轉」分析教材，計畫成果包含書面教材、網頁教材及教材散佈光碟，教材適用對象依章節深淺，包含一般社會人士、學生及具有專業知識的現地工程人員，教材適用對象示如摘表 1 。

    在針對一般社會人士部分，強調水庫必定能削減與稽延洪峰。不管在任何安全狀況下，水庫一定能降低天然流量的洪峰，並使洪峰時間稽延。有閘門式水庫受法令限制下，必須使水庫放水量小於天然流量，無閘門水庫則以南化水庫模擬及居家的小實驗說明之。其後，由水庫防洪運轉原理說明，水庫如何利用蓄水空間調蓄洪水以確保水庫安全及消減下游河道洪峰。

    在針對大專水利工程科系學生及具有專業知識的現地工程人員部分，首先介紹水庫洪水演算，先以水文學的方法解無控制水庫、受控制水庫及自然河槽中之蓄水演算；其次，模擬水庫放水後下游河道之洪水流況；最後以防洪運轉法規、物理限制、人為限制與放水型式說明水庫放水策略所需考量的限制，並以曾文水庫防洪運轉的相關操作規定為範例說明。

    最後，教材內容在最佳防洪運轉策略分析部分，對象為具有研究所背景的學生及專業人士，以系統分析法介紹優選模式的基本概念及相關方法，並以線性規劃連續趨近法說明水庫防洪運轉之最佳策略分析。

    教材附錄則以馬斯金更法演算例說明河道洪水演算及變化，線性規劃法說明水庫防洪運轉最佳策略，兩範例均以詳細計算步驟說明。

    在網頁教材部分 ( http://feitsui.hyd.ncku.edu.tw/Hazard/ ) ，將上述書面教材以網頁型式透過網際網路將教材提供給他校學生或社會人士，作為洪水災害防治教育的推廣教材之一，並另增加互動式網頁增進學習效果，包括發展線性規劃模式供網頁學習瀏覽人員輸入或修改防洪運轉策略之限制式，經網站伺服主機進行限制式分析及建立線性規劃參數後，求得最佳防洪運轉策略。另配合網站互動性建立留言版，可由學習瀏覽人員直接參與討論及提出建議，網頁亦包含相關介紹與說明，網站架構圖示如摘圖 1 。

    建議未來相關網頁教材部分均建立與提供線上即時互動計算，可立即提高學習成效及興趣，惟提供線上即時互動計算亦同時使網站伺服主機負擔增加，本網站伺服主機為民國 87 年 5 月購置，恐將無法負擔大量範例計算與分析，應予升級更新。另降雨逕流分析部分仍有許多相關理論及演算未在教材中提及，宜繼續辦理降雨逕流部分教材撰寫，並針對一般人士部分加強深入淺出的介紹。

摘表 1　教材適用對象

教材章節 | 內容範圍 | 適用對象
第一章 | 水庫對洪水之影響 | 一般人士
第二章 | 水庫防洪運轉原理 | 一般人士
第三章 | 水庫洪水演算 | 專業人士
第四章 | 水庫進水量 | 專業人士
第五章 | 河道洪水演算 | 專業人士
第六章 | 防洪運轉法規與策略 | 專業人士
第七章 | 防洪運轉模擬 | 專業人士
第八章 | 最佳防洪運轉策略分析 | 專業人士

摘圖 1　網站架構示意圖


前言

    自然災害非人力所能抗拒，對洪水而言，祇能透過各種方法對其造成的災害加以減輕。民國八十五年八月賀伯颱風來襲造成台北板橋一帶地區淹水不退，及八十三年八月間岡山地區之淹水，民間都論及上游水庫之洩洪恰當與否，概經常淹水地區之河川外水位直接受到上游水庫洩洪之影響，進而影響下游低窪地區的可能淹水範圍。

    水庫所扮演的角色除了蓄水供水外，尚肩負防洪的功能。水庫本身已具調節洪水之功能，若欲進一步減低放水洪峰，便須透過人為操作方可能達成。本教材擬介紹如何透過水庫之防洪運轉以減輕水庫下游低漥地區之淹水潛勢，以減少水患損失。

    國內水庫之防洪操作都遵循既定之運轉規則實施，此運轉規則之制定多採用模擬試誤分析，本教材除介紹一般之分析方法外，另將增加介紹如何應用數學規劃法分析水庫最佳操作策略。對有閘門控制洩洪的水庫，可透過閘門操作演算，預知數小時後之水庫放水歷線，並輔以下游河道洪水演算推估下游河川流量，掌握洪水在流域內之行蹤以提前預警，在水患發生前疏散人員及物資，減少生命財產之損失。

    目前國內外學校在水利工程教學上少有論及水資源設施之操作與管理，雖然水庫防洪運轉的問題早已受到重視，但有關水庫防洪運轉方面的教育書籍和課程卻尚十分缺乏，尤其是本土化之教材。本系已在研究所開設「水資源系統分析」及「水資源管理」等課程供學生選修，以加強學生對水庫等水工設施防洪運轉之瞭解。惟在大學部課程中，僅在「水資源工程」一課略加提及，鑑於加強水資源設施之操作管理以減輕災害為未來的趨勢，實有必要加強大學部學生此方面的知識；又因每次發生颱洪時，社會上都有水庫洩洪不當之說法，事實上多數情況是因為社會人士不瞭解水庫防洪運轉內涵所致，故亦有提供社會人士正確防洪運轉觀念的必要。

    配合學生的階段性學習所需及不同之教學深度，在教材編排上考量不同需求層次，分成一般人士、大學生及研究生可閱讀的三種，讀者可視自己的程度，循序選讀不同深度之內容。一般社會人士即可閱讀之部份，著重介紹正確的防洪運轉基本觀念，以消除一般人士直覺上認為水庫洩洪一定會增加下游河道洪水的錯誤觀念，此部份所闡釋的觀念，亦可供大學部學生先建立水庫防洪運轉課題的基本概念；大學生所適用的教材中，則增加了水文、水力過程的數學演算，及整個防洪運轉過程之流量、水位模擬分析；適用研究生學習的教材，則著重於研擬可資消減下游河道洪峰之最佳防洪運轉策略。

    此一「水庫防洪運轉」多媒體教材，屬於「淹水預警分析」課程的一部份，將可做為正式上課之輔助教材，亦可供學生在家透過網路自修之用。

    雖然水庫防洪運轉的問題在台灣已逐漸受到重視，但有關水庫防洪運轉教育方面的書籍和課程卻十分缺乏。有關水庫防洪運轉之議題包括：運轉之基本原理、運轉開始及結束之條件、防洪運轉與自然水文過程及法規之關係、防洪運轉之風險分析、水庫防洪運轉模式、最佳運轉策略分析方法、水庫防洪運轉與流域洪水預警報系統、水庫防洪運轉決策過程等。


第一章　水庫對洪水之影響

    水庫對於洪水的影響一定是使洪水量削減的，一般來說，在有閘門的水庫放水規定中，不管任何時刻放水，水庫的放水量都必須小於水庫的入水量，亦即須小於在未建水庫前水壩位置的自然流出水量，基於此項規定下，有閘門的水庫必然可使洪峰水量降低。

    那對於無閘門的水庫呢？答案亦是肯定的，水庫對於洪水的影響一定是使洪水量削減的。吾人舉一實例來看，圖 1.1 為南化水庫的溢洪道照片，以民國 83 年寶莉颱風為例，假設南化水庫在颱風來臨之前，水庫水位 170.0 、 172.5 、 175.0 、 177.5 及 180.0 公尺，由於南化水庫滿水位為 180 公尺，因此在颱風來臨前水庫水位不會超過 180 公尺，模擬以上不同水庫起始水位下，有無水庫所造成的影響如圖 1.2 、圖 1.3 。

圖 1.1　無閘門式南化水庫溢洪道

圖 1.2　南化水庫在不同起始蓄水位下的放水過程

圖 1.3　南化水庫在不同起始蓄水位下水庫水位過程

    由圖 1.2 中天然流量的洪峰水量均比任一模擬的起始水位之洪峰流量還要高，由於南化水庫是屬於無閘門式的水庫，因此水位未到達滿水位 180 公尺，是不會有水流出，直到水庫蓄水到達滿水位 180 公尺後，才有水量流出，可由圖 1.3 對照圖 1.2 水庫放水開始的時刻。其中水庫起始水位 170 公尺的情形下，水庫從颱風開始到颱風結束間，均無法使水庫蓄水到達滿水位 180 公尺，因此在圖 1.2 中水位 170 水庫放水量均為 0 。

    為何水庫具有消減洪水的能力呢？由圖 1.4 中，當水庫水位高於溢洪道時，水庫內的水開始流出，由於水的流動無法瞬間就完成，故水庫會產生「超高蓄水」，所以天然流量的均會先蓄存在這，再慢慢的流出，而天然流量越大，超高蓄水就會隨著越高，可蓄存的洪水量就越多，因此即使水庫是處於滿水位的狀況下，水庫仍具有消減洪水的能力。

圖 1.4　水庫洪水消減示意圖

    若還無法想像，可以自行在家中作實驗，在家裡找個臉盆或是湯鍋，當開始把水注入臉盆中時，就像水庫處於不同起始水位下的情形，當臉盆已滿，水開始往外溢流時，這時臉盆內的水深必定高於臉盆，可以由側面觀察；試著將注入臉盆的水量增加，則臉盆的水深亦會增加；再試著將注入臉盆的水量停止，由於臉盆內水深高於臉盆，臉盆內的水將持續慢慢的流出來，直到臉盆內的水深與臉盆一樣高為止。

    由以上的小實驗可以了解，無閘門式的水庫必定可使洪水消減，閘門操作式的水庫，基於法令的要求下，亦必定會使洪水消減，因此可以斷然的說：「水庫對於洪水的影響一定是使洪水量削減的。」


水庫防洪運轉原理

第二章　水庫防洪運轉原理

2.1　水庫防洪運轉之目的
2.2　水庫之位置
2.3　水庫之大小
2.4　水庫運轉操作
2.5　水庫型式


水庫防洪運轉之目的

2.1　水庫防洪運轉之目的

    水庫消減洪災的方法乃是攔蓄洪流之一部份，如此可使受保護地區之洪峰流量減至極小。在理想情況，水庫之位置應位於緊接受保護地區之上游，其運轉乃是要減除洪峰流量。此可將所有水庫進水量排出，直至水庫出水量達到下游河槽之安全容量 (圖 2.1 中之S點) 而完成。所有高於安全容量之水庫進水量皆由水庫儲存，直至水庫進水量已降至低於河槽安全容量時，水庫儲存之水即放流出去，以騰空水庫容量，留待下次洪水時再儲存。因為水庫位置緊接受保護點之上游，是以在該點之歷與從壩址放出之歷線相同，但洪峰流量已減小了一數量AB (圖 2.1 )。

圖 2.1　理想洪災消減水庫之運轉

    如果在水庫與保護地區間有若干距離，但在此等點之間無局部進流量，則水庫之操作與前一樣。然而，在水庫下游河段中之蓄水，可減低天然之歷線，使在控制點處之峰流降低值AB減少至CD (圖 2.1 )。如在壩與控制點間有一實質之局部進流，水庫之操作必須要使在保護地區處產生一極小洪峰，而非在壩處產生極小洪峰。在通常情況，局部進流洪峰較上游進流洪峰來得快，所以此項操作在洪水早期，壩址處應使放水量很低，然後以較高流量放水，使此高量之水在局部進流洪峰之後的時間到達 (圖 2.2 )。圖示之保護地區為河邊鎮，河邊鎮之天然歷線應等於在壩址處之入流演算至河邊鎮之歷線 (B) 加上局部進流歷線C，即歷線 (B+C)。水庫操作後，河邊鎮之歷線即為 (E+C)。由圖可知降低之峰流如圖上所註減峰量。

圖 2.2　理想水庫為保護距埧下游一日水程之河邊鎮


水庫之位置

2.2　水庫之位置

    上節指出水庫適當位置應緊接於保護點 (或河段) 之上游處，方可得最有效之洪災消減。但是這樣的水庫之位置通常位於廣大之洪水平原內，需要很長的壩體，且很大的高價值土地面積成為庫底，遭受洪水淹沒。壩址愈接近上游，所需之壩亦愈小，淹沒土地之價值亦甚小，但在降低洪峰方面之效果較小。效果損失之原因乃是由於河槽蓄水之影響 (圖 2.1 )，以及水庫與保護城市間之局部進流缺乏控制 (圖 2.2 ) 等所引起。如果局部進流之面積很大，則局部進流量所產生之洪水，水庫只能極少或無法控制。應予注意者，單一水庫不可能對其下游位於不同距離處之許多城市給予同等之保護。評估一洪災消減水庫或一系統水庫之有效準則乃是水庫所控制面積占總流域面積之百分數而定，此一準則主要乃是定性者。表 2.1 所示乃美國已建造或擬建之數個防洪系統的適當數據。一般，至少總流域面積之三分之一應受水庫控制以有效降低洪峰。

    經濟分析多偏好於上游之庫址，而無視其效果較小。有時，興建幾個小水庫反比興建單一大水庫好得多。因為每一問題皆具有其獨特性質，故無一般原則可供遵循，但是若干替代計劃必須使用經濟分析予以評估，此為水資源工程之必要者。數個小水庫之使用可獲發展之彈性，因開始時，可選擇系統中具有最高經濟還本率之水庫先建，然後再看該地區發展後，所增之效益蘊勢而決定興建其它單位之先後，如此可使財務負擔減少，經濟分析更為有利。

表2.1　若干典型防洪計劃之資料


水庫之大小

2.3　水庫之大小

    由於水庫容量若大，蓄存洪水之數量亦較大，故藉水庫運用，使得峰流降低之趨勢，亦隨水庫容量增加而增大。因為此一理由，評估洪災消減水庫之第二準則乃是其蓄水容量 (storage capacity)，通常用其河流流域面積所生逕流表示之。如果此值與整個面積上之可能暴雨雨量比較，吾人即可得到水庫有效蘊勢之概念。表 2.1 示出若干洪災消減計劃所具備之容量。

    千萬不要依照上述推想設計之基本原則乃是愈大愈佳，此因經濟因素控制了決策。所需最大之容量等於水庫安全放水與設計洪水量間之容量差。當水庫尺度增大時，還本遞減律即可能發生。因為在低流量時，歷線較寬，當需要降低之總洪增大時，則需蓄存更多之水以降低洪峰至一定量之值。假定歷線為一三角形，則使一已知洪峰降低所需之蓄水容量應隨洪峰降低量之平方而變化。此外，使洪峰降低一單位所獲效益通常小於降低增加量，此因更多之邊際面積而要保護也。若干實例中，水庫單位蓄水之成本隨水庫尺度增加而增加，但亦有成本略減之例。圖 2.3 即閘釋此等因素，曲線 A 表示蓄水單位成本與水庫容量之變化關係。曲線 B 表示洪峰降低量與各種容量之關係。利用此兩種曲線即可畫出曲線 C ，即表完成一定洪峰降低量之統成本。當此一成本與曲線 D 所表示之洪峰降低估計效益之現在價值比較時，顯然可知使洪峰降低量為 60,000 cfs (蓄水容量為 280,000 are-ft) 時之計劃乃是最佳者，蓋其將獲得最大之淨效益點。超過此點之

投資，所得效益之增加值不足以補償成本增加值，是以從經濟觀點來看，修建蓄水容量超過 280,000acre-ft 之水庫乃是不經濟者。

圖 2.3　洪災消減水庫之經濟分析


水庫運轉操作

2.4　水庫運轉操作

    圖 2.1 閘釋理想水庫運用之情況，示出下游河槽容量即可單獨支配理想水庫之運用。如果洪水體積已經接近或超過水庫之蓄水容量，其運用必將有所不同。僅有水庫之進流量精確預測才能推算其運用。同理，除非能預測局部進流量，不能有效的規劃包括局部進流 (圖 2.2 ) 之水庫運用。是故，在規劃洪災消減水庫運用時，河川流量預測乃屬必要。此項預測通常基於流域內之各雨量站網，各河流水位站用電話、電報或無線電及時報告其測量數據後，經計算而得出。在若干地方，已使用了無線電或電話自動水位記錄儀來觀測。此等報告可用雨量-逕流關係，單位歷線，及洪水演算等方法分析之。在適宜之情況下，此等預測十分精確 (± 10%)，但是預測完成後又下雨，則可能有很大之誤差。

    當洪災消減水庫空庫時，則其有使洪峰降低之最大潛勢。洪水發生後，洪災消減容量之一部分由匯積之洪水占據，該一容量部分在上述洪水未放空前，不能再加使用。但水庫放空前可能發生第二次洪水。是故水庫常須保留一部分蓄水容量俾能防範並容納一第二次之洪水；亦即控制任一次單獨洪水不能將水庫之整個容量用完。如果在水庫滿庫時，發生第二次洪水，則水庫之效應將使得此洪水更加惡化(1)。此兩效應—洪水時期不能預估未來之進流量及應需要保留多少蓄水容量，以容納第二次洪水—之意義即謂該一防洪水庫對防洪不完全有效。啦特 (Rutter) 研究之結論認為，在卻特諾加 (Chattanooga)處之田納西河 (Tennessee) ，在連續三次洪水來臨時期，TVA水庫系統僅約 50 % 有效。洪災消減水庫所期望之洪峰降低蘊勢實質上應取成小於基於理想運用所算得之洪峰降低量，除非是小洪水，且僅需水庫容量之一小部分即可作適當的控制。

    當水庫放出超過天然流量之流量，由一支流流來之洪洪水如同時到達下游某點時，則第三個運用問題即會發生。在支流以下之合成流量可能大於已發生過之天然洪水流量。此種情況已發生過許多次，乃是防洪運用最危險情況，尤其是在大河流。倚賴數日前或一週前之氣象預測可減小此一危險性。在上俄亥俄河 (Ohio) 或密蘇里河 (Missouri) 流域中之水庫放水需時 2 至 4 週方能到達下密西西比河 (Mississippi)。


水庫型式

2.5　水庫型式

    具有洪災消減能力的水庫有兩種基本型式—蓄洪水庫及滯洪水庫—其差異僅為所設出水工不同。蓄洪水庫之放水乃由閘門及閥門所調制，閘門及閥門之操作基於計劃工程師之判斷。洪災消減用之蓄水庫與保持水庫 (Conservation reservoir) 之不同點僅在洪災消減水庫需要容量較大之洩水道，俾在洪水後，能快速的放出蓄水。

    滯洪水庫設置有固定而無閘閥之出水口，此出水口能依水庫蓄水體積自動調節出流量。出水口通常包括一大的溢洪道或一個或多個無閘門之洩水道。在法國之Pinay蓄水庫包括有兩翼埧，攔河設置，但兩翼埧間留一缺口，以供排洪使用。此型出水口之選擇，視水庫蓄水特性及洪水問題之本性而定。無閘閥洩水道之功能如同孔口，常喜使用，因當水庫接近滿庫時，依其流量方程式 [image] ，對於放流較之像堰運用之溢洪道，具有較大之節流作用。一簡單之溢洪道常不適宜，因為有若干低於溢道頂之蓄水容量不能使用，然而，若洪水超過設計水量時，一緊急用之溢洪道在任何情況乃是必要的。

    滯洪水庫滿庫時之排洩容量應等於其下游河槽能通過，且不致造成嚴重洪水災害之最大流量，水庫容量必應等於設計洪水流量體積減去洪水期間放水之體積 (圖 2.4 )。洪水發生時，水庫開始充水，排出量亦增加，直至洪水過去及進流量等於出流量時為止。此時以及水即自動從水庫中洩降，直至蓄水完全排光為止。

    美國境內，滯洪水庫之傑出例子乃是 Ohio ， Miami 水土保持區之四個水庫。此計劃之所以選擇滯洪水庫乃是因為各小河流水位上升很快，如作蓄洪水庫，有效操作非常困難。況且，滯洪水庫在洪水過後，即開始洩降，不能使水庫之水保存以犧牲洪災消減。水庫中，在最高水位以下之很多土地常常將會淹沒，雖然此等土地上不許可永久之居民居住，但種植蔬菜或作物頗為相宜。靠近最高計劃水庫高程之陸地偶而亦會泛濫，在該處農耕幾無風險可言。在較低之高程，風險即增加，直至靠近水庫之底，僅有之實用是放牧。是故建造滯洪水庫只有一小部分土地永遠不能使用。

    滯洪水庫系統之規劃必須要保證水庫洩降時放出之流量與支流流來之洪流同時低達時，不致使洪水災害更加嚴重。當整個流域面積很小時，此一現象較不常見。然而，在一大流域中，各單獨之支流地區可能會遭到其各自之暴雨，同步之或然性就很大了。是以，較小之河流處多喜使用滯洪水庫，大的河流處多喜使用蓄洪水庫。

圖 2.4　 俄亥俄州靜水河上之鷹木滯洪水庫的入流及出流歷線， 1913年3月


水庫調洪演算

第三章　水庫調洪演算

    一水歷線實乃一經過某一水位站水波運動之記錄，當水波向下游動時，因受支流流量之加入及水波在不同點之速度不相同而使得它的形狀被改變了。無額外進流量流入時，歷線形狀修正有洪峰消失或水波之基期拉長 (圖 3.1) 及一洪峰之降低。有額外進流量流入時，洪峰消失之效應仍然存在，但總體積增加很不明顯。

圖 3.1 　一洪水坡之連續縱斷面

3.1　演算程序
3.2　無控制水庫之演算
3.3　受控制水庫之演算
3.4　自然河槽中之蓄水演算


演算程序

3.1　演算程序

    在自然河川水波流動之複雜條件下時，若應用水波浪力學 ( 變速流 unsteady flow) ，在理論上計算洪波流動變化之形狀是特別困難，使用微分方程式之數值分析方法，並使用容量甚大之計算機，乃是分析計算此一複雜問題之較佳方法。所用求解之方法乃是基於連績性原理 (principle of continunity) 應用於河流之一短段。此原理係用蓄水方程式 (storge equation) 所表出，

(3-1)

    此處 [image] 及 [image] 係表時間 [image] 之平均進流率與平均出流率， [image] 是時間 [image] 時，河槽在進流量與出流量之間水體積之變量。因 I 為已測定河槽之進流量。故此方程式中對 O 之解答將視 [image] 值而定。

    如在已知之一定時間內，平均流量係等於此時間開始時與終了時流量之平均，則方程式 (3-1) 可被寫為

(3-2)

    此處註腳 1 及 2 分別表示時 [image] 之開始與終了時，如果所取得段 [image] 是相當短的話。則在時段 [image] 內流量直線變化之假定是很恰當的。在實際問題中， [image] 及 [image] 及初始時出流量 [image] 蓄水量 [image] 是已知或者係只有很小誤差之估值。然而仍有二未知數 [image] 及 [image] ，所以需要第二個方程式，此方程式必須使蓄水量與某些可量度參數 (parametr) 相關，與某些可量取之流出量相關。


無控制水庫之演算

3.2 　無控制水庫之演算

    水庫可視為一河槽之加大。在水庫中蓄水影響洪波之形狀較之同長之自然河槽顯著很多。如果水庫無閘門控制，則水即經由堰頂或經一無控制之孔口流出，流出量 O 即為水庫水面高之函數。總而言之，深水庫之中流速甚低，水面幾乎水平。水庫中之蓄水體積直接與蓄水高程有關。因此，蓄水量與流出量亦有直接關係 (圖 3.2) 。由求積儀量取水庫不同等高線所圍之面積，即可由計算而決定蓄水體積。方程式 (3-2) 可再被改寫為：

(3-3)

    此方程式解答所需要之第二種關係乃是 [image] 值為 O 之函數 (圖 3.3) 。在演算時間開始時，方程式 (3-3) 左端所有項目均係已知，且在右端只有一值是要計算的 (表 3.1) 將這些已知值代入圖 3.3 ， [image] 值及其 [image] 之相當值亦可決定。

    如果水庫表面有很大之坡度，蓄水量即變成為進流量同時又是出流量之函數。圖 3.2 所示之出流量蓄水曲線即被一組以進流量為參數所示之出流曲線所取代。同時，圖 3.3 所示之演算曲線亦被一組以進流量為參數所示之曲線取代，演算程序將不變。

圖 3.2　無閘門水庫溢洪道之水面高程，蓄水量與溢流量間之關係

圖 3.3　無控制水庫演算曲線


受控制水庫之演算

3.3　受控制水庫之演算

    一水庫設有溢洪閘門或放出閥時，蓄水量與出水量之關係將視閘門或閥門張開之數目而定。此種水庫之演算與水面坡度甚大的水庫之情形是很類似的，在一設有閘門溢洪道，且其所有之閘門是同樣大小。高程 — 流量曲線即被一組以閘門張開數目為參數所畫之曲線取代 ( 圖 3.4) 。因之 [image] 與 O 之曲線關係必被一組以閘門張開數為參數之曲線所表出。此演算過程與表 3.1 所述相似。但表上要加入閘門張開數並依此張開數用內插法與 [image] 插入這組曲線。如果在研究之時間內閘門張開數不變，則演算步驟應與表 3.1 所述完全一致。蓋因所有數值均可從代表一定閘門開放數之曲線得出矣。

圖 3.4　具有閘門水庫之演算曲線


自然河槽中之蓄水演算

3.4　自然河槽中之蓄水演算

    在任意瞬時，河槽內之蓄水體積稱為河槽或河谷蓄水 (channel 或 valley storage) S. 最直接決定 S 之方法是從地形圖上量取。然而缺乏適宜的詳細地圖，再加上需要假定或計算河槽中流量每一可能情況之水面縱坡使得此方法很不適用。因方程式 (3-1) 僅包括有 [image] ，故蓄水之絕對值並不需要知道使用進流量與出流量之實際值 (圖 3.5) 。藉方程式 (3-1) 可以求得 [image] 值，每河流之進流量與出流量歷線可分成很短時間之間隔，每一時間段之 I 及 O 平均值可從歷線上求得，則由 I 減去 O 即可得 [image] 值，由任一零點高程開始，將蓄水增量累積即可計算蓄水體積。

    當我們照上述方法將 S 值計算出來，並將與此 S 值同時間之出流量，兩兩對應畫出關係曲線 (圖 3.6) 。由此曲線顯示，相同之出流量，漲水時之蓄水量較高，落水時之蓄水量較低。此乃因波峰面通過河槽時，在出流量增加以前，蓄水量已先增，波峰進入河槽以後，雖然出流量仍在增加，蓄水量卻開始減少。幾乎所有之河流演算方法，為了考慮此種變化，均使蓄水量與進流及出流兩者發生關係。某些情況，一組表蓄水，出流，進流間關係曲線已被畫出。則演算方程式之求解可依求解斜坡水面的蓄水庫演算方程式之同樣方法求解。

    另一廣泛利用之假定乃是蓄水係部分入流與部分出流之函數，以式表之，則為

(3-4)

    上式 S ， I 及 O 分別為同時間之蓄水量、進流量、及出流量等值，x 係一純常數，係用來指示在求蓄水量時 I 及 O 之相對重要性。 K 係蓄水量常數其單位為時間。 K 值近似等於波浪流經河槽之經行時間。通常蓄水常數 x 之變化係由 0 至 0.5 。因 [image] 。將方程式 (3-4) 微分，得

(3-5)

    如 [image] 則

(3-6)

    由此式，可從進流與出流記錄來估計 S 。對於一蓄水庫 [image] ，當 [image] 時 [image] 及 [image] 必均為零。故此情況時 [image] 零值，係指出僅出流量可決定蓄水量 ( 在水庫中 ) 。當 [image] 時，進流量與出流量 2 對蓄水量具有相等之影響力。自然河川中之 x 之變化常由 0.1 至 0.3 。方程式 (3-4) 乃是馬斯金更演算方法 (Muskingum method of routing) 之基礎。對任一河流，如 K 及 x 值常由此式得出。即先將 x 值假定則蓄水量與 [image] 之關係便可畫出來，由假定之 x 值畫出關係圖最接近直線者即是 x 所選定值，如圖 3.7 所示 x 應選擇為 0.3 。常數 K 即等於 S 對 [image] 所畫直線之斜度。

    將方程式 (3-4) 用 [image] 及 [image] 表之，代入方程式 (3-3) 中即得馬斯金更演算方程式，解 [image] 得，

(3-7)
(3-8a)
(3-8b)
(3-8c)
(3-8d)

    方程式 (3-8d) 之意義乃是對於定量流 (Steady flow) [image] 而言，僅當各常數和為一單位時，方程式 (3-7) 方才正確。當使用方程式 (3-20) 時， K 與 [image] 應使用相同之單位，當蓄水係用 6 小時增量作計算時，則此單位為 1/4 秒呎日，在畫圖 3.7 時，若此單位不變，則 K 之單位應為四分之一日，或其斜度表 K ＝ 6 小時。

    馬斯金更法之應用步驟見表3.2 之閘釋，將 K ＝ 0.74 日， x ＝ 0.3 ( 圖 3.7) 及 t ＝ 6 小時，代入方程式 (3-8a) 至 (3-8c) 即得可出 [image] ， [image] 及 [image] 之值， I 值乃係已知 ( 見表 3.2) ，則 [image] 及 [image] 積之值可以計算得出。已知或者估計出流量 [image] 之初值，則 [image] 即可計算得出。然後將上述 [image] ， [image] ， [image] 各積相加即可得出 [image] 下步演算時，即將求得 [image] 值變為 [image] ， I 值亦往下推即可求另一 O 值，此等步驟繼續演算下去，直至已知之 I 值算完為止。使用位數電子機，此一演算極易完成。

    實際一河段中之蓄水量視水深而定。蓄水量與流速具有關係之假定，僅當水位與流量具有密切關係時方才有效。若一河流需要知道坡度、水位、流量之關係時。則一較複雜之演算方法必須應用，俾能得到更精確之結果。前節所述之方法亦假定了河川中水面之縱斷面，在已知進流量與出流量聯合發生之任何時間均屬相同。此亦為近似的，但如河段取得不太長亦可得到滿意之精度。一般而言，上述之方法，在大多數之河流得出之結果，頗為滿意。

圖 3.5　一河流段之入流與出流歷線，示計算河槽蓄水計算方法

圖 3.6　圖 3.5 之出流與蓄水關係

圖 3.7　馬斯金更演算法中計算 K 及 x 之方法

表 3.2　馬斯金更法之應用


第四章　水庫進水量預估

    水庫進水量預估包含暴雨預報與降雨逕流模式兩部分，這兩部分將由其它教材部分詳加說明。降雨逕流模式常用的有單位歷線法、線性水庫模式、水筒模式與貯蓄函數法等，本章僅對單位歷線法加以說明。

4.1 單位歷線法
 | 4.1.1 由複合暴雨推導單位歷線
 | 4.1.2 單位歷線之應用


4.1　單位歷線法

4.1.1　由複合暴雨推導單位歷線

    由一複合之暴雨推導一單位歷線，若在此複合暴雨中之個別暴雨，如形成有明顯之洪峰，則可將個別暴雨之歷線分出，而應用之歷線為獨立暴雨所形成者，如將單位歷線平均之，則可消除分離時之誤差。

    如歷線本身不易分離，則以在暴雨期間連續時距分析推估直接逕流體積 [image] ， [image] ，…， [image] ，而總歷線中任一縱標 [image] 可以逕流 Q 與單位歷線之縱標U表之：

(4.1-1)

    第一縱標 [image] ，由於 [image] 已知 (或推估)， [image] 則可計算，如圖 4.1.1 ，繼之第2縱標為：

(4.1-2)

    上式中僅 [image] 未知，故可計算得知，同此法所有之縱標均可求得之。

    雖然此種計算步驟看似簡單，但仍有甚多之困難，由於每一計算均須依前項之 U 值而計算之故。又推估逕流增值之誤差、觀測河溪流量之誤差、以及在某些暴雨期間雨量強度與雨量面積分佈等變化，可能使誤差累積而致單位歷線之後面部份誤差更大，並有較大之負縱坐標值發生。

圖 4.1.1　由複合暴雨求做單位歷線

4.1.2　單位歷線之應用

    單位歷線之應用以均一之逕流為基礎，圖 4.1.2 為應用 3 小時單位歷線由一連串之不同降雨強度之期距合成之暴雨歷線。連續 3 小時期距逕流之增值可以逕流關係計算得知，由每 3 小時逕流增值所得直接逕流歷線則可以期距逕流量乘單位歷線求得，而總逕流歷線乃為所有增值歷線與推估基流量之總和。

圖 4.1.2　應用單位歷線合成河溪流量歷線


河道洪水演算

第五章　河道洪水演算

    在河道洪水演算中，主要為了解上游水文流出狀況對下游河道的影響，在河道洪流演算有相當多種方法，本章配合水庫防洪運轉操作，僅介紹較為簡易且模擬效果良好之馬斯金更法，欲更加了解其它相關計算方法，請參閱河道洪水演算教材。

5.1 馬斯金更法
 | 5.1.1 演算原理與限制
 | 5.1.2 馬斯金更法演算例


第五章 河道洪水演算

5.1　馬斯金更法

5.1.1　演算原理與限制

    計算洪水波在水體中傳播時之高度及速度，就稱為洪水演算，而下游河道洪水演算部份由於洪水波傳送與消減的影響較為複雜。故渠道演算主要可分成兩種形式，一為水文演算乃利用連續方程式以表示水文系統儲蓄量之改變，美國陸軍工程師團 McCarthy 等在 1934-35 年間研究 Muskingum 水土保持區防洪計畫時，發展出 Muskingum 洪水演算法，此為一種水文演算法，為目前最普遍應用之一種河渠洪水演算法。

    馬斯金更假定洪水來臨時，河川蓄水可分為兩種，其一為稜形蓄水(Prism storage)；另一為楔形蓄水(Wedge storage)。前者為平時定量流時河川之蓄水；後者為受洪水波影響時河川之蓄水。洪水來臨時，楔形蓄水為正；退水時，楔形蓄水為負。

稜形蓄水量＝KO

楔形蓄水量＝KX(I－O)

    基本上河渠洪水演算都以連續方程式為基礎，Muskingum 演算法假定渠道蓄水與入流量、出流量間有一權重關係，可表示成如下方程式：

S＝k[xI+(1-x)O] (5-1)

    式中，

k | = 蓄水常數，為加權蓄水量-流量關係圖斜率之倒數；
x | = 每一已知河川斷面的加權因子，介於 0 至 0.5 間。

    考慮演算一過程時段 dt 中， I 、 O 、 S 之變化代入(5-1)式得到：

S2 - S1 = k[x( I2 - I1) + (1-x)(O2 - O1)] (5-2)

    再利用表示成有限差分形式的連續方程式：

(5-3)

    將兩者聯立，可得到入流及出流間之一線性方程式：

(5-4)

    式中，

    需注意 k 與 Δt 的時間單位要相同，且 c0 + c1 + c2 = 1 。

    針對多段河道、長時段演算，(5-5)式即可化成遞迴形式之線性化方程式

(5-5)

    式中，

= 第 j 段河道， t 及 t + 1 時之入流量；
= 第 j 段河道， t 及 t + 1 時之出流量；
= 第 j 段河道之河川演算參數。

    採用 Muskingum 法時，先假定河川蓄水與入流量、出流量間有一權重關係，可表示成一線性方程式。在分析上分成兩階段，第一階段先由歷史流量記錄求取 K、x 兩參數，第二階段再以K、x兩參數求得 c0 、 c1 、 c2 三係數，代入馬斯金更出流及入流之線性方程式進行洪水演算分析。

    整個線性方程式演算皆取決於 c0 、 c1 、 c2 三係數之推求，而此三係數為 K 、 x 兩參數之函數。故在一般洪水演算前，應利用該河段過往之水文記錄，在此則利用FRLFI模式所模擬的流量資料來推求 K 、 x 值，接著再決定演算時距 ，便可得出 c0 、 c1 、 c2 三係數，即可依序推求出流量。

    馬斯金更參數K值代表著蓄水常數，為加權蓄水量與流量關係圖斜率之倒數，具有時間的因次。而x值為無因次參數，用於對入流與出流量之加權衡量(通常 x 比值的範圍為 0<= x <= 0.5 )。

    建立了馬斯金更線性演算模式之後，將各個河道演算斷面程序，寫入線性規劃的限制式當中，與水庫演算部份作結合，將水庫演算及水庫防洪的操作限制，分別寫入線性規劃模式中當作限制式，最後所要決定的便是水庫防洪操作目標式的設定。理論上防洪應以儘量減少下游洪災損失為標的，然此經濟損失數據不易求得，故水庫防洪操作目標式的設定是以降低下游河川某特定控制點之洪峰流量為分析目標。


馬斯金更法演算例

5.1.2　馬斯金更法演算例

例題：某河川之入流量歷線如下表所示，請回答下列各問題：

日期 | 入流量 （CMS） | 日期 | 入流量 （CMS） | 日期 | 入流量 （CMS）
7月25日 | 60 | 8月2日 | 230 | 8月10日 | 99
7月26日 | 90 | 8月3日 | 202 | 8月11日 | 93
7月27日 | 130 | 8月4日 | 160 | 8月12日 | 87
7月28日 | 207 | 8月5日 | 145 | 8月13日 | 82
7月29日 | 240 | 8月6日 | 130 | 8月14日 | 77
7月30日 | 280 | 8月7日 | 120 | 8月15日 | 73
7月31日 | 302 | 8月8日 | 112 | 8月16日 | 60
8月1日 | 290 | 8月9日 | 105 | 8月17日 | 60
  1. 已知此河川之蓄水量 S＝K[XI+(1-X)O] ，試推導出流量 Qt+Δt=C0It+Δt+C1It+C2Ot 問 C0 ， C1 與 C2 隨 K ， X 與 Δt 之關係式。
  2. 已知此河川之特性為X＝0.2，K＝2日，若Δt＝1日，試以馬斯金更法（Muskingum Method）計算出流量。

【解】

  1. 已知蓄水量
S＝K[XI+(1-X)O] (5-1)

將水文方程式以有限差分型式表示

(5-3)

將 (5-1) 式代入 (5-3) 式並經整理可得

Qt+Δt=C0It+Δt+C1It+C2Ot (5-6)

式中，

需注意 k 與 Δt 的時間單位要相同，且 c0 + c1 + c2 = 1 。

  2. 已知 X＝0.2 ， K＝2 日， Δt＝1 日

Qt+Δt= 0.05 It+Δt + 0.43 It + 0.52 Ot

（1） 日期 | （2） 入流量 (CMS) | （3） 0.05It+Δt | （4） 0.43It | （5） 0.52Ot | （6） Qt+Δt
7/25 | 60 | - | - | - | 60.00
26 | 90 | 4.50 | 25.80 | 31.20 | 61.50
27 | 130 | 6.50 | 38.70 | 31.98 | 77.18
28 | 207 | 10.35 | 55.90 | 40.13 | 106.38
29 | 240 | 12.00 | 89.01 | 55.32 | 156.33
30 | 280 | 14.00 | 103.20 | 81.29 | 198.49
31 | 302 | 15.10 | 120.40 | 103.22 | 238.72
8/1 | 290 | 14.50 | 129.86 | 124.13 | 268.49
2 | 230 | 11.50 | 124.70 | 139.62 | 275.82
3 | 202 | 10.10 | 98.90 | 143.42 | 252.42
4 | 160 | 8.00 | 86.86 | 131.26 | 226.12
5 | 145 | 7.25 | 68.80 | 117.58 | 193.63
6 | 130 | 6.50 | 62.35 | 100.69 | 169.54
7 | 120 | 6.00 | 55.90 | 88.16 | 150.06
8 | 112 | 5.60 | 51.60 | 78.03 | 135.23
9 | 105 | 5.25 | 48.16 | 70.32 | 123.73
10 | 99 | 4.95 | 45.15 | 64.34 | 114.44
11 | 93 | 4.65 | 42.57 | 59.51 | 106.73
12 | 87 | 4.35 | 39.99 | 55.50 | 99.84
13 | 82 | 4.10 | 37.41 | 51.92 | 93.43
14 | 77 | 3.85 | 35.26 | 48.58 | 87.69
15 | 73 | 3.65 | 33.11 | 45.60 | 82.36
16 | 60 | 3.00 | 31.39 | 42.83 | 77.22
17 | 60 | 3.00 | 25.80 | 40.15 | 68.95

*假設 Qt+Δt 之初始值為 60 CMS ，第（6）欄即為所求。


第六章　防洪運轉法規與策略

6.1 運轉法規
 | 6.1.1 水利法規
 | 6.1.2 水庫防洪運轉規則
 | 6.1.3 閘門操作規則
6.2 放水策略
 | 6.2.1 調節性洩洪
 | 6.2.2 預先洩放
 | 6.2.3 定量放流
 | 6.2.4 定率放流
 | 6.2.5 定開度放流
 | 6.2.6 水位維持操作
 | 6.2.7 異常洪水放流
 | 6.2.8 水位控制法
 | 6.2.9 優選法


運轉法規

6.1　運轉法規

6.1.1　水利法規

    水利法係從事水利工作之根本母法，法內有甚多條款為從事水庫營運工作者必需注意遵守，相關法規條文摘錄於附錄二。

1. 水庫放流

  1. 防水、引水、蓄水、洩水之建造物，如有水門者，其水門啟用之標準時間及方法，應由興辦水利事業人預為訂定，申請主管機關核准，並公告之。主管機關認為有變更之必要時，得限期令其變更之（水利法第 48 條）。
  2. 洪水期間，有閘門之水庫洩洪前，水庫管理機關應通知有關機關採取必要防護措施（水利法第 65 之 1 條）。
  3. 實施蓄水或排水，致上下游沿岸土地所有權人發生損害時，由蓄水人或排水人予以相當之賠償，但因不可抗力之天災所發生之損害，不在此限（水利法第 69 條）。
  4. 減水閘埧啟閉之標準，水位或時間由主管機關報請上級機關核定公告之（水利法第 71 條）。

2. 水庫運用要務

    由上述，水利法第四十八條規定水門啟用之標準、時間及方法，應申請核准並公告；第六十五條之一規定水庫洩洪必需通知有關機關防護。

    又水利法施行細則第一百二十二條規定多目標水庫運用規則應報請核定發布；第一百二十四條規定洪水時期，水庫最高放水量不得大於最高流入量，水庫放水量之增加率不得超過進水量之最高增加率。

6.1.2　水庫防洪運轉規則

    防洪運轉為水庫構造物安全而放流，包括：洪水時溢洪，緊急降低水庫水位等，必須於短暫時間內放流相當水量，此時極易導致下游地區災害，應有妥善之防範與合理之操作，期免發生災害或將損失減至最低限度。

    當洪水發生時，水庫運轉規則應規定要如何處理洪水；此外，若有閘門，並應規定何時開、如何開、何時關閉；開閘門前如何發佈警報等，均應有詳細規定，以供執行人遵循，相關法規條文摘錄於附錄三。

    茲列水庫放流時應注意之基本原則如下，於操作水門時遵循。

1. 水文限制

  1. 應限制下游之放水量不得大於上游之進水量，以控制不發生「人為洪水」。
  2. 水庫放水量之增加率不得大於天然流量之最高增加率。如臺灣省曾文水庫運用規則第十六條、臺灣省鯉魚潭水庫運用規則第十一條。
  3. 水庫放水宜先以不發生災害之小流量為警告性放水，俟適當時間後遞增放水流量。如臺灣省曾文水庫運用規則第十八條、臺灣省石門水庫多目標運用規則第二十條。
  4. 水庫計畫自規劃調查至詳細設計施工，其間仍有多項假定，必須依據技術之進步，水文分析之研證，運用記錄得失之檢討等，隨水文發生機會之資料核對分析檢討，作合理修正，使各項管理操作辦法能跟隨時代與環境修正 (updating) 。

2. 水力限制

  1. 放水量宜儘量限制在下游河道治理計畫之設計流量範圍內。如臺灣省曾文水庫運用規則第十六條。
  2. 水庫各放水流路應依照各構造物之水理設計原則操作，並防不正常操作影響安全。如曾文水庫各水門啟用標準時間及方法第三條。
  3. 放水量之增加，每一小時不得超過限定流量，以免造成人為超越自然水面比降之洪水，破壞河床平衡與沿河構造物。如臺灣省曾文水庫運用規則第十五條。
  4. 土石壩不得發生溢流。

6.1.3　閘門操作規則

    有閘門控制溢流水量之水庫一般均會另訂運用規則或相關閘門啟用辦法，並公告之。閘門一般包含有：電廠進水口閘門、排砂道放水口閘門、河道進水口閘門及溢洪道放水口閘門，相關法規條文摘錄於附錄四，本節茲就操作原則加以說明。

1. 水力限制

    各類型閘門放流受水頭及流速影響，故有閘門開度啟用之水頭上限及下限，若閘門取水口允許自由溢流，則水頭下限為 0 ，若閘門後水道流量有其最小規定值，則水頭下限從其規定值反算水頭高度定之，如曾文水庫各水門啟用標準時間及方法第三條第三款第一項。如電廠進水口水量經渦輪機流出，欲推動渦輪機運轉需有高於水頭下限方能發電，但若高於水頭上限則可能使渦輪機受損，如臺灣省曾文水庫運用規則第十九條。排砂道放水口及河道進水口閘門一般為低水位所設計，在高水頭時，高速的泥流可能會對閘門及水道產生磨損，一般狀況依設計流量上限決定水頭上限。

    又當水庫太大時，可能會造成閘門因水壓力過大而受損，而水位太小時，放出水量小，若洩槽式溢洪道出口為跳斗，則可能水無法躍起可能造成基礎掏蝕，破壞溢洪道結構。

2. 放水順序限制

    基於放水水力限制與水資源最大運用考量下，啟用閘門順序一般均由電廠取水口先啟用，其後依水力限制或水工模型試驗建議閘門啟用順序依序啟用，以期水理安定。

    以曾文水庫為例，水門操作順序依序為電廠進水口閘門、溢洪道二號閘門 (300 CMS) 、溢洪道一號閘門 (650 CMS) 、溢洪道三號閘門 (900 CMS)。

3. 放水量限制

    電廠進水口、排砂道放水口及河道進水口閘門一般為避免構造物磨損，均以不超過設計流量為上限，故水位高於某一限度時，可能需關閉此諸放水設施。

    另閘門放水量接近溢洪道自由溢流量時，可能發生水力不穩定之過渡流況現象，此時應彈性調整放水量至閘門流或自由溢流以利運轉，原則上可採自由流放水，但若實際執行時正巧受到最大可增放水量限制，或放水量不得大於進水量之限制，以致無法提高至自由流況時，則宜先減少放水量至水力穩定之閘門流狀況，至下一調整閘門開度時刻再提高放水量。

4. 閘門機械限制

    閘門開關受機械控制，機械有單位時間內所能操作的限度，閘門啟閉速率；例如：每隔 30 分鐘或 1 小時可啟動一次；每次開度不得超過 30 分鐘等，故閘門操作指令不應超過機械限制，以免閘門啟閉無法達成指令要求。


放水策略

6.2　放水策略

    一般而言，訂定防洪運轉規則，最根本所需考慮者包括：

  1. 如何確保最大可能洪水時水庫之安全。
  2. 在洪水未到達前，如何預備充分之防洪容量，以供洪水來臨時發揮減洪功能。
  3. 洪水時應如何調節放水量，以達到減洪功效。
  4. 在完成洪水調節後應確保蓄水量，期以達成水庫安全維護及水資源有效利用的雙重目的。

    因自然界的供水流量可能忽增忽減，水庫或調節池水位之急速上漲、洩降，在計畫階段應有詳細之分析研擬，據以訂定操作規則；運轉時應遵守各規定適切操作，除絕對避免過分或不正常之操作外，同時應注意有關構造物及環境之變化與安全，作定期檢查，一般之放水策略分述於下列各小節。

6.2.1　調節性洩洪

    水庫放水，除洪水時之排洪外，在非洪水時有時亦須調節水庫蓄水或水位，而作調節性運轉。例如為水庫檢修需要降低庫水位，或調節上游某些工程設施之有效運用，產生之間歇性流量之急劇變化，在水庫內調節放流。水庫壩工構造物中調節運轉應施設之設備為溢洪道或排洪隧道，及低水位放流設備。

6.2.2　預先洩放

    在洪水來臨前，為增加攔洪容量而放水，此時下游河道水位較低，在洪峰來臨前，預先將水庫蓄水放流，以容納更多之洪水；或為錯開多水庫系統洪峰水量同時到達下游而預先將水庫蓄水量放流之運轉，本法需有較精確之洪流預報模式，但因颱洪未發生之風險仍高，故國內目前並不採用本方法。

6.2.3　定量放流

    水庫放水操作，每單位時間內維持固定放水量，逐步調整閘門開度以配合固定放水量放水。雖然在進水量大於放水量時會使水庫水位持續上升，但若能預期不超過最大可能洪水位時，本法可有效減少下游河道之洪水量。

6.2.4　定率放流

    本法依水庫進水量之一定百分比放水，可因應進水量之增大而增加放水流量，減緩水庫蓄水量之快速上升；唯若針對大的設計洪水擬定放流率，則可能發生小洪水時減低水庫調洪能力。

6.2.5　定開度放流

    水庫維持固定閘門開度放水，由水位高低自然決定放水量。一般用於洪峰通過後，洪水位高於閘門開口高程時，讓水庫水位自然降低，視適當時刻再逐步關閉閘門。

6.2.6　水位維持操作

    水庫放水量等同於進水量以維持固定水位，閘門式水庫依設定之水位配合調節閘門開度放水。此法一般用於操作過程中前一洪峰通過，可能尚有另一波洪峰會進入水庫前而顧及下游淹水潛勢時，唯由於反應進水量之放水有一單位時刻之延遲，故除非預估可能之進水量，否則水庫蓄水仍可能緩慢增加。

6.2.7　異常洪水放流

    在水庫安全之前提下，防洪運轉放水計畫之擬訂與執行，可採用「逾量放水時刻最遲」原則，依此原則儘量延緩放水量超過下游河道無害流量之時刻，亦即水庫放水量儘量維持低於下游河道無害流量，以免造成下游災害，另藉此機會可增加觀察洪水發展之時間，不論洪水減退或增漲，防洪運轉計畫均能及時配合修正，以有效截蓄水量及提高水庫之防洪效果，而達到避免浪費水資源及維護大壩安全之雙重目的。

    除由水庫當時之水位推算進水量外，在放水計畫之制定上，利用現有水文測報系統傳回之雨量資料預測進水量，作為放水計畫擬訂之根據，使水庫防洪功能更能發揮。其方法為使用設計暴雨期序法預測將降之雨量，再銜接實際降雨量後假定為設計暴雨之一部份，實際與預測降雨量銜接後之合成雨量系列，其任何時間之累計雨量，均不應大於原設計暴雨相同延時之累計雨量，依此原則將一部份降雨捨去。應用在運轉分析上時，則自水庫防洪最高限制水位逆時向前推演，由後一時期之蓄水量與放水量，依連續方程式及閘門放水量與水庫蓄水量之關係，推求前一時期之蓄水量及出水量，此計算程序相當於一逆向之水庫洪水演算。

    「逾量放水時刻最遲」制度可能之優缺點如下：

  1. 本制度之特性在於延緩超過河道無害流量之放水時機，期以充分運用水庫蓄洪容積，但對大洪水則往往造成水庫維持在高水位增加操作壓力。
  2. 該法必須配合洪水預報以掌握可延遲放水時機，再經過試誤演算以達成降低最高水位之目的，若預報有誤差，對運轉大洪水之缺點為可能造成往後放水之流量大於原大洪水者。增大放水量可能增大對下游之災害，但對水庫本身則可達成在防洪運轉過程中降低水位之效。
  3. 操作方式傾向於「即時」(Real time) 之觀念，但在計算時效及進水量預測之可靠度上仍有待商榷，故現階段仍未實施，但可由備用計算機分析放水策略，做為輔助操作之參考。

6.2.8　水位控制法

    依據進水量大小，斟酌水庫尚有的可調洪容積，決定放水量，此法只能對目前時刻之水庫狀況決定放水量，至於應放水量除由歷史分析有一建議值外，尚待現地操作人員憑經驗預估未來 3 到 6 小時內可能之進水量再決定放水量，故規則上一般會保留一定範圍之流量，供操作人員彈性決定放水量。翡翠水庫即採用本法放水。

6.2.9　優選法

    當流入水庫的洪水有可能使水庫水位超過蓄洪容積之最高限制水位時，防洪操作的首要考慮事項為防止蓄水溢頂；若防洪操作過程中，不虞使水庫水位超過蓄洪容積之最高限制水位時，操作目的便在於充分發揮水庫蓄洪容積以消減洪峰，並促使防洪操作終了時的水庫水量蓄至期望之水位。

    在不考慮水庫進水量之機率性下，本法必須配合洪水預報以預估在整個操作過程中的水庫進水量歷線，再據以研擬最佳的放水量。由於水文預測之誤差，故實際執行時，需每小時進行流量預測，以修正放水量，唯即使對未來較遠時刻之流量預測不準，但已涵蓋前述水位控制法之優點，可將未來 3 至 6 小時較準確之流量預測值考慮在內，並同時為操作結束時的水庫蓄水預做考量。


防洪運轉模擬

第七章　防洪運轉模擬

7.1　模式簡介

    所謂即時防洪運轉模擬模式，為仿現地運轉程序，協助現場運轉作業之模式。其與優選模式之差別，在於優選模式為預測情況下，全時段整體的水庫最佳放水策略，而模擬模式則根據即時資訊，逐時段決定水庫最佳放水策略。

    模擬模式的功能，在於提供合理且合法的分析程序。此模式提供完整資訊，使操作者在緊急的情況下，能夠臨危不亂作出適當之決策。若優選模式無法正常運作時，模擬模式亦提供操作者進行必要之分析。

7.2　模式分析原理

    即時防洪運轉模擬模式中，需考慮水庫物理條件及水庫防洪作業對水庫的影響程度，進而才能決定水庫放水策略。關於模擬模式的分析原理，及現行曾文水庫防洪運轉法規與限制條件茲分述如下：

  1. 最大允許放水量條件
  1. 溢洪道容量條件

        水庫放水量被溢洪道之容許放流量所限制，溢洪道的最大容許放流量即為閘門全開時之自由流量，而曾文水庫溢洪道自由流流量可近似表示如下：

    其中，

            =水庫於 t 時刻蓄水量；

            = t 時刻溢洪道的最大容許放流量。
  2. 防洪運轉規定

        洩洪總放水量超過河道無害流量2,250cms時，最高放水量不得大於流入水庫之最高流量：

        洩洪總放水量超過河道無害流量2250cms時，總放水量之增加率應小於水庫進水量之最高增加率：

        洪峰通過後，水庫水位低於標高230公尺時，水庫可放水量為進水量加上一超放水量：

    其中，

        洪峰通過後，放水量應逐時遞減：

  3. 每單位操作時段放水量限制

    一般情況下，每單位操作時段放水量的最大允許增加量每小時不得超過1,500秒立方公尺：

    t ：一小時操作時段

    特殊情況下，每單位操作時段放水量的最大允許增加量半小時不得超過1,000秒立方公尺：

    t ：半小時操作時段

  2. 最小允許放水量條件
  1. 防洪運轉規定

    放水洪峰通過前，放水量應逐時遞增：

  2. 調整放水量條件

    放水洪峰通過後，放水量不驟降：

  3. 放水量視出水工調整條件
  1. 溢洪道閘門操作規定

        三閘門同時等量運作為原則，必要時得使用一門或二門單獨運轉。使用一座閘門運轉時，應先啟用二號閘門，使用兩座閘門運轉時，啟用二號及三號閘門。

        閘門之開啟，應自最小容許流量開始，一號閘門為250 cms，二號閘門為300 cms，三號閘門為350 cms。溢洪道開始放水之第一小時放水量設定為300 cms。原則上，第二小時放水量定為650 cms，第三小時放水量定為900 cms。總放水量大於900cms，三座閘門應同時操作，並維持同一開度。

  2. 其它出水工限制條件

    曾文發電廠最大發電放水量為56 cms，放水量達5500 cms 時，曾文發電廠應停止發電，河道放水道之放水量上限經曾文電廠建議為80 cms。

  4. 預估水庫放水後蓄水狀況

    對水庫運轉分析而言，任何水庫操作演算皆以簡單的質量平衡方程式為基礎，為利用連續性配合任一時段系統輸入與輸出差量須等於系統整體變化之條件，可將系統狀態表示成有限差分形式之連續方程式，即：

    預估水庫放水後蓄水狀況，將連續方程式改寫為：

其中，

=水庫t及t+1時之進水量；

=水庫t及t+1時之放水量；

=水庫t及t+1時之蓄水量。
  5. 人為決策

    根據以上防洪運轉法規與限制條件，且參考閘門及其它出水工限制條件，提供逐時段放水量的上限和下限，由操作者決定逐時刻放水量，進而預估放水後水庫蓄水狀況。


模式簡介

7.1　模式簡介

    所謂即時防洪運轉模擬模式，為仿現地運轉程序，協助現場運轉作業之模式。其與優選模式之差別，在於優選模式為預測情況下，全時段整體的水庫最佳放水策略，而模擬模式則根據即時資訊，逐時段決定水庫最佳放水策略。

    模擬模式的功能，在於提供合理且合法的分析程序。此模式提供完整資訊，使操作者在緊急的情況下，能夠臨危不亂作出適當之決策。若優選模式無法正常運作時，模擬模式亦提供操作者進行必要之分析。


模式分析原理

7.2　模式分析原理

    即時防洪運轉模擬模式中，需考慮水庫物理條件及水庫防洪作業對水庫的影響程度，進而才能決定水庫放水策略。關於模擬模式的分析原理，及現行曾文水庫防洪運轉法規與限制條件茲分述如下：

  1. 最大允許放水量條件
  1. 溢洪道容量條件

        水庫放水量被溢洪道之容許放流量所限制，溢洪道的最大容許放流量即為閘門全開時之自由流量，而曾文水庫溢洪道自由流流量可近似表示如下：

    其中，

            =水庫於 t 時刻蓄水量；

            = t 時刻溢洪道的最大容許放流量。
  2. 防洪運轉規定

        洩洪總放水量超過河道無害流量2,250cms時，最高放水量不得大於流入水庫之最高流量：

        洩洪總放水量超過河道無害流量2250cms時，總放水量之增加率應小於水庫進水量之最高增加率：

        洪峰通過後，水庫水位低於標高230公尺時，水庫可放水量為進水量加上一超放水量：

    其中，

        洪峰通過後，放水量應逐時遞減：

  3. 每單位操作時段放水量限制

    一般情況下，每單位操作時段放水量的最大允許增加量每小時不得超過1,500秒立方公尺：

    t ：一小時操作時段

    特殊情況下，每單位操作時段放水量的最大允許增加量半小時不得超過1,000秒立方公尺：

    t ：半小時操作時段

  2. 最小允許放水量條件
  1. 防洪運轉規定

    放水洪峰通過前，放水量應逐時遞增：

  2. 調整放水量條件

    放水洪峰通過後，放水量不驟降：

  3. 放水量視出水工調整條件
  1. 溢洪道閘門操作規定

        三閘門同時等量運作為原則，必要時得使用一門或二門單獨運轉。使用一座閘門運轉時，應先啟用二號閘門，使用兩座閘門運轉時，啟用二號及三號閘門。

        閘門之開啟，應自最小容許流量開始，一號閘門為250 cms，二號閘門為300 cms，三號閘門為350 cms。溢洪道開始放水之第一小時放水量設定為300 cms。原則上，第二小時放水量定為650 cms，第三小時放水量定為900 cms。總放水量大於900cms，三座閘門應同時操作，並維持同一開度。

  2. 其它出水工限制條件

    曾文發電廠最大發電放水量為56 cms，放水量達5500 cms 時，曾文發電廠應停止發電，河道放水道之放水量上限經曾文電廠建議為80 cms。

  4. 預估水庫放水後蓄水狀況

    對水庫運轉分析而言，任何水庫操作演算皆以簡單的質量平衡方程式為基礎，為利用連續性配合任一時段系統輸入與輸出差量須等於系統整體變化之條件，可將系統狀態表示成有限差分形式之連續方程式，即：

    預估水庫放水後蓄水狀況，將連續方程式改寫為：

其中，

=水庫t及t+1時之進水量；

=水庫t及t+1時之放水量；

=水庫t及t+1時之蓄水量。
  5. 人為決策

    根據以上防洪運轉法規與限制條件，且參考閘門及其它出水工限制條件，提供逐時段放水量的上限和下限，由操作者決定逐時刻放水量，進而預估放水後水庫蓄水狀況。


最佳防洪運轉策略分析

第八章　最佳防洪運轉策略分析

8.1 系統分析
 | 8.1.1 系統分析法
 | 8.1.2 系統分析實施步驟
 | 8.1.3 模式
 | 8.1.4 模式種類
 | 8.1.5 模擬與優選分析
 | 8.1.6 系統分析在水庫管理及水庫操作之應用
8.2 線性規劃
 | 8.2.1 線性規劃基本原理
 | 8.2.2 線性連續趨近法
8.3 最佳運轉策略


8.1.1　系統分析法

    何謂系統？系統乃一組功能性的成份，循許多型式的程序相互作用在一起，部份成份在作用的過程中具有輸入及輸出的特性。系統的運作須遵循物理、生態及其他自然科學的法則。以水庫防洪系統為例，包括輸入的洪水入流量，水庫調節洪水之功能，對閘門之人為控制以放出特定的洩洪輸出量。系統分析(Systems Analysis)在工科領域又稱系統工程(Systems Engineering)，實施上為一種從許多可行的替代方案中選出最佳方案的藝術或科學，內涵包括大量的工程措施以達成決策者的系統整體最佳目標，而同時又受到許多如法令，道德，經濟，資源，政治及社會壓力的限制。因此系統具有包羅廣泛的科際整合特性，分析上需有電腦計算及數學分析的配合，以科學性的定量方法，提供系統內各種成份相互作用結果的資訊，以做為下決策的合理基礎。


8.1.2　系統分析實施步驟

    一般而言實施上可分成下列六個步驟：

  1. 確定問題。闡述需求，包括時空特性及系統的邊界，穿過邊界的外在輸入與輸出變量及系統內部的變量。
  2. 問題分析的目標，亦即簡單地指出分析的目的何在。例如最大效益、最低成本、最可靠或最小風險、最大效率或環境保護，一般均具科際整合的特性。
  3. 定量表示系統的分析目標。例如以貨幣數量衡量經濟性，以生化需氧量或溶氧量衡量環保程度，或對目標(供水)的偏差量。此類量度中往往包含具有取捨性質的多目標特性在內。
  4. 定義可行的替代實施方案。例如水庫的每日放水量有多種選擇，一般均須透過描述系統內部作用特性之模式 (Model) 進行分析，措施上包括政治性與非政治性的。既有模式可協助判定系統有關的資料以利搜集與分析。分析程序上包括模式的檢定及驗證，必要時須進行模式參數的敏感性分析 (Sensitivity Analysis) 以掌握最重要的參數。
  5. 找出最佳的替代方案。方法有試誤法，優選法，取捨分析 (Trade-off Analysis)，多目標分析法。特性上有局部最佳及整體最佳，風險及可靠度等。
  6. 回顧，回饋及修正。系統是動態的，最佳方案為在擬達成某項目標的前提下分析而得，系統目標改變則最佳方案自然亦隨之而變。故往往需回溯前面不同的分析步驟，檢核最佳方案是否仍合理。明確指出最佳方案之限制，假設及分析過程中可能之近似簡化。


8.1.3　模式

    模式為一組法則或規定，用以適當地描述為某特定目的之系統內必要成份的相互作用與反應。故系統分析需透過模式的協助方能進行。下圖為一模式的示意圖：

系統之成份在圖中包括：

u | = |
 | = | 獨立的決策或控制變量，為設計或操作時系統可控制的輸入量。
x | = |
 | = | 系統狀態，為一種特殊的因變量，其值隨系統上一時段(或階段)的狀態而變，掌握此值即可不需考慮過去時段不同控制措施下的系統變化。
x(0) | = | 起始情況 (狀態)。
r | = |
 | = | 獨立的不可控制輸入變量，可能為序率變量。
a | = |
 | = | 參數，其值相當固定，代表系統的某種特性，一般而言不受 u 及 r 值的影響。
b | = | 邊界條件。為系統限制的一種形式，可為物理性、技術性、法律性或財務性者。
y | = |
 | = | 特定的因變量，用以衡量系統目標表現情況的輸出變量。


8.1.4　模式種類

    模式的類別上有判斷型、物理型、類比型、數值型及混合型等。選用能適當描述系統之模式均與所欲從事的分析有關，對系統分析而言，因須進行大量可行替代實施方案的分析，故最常以數值或數學模式來描述系統，透過此類模式的分析，可以不須對實體系統進行試驗。數值模式由一些數學關係式、邏輯運算所組成，用以預測系統在特定輸入下的相關輸出量。此類數學模式又可分為：

  1. 代數型。如下之代數關係式：

(8.1.4-1)

例如在水庫操作上為表示水量守衡的連續方程式：

(8.1.4-2)

(蓄水量) | (放水量) | (蒸發量) | (入流量)
狀態變量 | 決策變量 | 因變量 | 不可控制的輸入量
  2. 微分、積分或微分-積分型。

(8.1.4-3)

實際分析上常將之差分化以利分析。

  3. 定率或序率型。例如以機率表示歷史的入流量特性，以進行成本或效益的期望值分析。
  4. 理論型式或經驗型。例如來自質量守衡的連續方程式：
(8.1.4-4)

或經驗型式的合理化公式：

(8.1.4-5)
  5. 靜態型與動態型。指系統隨時間演進與否。
  6. 物理型或行為型。例如用以預估用水需求變化需採用行為型模式。
  7. 集塊型或分佈型。例如單位歷線分析法，或史丹福集水區模式。

以下為模式二例：

例一：

(8.1.4-6)

    式中，

= 已知的起始蓄水量 ；
；
；
；
   = 月蒸發係數，為一參數；
= 水庫水面積。

例二：

(8.1.4- 7)

    式中， [image] 目標供水量。

    就上述二例中所用到的變量，依模式成份之定義可綜合如下：

，放水量，為獨立(非系統內部)的可控制輸入變量；

，獨立不可控制的輸入變量， [image] 為外在變量；

，亦稱系統狀態變量，為一因變量；

，起始情況，此地為水庫起始蓄水量；

，每月之蒸發係數，為一參數；

，邊界條件；

    模式之主體或變量間的作用關係有下列三式：

(8.1.4-8)

(8.1.4-9)

(8.1.4-10)


8.1.5　模擬與優選分析

    找出最佳替代方案的分析方法，及相關所用以分析的模式，可概分為模擬與優選二類。模擬模式用以回答描述性的「假如…，則…」型式問題，其優點為能精確地預測與進行細部的模式分析；故富彈性且具有廣泛的可接受性。但缺點為不能直接求得問題的最佳解；如果有許多可能的替代方案需要分析，則須以試誤法進行模擬，一般而言分析成本甚高。實例上有：HEC-1至 HEC-6；QUAL-IIE；SWMM；HSP；SSARR；SEA AR；Thomas-Fiering 等模式。

    優選模式亦含有某種程度的模擬在內，其意義上為採用一種有系統的方法去找出最佳的管理或操作方案，而不需以試誤法去考慮或分析所有的可行方案。優點為能指出最佳解，同時可自動產生其他狀況下的最佳替代方案。缺點為模式架構受限於計算方法，一般在實體系統的模擬上均不甚詳細，另方面對規劃管理者而言較不具直覺上的意義。其分析的型式均表成一標的函數及對最佳解的一些限制式如下：

  1. 標的函數：
(8.1.5-11)
  2. 限制式：
(8.1.5-12)

式中 f(x,u) 即模式中的輸出變量函數 y，其值為一純量。而 g 函數即為某種型式的模擬模式。一般常用的優選技術 (Optimization，或數學規劃法) 有：線性規劃，網流模式，動態規劃，非線性規劃，序率規劃，多目標或多準則優選分析法等。


8.1.6　系統分析在水庫管理及水庫操作之應用

    下表列出系統分析在水庫管理及操作上的應用特性：

項目 | 管理 | 操作
問題 | 在既有設施下，調節系統以達成最佳營運，例如最小衝突。 | 在既有設施下，短期內儘可能達成整體的營運管理目標。
範疇 | 中期至長期：5至30年；分析時距為月、季或年；空間範圍為全流域或局部流域。 | 短時程，如一日至一年；分析時段為分、時、日或月；局部流域或個別設施。
營運目標 | 符合多種規劃標的；可靠度或風險；最大經濟報酬；可靠供水量或發電量。 | 使與管理目標之偏差量最小；安全、效率、可靠。
量度標準 | 經濟；生化等。 | 絕對偏離量，或偏離的最小二乘方量。
實施方案 | 整合一複雜營運系統內之調節時程；使用長期氣候預報。 | 在管理指標的整體基礎上，進行對個別設施的即時 (Real-time) 調節。
分析模式 | 動態且較詳細；若能使用較詳細的序率模式最為理想；中尺度至大尺度；在時段為月、季或年下，分析得系統內所有設施的營運決策。 | 最為詳盡。例如：採用變量流模式；最理想者為具有即時資訊處理的序率模式，能作預測與控制；完全動態的分析得到在短時段內詳細的決策。

度的複雜系統，或在各項標的競爭用水及水權優先的衝突情況。


8.2.1　線性規劃基本原理

    系統分析常應用數學規劃（mathematical programming）法以求取優選策略，也就是在所有可行方案中，選取可達到最好目標者。規劃法中的線性規劃是20世紀中期開始發展的科學，線性規劃模式中的所有方程式及函數都是線性的，所以應用最為廣泛。線性規劃有個非常高效率的解題方法，稱為單純法（simplex method），可用來解決任何尺度線性規劃的問題。

    此下以一水庫為符合供水合約要求之營運分析為例，介紹線性規劃之應用。如圖所示之系統：

    考慮下游地區的週期性用水需求可以表示成下式：

(8.2.1-1)

式中，

t | = | 時段指標；
 | = | 年需水總量；
 | = | 各時段之用水係數。

    系統營運上的其他限制條件包括：

(1) [image] (8.2.1-2)

(2) [image] (8.2.1-3)

(3) [image] (8.2.1-4)

(4) [image] 已知；

(5) 所有變量均 [image] 。

上述諸式中，

T | = | 分析時段總數；
 | = | 水庫蓄水量 [image] ；
 | = | 水庫起始蓄水量；
 | = | 營運分析的期末蓄水；
 | = | 水庫入流量；
 | = | 水庫蒸發量，須經疊代計算；
， | = | 水庫的最大及最小蓄水量；
 | = | 放水量 [image] ；
 | = | 缺水量；
 | = | 超供水量；

而且 [image] ，亦即此二水量僅有一量有值，另一量必定為 0。

    根據不同的管理目標，水庫營運分析的標的函數可能有下列三種選擇：

1. 標的函數 #1 ： 希望相對於目標供水量的總缺水量為最小。

(8.2.1-5)

2. 標的函數 #2 ： 使總缺水量為最小。

(8.2.1-6)

3. 標的函數 #3 ： 儘量減低最大的供水偏差量

(8.2.1-7)

    上述之標的函數 #3 具有平均供水偏差的效果，相當於一平滑化 (Smooth) 之標的函數如下式：

(8.2.1-8)

    此式將「懲罰」較大的缺水量值，但相對於標的函數 #3，需先進行線性化的處理，方能應用線性規劃求解。

    茲採用標的函數 #3 進行分析，其可行解的限制條件可整理如下：

(8.2.1-9)

(8.2.1-10)

(8.2.1-11)

所有變數 (8.2.1-12)

(8.2.1-11) 式亦可寫成下列二式：

(8.2.1-13)

(8.2.1-14)

    問題中諸變量在分析上之類別為：

  1. 已知變量有： 、 [image] 、 [image] 、 [image] 、T、 [image] (=0)、 [image] 。
  2. 未知目標函數值：C = 為最大的供水偏差量。
  3. 未知的因變量有： 、 [image] 。
  4. 未知的決策變量有： 。

對一3時段的營運分析問題，將 (8.2.1-7)、(8.2.1-9)、(8.2.1-10)、(8.2.1-13)、(8.2.1-14) 諸式表成矩陣型式如下表，即可以線性規劃求解：

MIN | 0 | 0 | 0 | 0 | 0 | 0 | 1 | = | Z
變數: | X1 | X2 | X3 | X4 | X5 | X6 | X7 |  |
 | Q1 | V2 | Q2 | V3 | Q3 | V4 | C |  | b
 | 1 | 1 |  |  |  |  |  | = | I1 - EVAP1 + V1
 |  | -1 | 1 | 1 |  |  |  | = | I2 - EVAP2
 |  |  |  | -1 | 1 | 1 |  | = | I3 - EVAP3
 |  | 1 |  |  |  |  |  |  | Vmax
 |  |  |  | 1 |  |  |  |  | Vmax
 |  |  |  |  |  | 1 |  |  | Vmax
 | 1 |  |  |  |  |  | 1 |  | D1
 |  |  | 1 |  |  |  | 1 |  | D2
 |  |  |  |  | 1 |  | 1 |  | D3
 | 1 |  |  |  |  |  | -1 |  | D1
 |  |  | 1 |  |  |  | -1 |  | D2
 |  |  |  |  | 1 |  | -1 |  | D3

上表中的已知值均出現在方程式右方 (Right Hand Side, RHS)，線性規劃將求得方程式左方所有未知變量的最佳解與最小之標的函數值。

    線性規劃法使用簡便，計算效率高，商用的電腦套裝軟體，例如LINDO、MINOS等極為普遍，超過半數以上的水資源規劃與管理問題皆可套用線性規劃求解。但線性規劃的缺點及限制則有：

  1. 對隨時段動態演進的問題，上表會形成寬鬆矩陣 (Sparse Matrices) ，而線性規劃若以使用普及的簡繁法 (Simplex Method) 求解，其計算時間隨矩陣之行數與列數乘積成二次方增加，故有計算時效的問題。
  2. 方程式中的非線性項必須先經線性化處理，或以連續線性近似法分析，但對非凸型的函數則可能難以求得整體最佳解 (Global Optimum)。
  3. 不易明確地納入風險及不確性的分析在內。
  4. 對整數值的變量或離散決策型態的問題並不適合，此二類問題宜採用整數規劃或動態規劃分析。


8.2.2　線性規劃連續趨近法

    並非所有規劃的問題都能適用線性規劃模式，當一個或多個線性規劃的假設不成立時，就只好改用其它數學規劃模式，譬如，整數規劃或非線性規劃。惟線性規劃亦可用連續趨近法來處理限制式中的非線性項，線性規劃連續趨近法為疊代法的一種，其求解程序係利用一階泰勒級數展開法，將非線性項近似取為線性項，並定出一起始可行解代入分析，再由分析所得結果疊代至上述起始可行解中，直到分析所得結果與起始可行解近似為止。

    例如在水庫防洪運轉分析中，主要之非線性函數為溢洪道的放水堰流公式，並不能直接運用於線性規劃分析，因此可運用線性規劃連續趨近法處理。首先將此非線性方程式做一階泰勒級數展開：

(8.2.2-1)

式中 [image] 為 [image] 的假設近似值。

??由於上式將非線性方程式近似為一次的線性方程式，因此可將此式置入線性規劃模式中加以遞迴分析，將分析得出的 [image] 值疊代回原式中的 [image] 值中，再對整體線性規劃模式加以求解，重覆此步驟直至 [image] 為止，此時分析所得的結果即為系統的最佳防洪操作策略。


參考文獻

  1. American Society of Civil Engineers, "Hydrology Handbook", Second Edition, ASCE Manuals and Reports on Engineering Practice No. 28, New York (1996).
  2. Burton, J. R., W. A. Hall, and D. T. Howell, "Optimal design of a flood control reservoir", Congr. Int. Ass.Hydrol. Res., 10(2), pp. 1-8, 1963.
  3. Can, E. K. and M. H. Houck, "Real-Time Reservoir Operations by Goal Programming", Journal of Water Resources Planning and Management, ASCE, 110(3), pp. 297-309, 1984.
  4. Chou, Frederick N.-F. and Der-Yung Chen, "Flood Mitigation through Joint Flood Control of Parallel Reservoirs", Urban Disaster Mitigation: The Role of Engineering and Technology, F.-Y. Cheng and M.-S. Sheu eds., Elsevier Science, Oxford, England, pp.275-286, 1995.
  5. Dingman, S. L., "Physical Hydrology", Macmillan Publishing Company, New York (1994).
  6. Grygier, J. G. and J. R. Stedinger, "Algorithm for Optimizing Hydropower System Operation", Water Resources Research, 21(1), 1-11, 1985.
  7. Mays, Larry W. and Yeou-Koung Tung, "Hydrosystems Engineering & Management", McGraw-Hill, 1992.
  8. Sevruk, B., Methods of correction for Systematic Error in Point Precipitation Measurement for Operational Use, WMO Operational Hydrol. Rept 21, WMO publ. 589 (1982).
  9. Shaw, E. M., "Hydrology in Practice", Third Edition, Chapman & Hall, London (1994).
  10. Smith, K. Principles of Appled Climatology, McGraw-Hill (1975).
  11. Wasimi, S. A. and P. K. Kitanidis, "Real-Time Forecasting and Daily Operation of a Multireservoir System During Floods by Linear Quadratic Guassian Control", Water Resources Research, 19(6) , 1511-1522 , 1983.
  12. Windsor, J. S., "Optimization Model for the Operation of Flood Control Systems", Water Resources Research, 9(5), 1219-1226, 1973.
  13. Winter, T. C. Uncertainties in Estimating the water balance of lakes. Water Resources Bulletin 17:82-115 (1981).
  14. 中興工程顧問社，「淡水河，石門水庫及翡翠水庫防洪聯合作業研究報告」，民國75年3月 (1986)。
  15. 王如意、易任，「應用水文學新編上冊」，國立編譯館，臺灣，台北，第 83 - 84 頁，民國 80 年 1 月。
  16. 吳建民，「曾文水庫防洪運轉之檢討 (一) (二)」，工程月刊，55 卷4、5期，民國71年4、5月 (1982)，pp. 223-235、pp. 316-331。
  17. 周乃昉，「曾文水庫在緊急情況下運轉操作之探討研究，第二部份：防洪運轉分析及其規則之檢討修訂」，農業工程研究中心，民國 82 年。
  18. 周乃昉、徐享崑、林佳珍，「水庫之蓄水機率分佈及供水可靠度」，八十三年度農業工程研討會論文集，臺灣，高雄，pp. 59~69，1994。
  19. 周乃昉、楊森弼，「水庫運轉對下游河道流量影響之研究(一)：洪水流量」，國立成功大學水利及海洋工程學系所，NSC 85-2211-E-006-061，1996。
  20. 周乃昉、楊豐榮、鄭子璉、鄭志偉，「曾文水庫即時防洪運轉分析模式之研擬」，第二屆環境系統分析研討會，臺灣，台南，第 329 - 335 頁，民國 88 年 12 月。
  21. 易任，「渠道水力學（下）」，東華書局，台北 (1987)。
  22. 易任譯，「水文工程學（下）」，東華書局，台北 (1987)。
  23. 金維仁，「水庫群最佳聯合防洪操作分析方法之比較」，碩士論文，國立成功大學水利及海洋工程研究所，民國 84 年。
  24. 陳德源，「最佳控制理論在並聯水庫防洪操作之應用」，碩士論文，國立成功大學水利及海洋工程研究所，民國 82 年。
  25. 楊森弼，「防洪運轉起始水位對水庫調洪之影響」，碩士論文，國立成功大學水利及海洋工程研究所，民國 85 年。
  26. 黎明工程顧問有限公司，「曾文水庫大壩安全評估計畫(上冊)」，委託機關：台灣省南區水資源局(1998)。
  27. 簡俊彥、郭玉珍、黃月娟，"曾文水庫操作運轉對下游流域影響之研究"，台灣省水利局 73 年度研究發展計劃，民國 74 年 2 月 (1985)。
  28. 黃慶銓，「水庫構造與維護管理」，台灣省水利局，水庫放水安全操作講義，農發會71農建－1.3－源－046，pp.28-49，中華民國七十一年元月。
  29. 吳憲雄，「水庫營運」，台灣省水利局，水庫放水安全操作講義，農發會71農建－1.3－源－046，pp.50-56，中華民國七十一年元月。
  30. 陳茂生，「水庫放流(洩洪)與安全措施」，台灣省水利局，水庫放水安全操作講義，農發會71農建－1.3－源－046，pp.57-88，中華民國七十一年元月。


最佳防洪運轉策略分析

附錄一　線性規劃法演算例

A1.1　最佳防洪運轉策略分析

    有一水庫之防洪操作如下圖所示，

操作時段總數為3，水庫的最大蓄洪容量為 Xmax ，水庫之入流量為 I1 、 I2 、 I3 ，水庫之放流為 u1 、 u2 、 u3 ，河道下游某參考控制點之目標控制流量為 T = 20 ，忽略壩下游河道之洪水演算，操作目標是調節水庫洩洪流量以使其儘量接近下游控制點的目標流量。若起始蓄水量為 0，請求解最佳的水庫放流量過程 u 。其他有關資料如下：

=[20, 37.5, 10]； =[40, 40, 40]； =[15, 15, 15]

    水庫在時段 k 蓄水之連續方程式，亦即系統之狀態方程式為

；k = 1, …, n (A1-1)

其他的限制條件有控制變量的可行解區間：

(A1-2)

及狀態變數的可行解範圍：

(A1-3)

    茲將防洪操作目標表成一最小偏差的標的函數如下：

Minimum C (A1-4)

    可得到最佳解為：

=[20, 22.5, 22.5]

=[0, 0, 13.75, 15]

    而標的函數之數值則為：

C = 3.75。

A1.2　計算範例解答

    在 A2.1 節中討論的例題以風雨災害實驗室線上網站操作說明，網站的位置為 http://feitsui.hyd.ncku.edu.tw/Hazard/study/operate/Apdx01/LineProg.htm ，如圖 A1.1 ，由於線性規劃的各變量必須大於等於 0 ，因此輸入限制式時將省去大於等於 0 的條件，依水庫條件所需之線性規劃限制式如表 A1.1。

    經演算後，如圖 A1.2，將線性規劃計算結果列於表 A1.2 ，第 1 列為目標函式最小成本，第 2 ~ 9 列為各變量的最佳解，第 10 ~ 24 列為滿足各不等式為等視之變量，第 25 列為線性規劃累算次數。

表 A1.1　依水庫條件所需之線性規劃限制式

輸入限制式 | 限制式代表意義
MIN C SUBJECT TO X0 = 0 U1 <= 40 U2 <= 40 U3 <= 40 X1 <= 15 X2 <= 15 X3 <= 15 U1 - C <= 20 U2 - C <= 20 U3 - C <= 20 - U1 - C <= - 20 - U2 - C <= - 20 - U3 - C <= - 20 X1 - X0 + U1 = 20 X2 - X1 + U2 = 37.5 X3 - X2 + U3 = 25 | 目標函式誤差量 C 為最小 限制式 水庫期初蓄水量為 0 水庫放水量各階段小於 40 水庫蓄水量各階段小於 15 水庫放流各階段減誤差小於目標控制流量 水庫放流各階段加誤差大於目標控制流量 現在蓄水減前一階段蓄水加水庫放流等於水庫入流

表 A1.2　線性規劃計算結果

1 | 最小成本 | 3.75
2 | x0 | 0
3 | u1 | 20
4 | u2 | 23.75
5 | u3 | 23.75
6 | x1 | 0
7 | x2 | 13.75
8 | x3 | 15
9 | c | 3.75
10 | u1 <= 40 | 20
11 | u2 <= 40 | 16.25
12 | u3 <= 40 | 16.25
13 | x1 <= 15 | 15
14 | x2 <= 15 | 1.25
15 | x3 <= 15 | 0
16 | u1 - c <= 20 | 3.75
17 | u2 - c <= 20 | 0
18 | u3 - c <= 20 | 0
19 | - u1 - c <= -20 | 3.75
20 | - u2 - c <= -20 | 7.5
21 | - u3 - c <= -20 | 7.5
22 | x1 - x0 + u1 = 20 | 0
23 | x2 - x1 + u2 = 37.5 | 0
24 | x3 - x2 + u3 = 25 | 0
25 | 計算次數 | 6

圖 A1.1　網站計算範例輸入畫面

圖 A1.2　網站計算結果輸出畫面


附錄二　相關法規

A2.1　水利法

第 | 四十八 | 條 | 防水、引水、蓄水、洩水之建造物，如有水門者，其水門啟用之標準、時間及方法，應由興辦水利事業人預為訂定，申請主管機關核准並公告之，主管機關認為有變更之必要時，得限期令其變更之。
第 | 六十五 | 條之一 | 洪水期間，有閘門之水庫洩洪前，水庫管理機關應通知有關機關採取必要防護措施。
第 | 六十九 | 條 | 實施蓄水或排水，致上下游沿岸土地所有權人發生損害時，由蓄水人或排水人，予以相當之賠償，但因不可抗力之天災所發生之損害，不在此限。
第 | 七十一 | 條 | 減水閘壩啟閉之標準，水位或時間，由主管機關報請上級主管機關核定公告之。

A2.2　水利法施行細則

第 | 一百零六 | 條 | 本法第六十四條所稱洪潦，係指洪水與積潦。
 |  |  | 水道流量漲至超過其水道可能容洩之限度，足以溢決泛濫成災之大水為洪水。降雨或融雪停滯於地面足以浸淹為害之積水為積潦。
第 | 一百十三 | 條 | 本法第六十九條所稱蓄水人，係指控制、運轉、維護、管理或創建蓄水用之堰壩之人。
第 | 一百十七 | 條 | 凡因蓄水或排水發生損害，其賠償數額雙方無法協議時，得申請主管機關查勘實際情形核定之。
 |  |  | 不服主管機關核定之賠償額者，應於收受核定通知後三十日內向該法院起訴。
第 | 一百二十四 | 條 | 有閘門之水庫於洪水期間，其最高放水量不得大於流入水庫之最高流入量。水庫放水流量之增加率，不得超過該水庫流入量之最高增加率。
 |  |  | 前項放水流量，在水庫下游設有下池或相當於下池功能之設施，供以調節上游水庫放水者，為調節後之放水流量。
第 | 一百二十六 | 條 | 各級主管機關，得通知蓄水人保持並提供水庫之運轉維護記錄，以保障公眾生命及財產之安全。
第 | 一百二十八 | 條 | 在發生特殊洪水或災變，危及蓄水庫安全，或在情況危殆，嚴重威脅公眾生命及財產之安全時，蓄水人或管理機構，除應通知該管主管機關外，並應立即採取適當緊急措施，於事後將辦理情形報請主管機關核備。
第 | 一百三十一 | 條 | 水庫計畫之申請書，應記載左列事項：
 |  |  | 一、蓄水人姓名或名稱及住(地)址。
 |  |  | 二、計畫壩址及附屬設施之地點、型式、大小及高(深)度。
 |  |  | 三、水庫壩址地質調查報告。
 |  |  | 四、水庫之蓄水容量、面積及運轉計畫。
 |  |  | 五、蓄水及引水之使用目的。
 |  |  | 六、集水區之面積、雨量、堰壩之流量及洪水量紀錄以及洪水估計。
 |  |  | 七、水庫計劃用地及地上物處理計畫。
 |  |  | 八、如係改造者，應說明有關工程項目及目的。
 |  |  | 九、施工計畫及集水區水土保持計畫。
 |  |  | 十、環境影響評估報告。


附錄三　水庫防洪運轉法規

    國內水庫運用規則及相關水利法規等詳細規範，可透過經濟部水利處網站取得，相關網址為水利法規資料庫 (http://www.wca.gov.tw/law/) ，教材內摘錄部分為相關防洪運轉部分。

A3.1　臺灣省曾文水庫運用規則
A3.2　臺灣省石門水庫多目標運用規則
A3.3　臺灣省鯉魚潭水庫運用規則
A3.4　立霧壩及取水口操作規則
A3.5　立霧壩重大地震、超級颱風及水庫（壩）崩塌時之緊急操作規則


A3.1　臺灣省曾文水庫運用規則

第三章　防洪運轉

第 | 十四 | 條 | 本水庫有下列情事之一時應開始防洪運轉： 一 颱風或豪雨情況時水庫水位超過標高二百二十五公尺或水庫水位及水庫進水量達到附表二之水庫水位及水庫進水量。 二 非颱風或豪雨情況時，水庫水位超標高二百二十七公尺或水庫水位及水庫進水量達到附表三之水庫水位及水庫進水量。
第 | 十五 | 條 | 防洪運轉時，應依下列規定操作溢洪道閘門： 一 閘門之開啟，應自最小容許流量開始，一號閘門為二百五十秒立方尺，二號閘門為三百秒立方公尺，三號閘門為三百五十秒立方公尺。 二 閘門之開度每小時得調整一次，每次調整增加之洩洪總流量不得超過一千五百秒立方公尺。颱風或豪雨情況下可視情況每三十分鐘調整一次，每次調整增加之洩洪總流量不得超過一千秒立方公尺。 三 溢洪道流量大於九百秒立方公尺時，三座閘門應同時操作，並維持同一開度。 四 使用二座閘門運轉時，應先啟用二號及三號閘門，使用一座閘門運轉時，應先啟用二號閘門。
第 | 十六 | 條 | 防洪運轉時，水庫之放水量應依下列規定： 一 在洪峰未過前，洩洪總流量超過二千二百五十秒立方公尺時，洩洪總流量之增加率應小於水庫進水流量之最高增加率，洩洪總流量應小於最大進水流量。水庫水位超過標高二百三十公尺，或水庫水位及水庫進水量達到附表四之設計洪水情況時，即以最大容許放水量放水。 二 洪峰過後，水位低於標高二百三十公尺，洩洪總流量不得大於進水流量加上附表五之增放水量，且不得大於進水流量之洪峰。
第 | 十七 | 條 | 本水庫有下列情事之一時，應停止防洪運轉： 一 洪峰已過，水庫水位未超過標高三百二十七公尺，且水庫水位及水庫進水量低於附表六之水庫水位及水庫進水量。 二 依十四條第一款規定開始之防洪運轉，洪峰未過，水庫水位未超過標高二百二十五公尺且水庫水位及水庫進水量低於附表二之水庫水位及水庫進水量。 三 依第十四條第二款規定開始之防洪運轉，洪峰未過，水庫水位未超過標高二百二十七公尺且水庫水位及水庫進水量低於附表三之水庫水位及水庫進水量。 四 依第十四條第一款開始之防洪運轉，於颱風或豪雨情況解除後，進水流量及水庫水位無同條第二款及緊急情況之情事。
第 | 十八 | 條 | 南水局應於溢洪道洩洪開始一小時前，由該局將洩洪量迅速有效向下游地區發布洩洪警報，並以電話通知經濟部水利處及其轄區內警察機關，迅速轉知下游居民，開始洩洪運轉之第一小時，並應以最低容許洩洪量洩放，以示警告。
第 | 十九 | 條 | 防洪運轉時，洩洪總流量達五千五百秒立方公尺時，曾文發電廠應停止發電。
第 | 二十 | 條 | 防洪運轉時，為排除進水口附近淤砂，得使用河道放水道放水。
第 | 二十一 | 條 | 東口導水堰排砂閘門有下列情事之一時應予開啟： 一 沖除泥砂或淤積之雜物。 二 防洪運轉。 三 因地區性陣雨使到達東口導水堰之流量超過東口進水口之最大容許進水量。 四 依第十條第一項但書規定在東口溢流時。 五 供應下游用水。


A3.2　臺灣省石門水庫多目標運用規則

第五章　防洪運用

第 | 十八 | 條 　 | 每年自六月一日至九月三十日為防洪運用期間，在此期間內第一次洪水來臨前，水位應儘可能降至規線上限標高以下，如水位因攔蓄洪水而升高至標高二百四十公尺以上時，在次一洪水來臨前，應儘可能降低至標高二百四十公尺以下。但八、九月份，在中央氣象局預測颱風有襲臺可能時，水位以溢洪道洩降至標高二百三十七•五公尺，再利用發電及永久河道放水口洩放，儘可能降至標高二百三十七•五公尺以下。
第 十九 條 　 本水庫在遇有颱風來襲時，北水局應依下列規定執行防洪作業：
一　颱風警報發布後：
  1. 水庫管理中心運轉課〈以下簡稱運轉課〉應根據氣象單位提供之颱風動態資料，繪製颱風動態紀錄圖，並將其動態呈報局長及水庫管理中心主任，同時通知有關單位。
  2. 運轉課應將颱風動態轉告石門電廠閘門操作組，並與其密切聯繫查核各項閘門設施、操作電源、緊急發電機、通信電話等運轉情況，俾免臨時故障，無法使用。
  3. 管水組養護課〈以下簡稱養護課〉應派人員，加強水庫各項工程結構物之維護觀測及檢查。

二　警報預測颱風將於六小時內侵襲本省時：

  1. 運轉課應加強與氣象單位聯繫。
  2. 運轉課應根據各氣象單位提供之各種氣象資料、颱風行徑等，研判該颱風對本水庫可能發生之各種情況，辦理水庫防洪運用之各種計算。
  3. 運轉課應增派人員參加日夜輪值。

三　警報預測颱風將於三小時內侵襲本省時：

  1. 水庫管理中心主任直接指揮督導水庫防洪運用。
  2. 養護課應增派維護觀測人員，加強各重要結構物及隧道內滲漏水量之監視，並隨時校核派駐工區各工作崗位人員之動態。
  3. 運轉課應與各水利會聯繫，停止各渠道灌溉用水之洩放，並研擬運用方案。
  4. 運轉課課長督導水文資料之分析研判。

四　颱風侵襲本省時：

  1. 運轉課派員駐守溢洪道閘門控制室，會同閘門操作組人員機動檢視溢洪道閘門之操作，必要時，得傳遞水位、洩洪資料或代水庫管理中心主任簽發操作命令。
  2. 運轉課應隨時根據氣象及水文資料予以分析研判，估計尖峰洪水流量，流量過程曲線及洪峰到達石門之時間。
  3. 計畫組資訊課應隨時與經濟部水利處〈以下簡稱水利處〉密切聯繫，將石門下游各溪流及臺北地區水文狀況，呈報水庫管理中心主任作為防洪運用之參考。
  4. 運轉課應研擬運用方案呈報核備。
  5. 水庫管理中心主任應根據運用方案，決定水庫洩洪之時間及流量，正常時水庫運用操作命令之下達，均須經水庫管理中心主任之認可，以書面送達閘門操作組。

前項颱風警報，以中央氣象局發布之消息為準。
第 | 二十 | 條 　 | 本水庫如有洩洪必要時，應在洩洪一小時以前將洩洪時間及可能洩洪量由水庫管理中心主任或運轉課課長，並通知水利處及桃園縣警察局防救中心。但為每秒六百立方公尺以下之調節性放水時，得不予通知。 水利處接獲北水局洩洪通知後，應即轉知警察暨新聞機關、台北市政府工務局及台北縣政府工務局，洩洪開始後水利處及北水局，仍應隨時密切聯繫，並由水利處將水庫洩洪情況繼續轉知上列各有關機關。
第 二十一 條 　 本水庫溢洪道閘門之操作，應按控制洩放及超高攔蓄方法為之，並遵守下列規定：
一　在確知上游洪水暴雨來臨後，即開啟閘門，將蓄水先行部分控制洩放，並利用閘門開啟後其頂高較啟開前超過部分增加攔洪量。
二　洩洪流量應視當時水位及進水流量，按溢洪道閘門操作關係曲線決定之。
三　進水流量以單位時間內水位昇高率推定之。
四　溢洪道閘門之操作，以六扇閘門同時開啟為原則。
五　溢洪道閘門之開度，以○•六公尺為起點，每隔○•三公尺為一級。
前項溢洪閘門操作關係曲線如附圖二。


A3.3　臺灣省鯉魚潭水庫運用規則

第三章　洪水運轉

第 | 十 | 條 | 本水庫溢洪道無閘門控制，水位超過標高三百公尺時，自然溢流。
第 | 十一 | 條 | 本水庫之洪水運轉係指颱風時降雨或非颱風時期豪雨發生時之水庫運轉，洪水運轉應符合下列原則： 一 不得超過流入本水庫之尖峰流量。 二 在不影響蓄水利用運轉功能之原則下，協助減輕景山溪下游之洪水災害。
第 | 十二 | 條 | 本水庫下游後池堰，在裝設閘門前，其水位超過排砂道堰頂標高二百零二公尺及溢洪道堰頂標高二百零六•一公尺時，以自然溢流方式調節上游放水。


A3.4　立霧壩及取水口操作規則

丙、颱風警報期間操作

一 、 海陸上颱風警報發佈後，如天氣良好時可先全力運轉，否則七座排洪門應即全開，如遇操作電源發生故障時，應運用一切可能辦法 (包括人力操作) 將全部排洪門開啟。
二 、 海陸上颱風警報發佈後，發電廠應即派值班主任一人及短工若干人進駐溪畔增援，並派水路維護員一人及短工二人進駐砂卡礑進水口應變。
三 、 本廠於颱風來襲期間繼續由砂卡礑支流取水發電外，視颱風半徑在二小時以內將扺達時，溪畔取水口即作如下緊急操作：
  1. 壩排砂門全開。
  2. 取水口制水門關閉停止取水，但為避免取水庭積砂予留開度 20 公分由沈砂池前排洪門排砂。
  3. 沈砂池排洪門全開。
  4. 沈砂池取水口全閉。
  5. 沈砂池送水門排砂門全閉。
四 、 電訊不通時，派駐取水口值班主任，視情況輕重，得依丙項第 (三) 條之規定執行操作。
五 、 配電線或柴油機之水門操作電源任一發生故障時，除照乙項第 (五) 條操作外，不問颱風是否在二小時內到即執行操作，電源全部故障時，即利用手動操作。

註：本「立霧壩及取水口操作規則」，係台灣電力公司立霧發電廠現所遵行，民國80年9月16日修訂。


A3.5　立霧壩重大地震、超級颱風及水庫（壩）崩塌時之緊急操作規則

一、重大地震

    重大地震應屬於七級以上之地震，目前地震發生之正確時間尚無法預測，通常氣象局均依資料判斷，只能推測可能有地震或重大地震將發生提供注意。

    無論如何我們應事先作好防患工作是必要的，平時即該假想有重大地震之災害，訂定防患措施以防不測。

(一) 發電設備 (包括水輪發電機、主變壓器、油斷路器等) 之操作

  1. 水輪發電機解聯停機 (依水輪發電機解聯停機操作標準執行操作) 啟斷 #110.#120，#1.2 機停止。
  2. 前池排砂門全開，#1.2 制水門關閉，水壓鋼管放水 (依水輪機大修停機操作標準執行操作) 以防水壓鋼管受震斷裂沖毀電廠。
  3. 停止 #1.2 主變壓器加壓 (依 M.Tr 停電操作標準執行操作)、啟斷 #710.#720 O.C.B。
  4. 溪畔壩排洪門開啟，降低水庫 (調整池) 水位在標高 157.5 公尺以下，以減少水壩負荷，避免水壩崩塌。
  5. 電訊暢通時，上列各項操作應隨時向調度處報告。
  6. 將災害情況向廠長報告，並通知運轉組召集人員待命準備搶救工作。

(二) 運轉人員之安全與逃生

  1. 廠區所有人員均應佩戴安全帽及安全鞋待命。
  2. 屋外工作人員唯恐高山坍方，應疏散至安全地區待命。
  3. 廠內運轉人員如發現廠房已有龜裂或崩塌現象時，情況許可時先照前 (一) 發電設備之操作標準執行，並嚴防火災發生，將災害情況報告調度處，並向廠長報告後準備逃生。
  4. 緊急且有人命危險時，作全停電操作，將 #110 #120 作緊急機處理，並將 O.B.C #620. #630. #640 切開與系統斷聯而後即刻逃生。
  5. 人員逃生時，應攜帶急救藥品、手電筒、水壺、乾糧等以防不測 (上項物品平時均應準備使用)。
  6. 逃生前盡可能通知有關單位及廠長。
  7. 萬一人員有受傷時，應即時設法通知救護隊支援。

二、超級颱風

    超級颱風應屬風速每秒七十公尺以上之颱風，目前氣象報告均非常準確，本廠之各項設備應在陸上颱風警報發佈前，依本廠防颱防洪措施作好對策，在陸上颱風警報發佈後，所有員工在接到電廠指令通知後，即刻回廠待命。

    但是超級颱風時溪畔壩必須在海陸上颱風警報發佈後，並有可能登陸跡象時操作之。如天氣良好時可先全力運轉，否則七座排洪門應即全開，如遇操作電源發生故障時，應運用一切可能辦法 (包括人力操作) 將全部排洪門開啟。

(一) 海上颱風警報發佈後

  1. 溪畔壩、砂卡礑壩，儘速派員進駐待機應變。
  2. 通訊不良時授權進水口待機人員判斷當前情形，儘速操作關閉制水門，並啟開排砂門。
  3. 砂卡礑壩如因山路崩塌、人員無法前往或豪雨已到達時，應待能通行後，再行前往砂卡礑壩操作水門以策安全。
  4. 廠內柴油發電機試運轉，尤其砂卡礑壩、溪畔壩柴油發電機，確認良好。
  5. 赴砂卡礑壩待機應變人員，應隨身攜帶無線電對講機並尋找適當之地點試話、手電筒、急救藥品、乾糧及防寒衣物，返程若遇山崩時不能冒險，應設法尋找安全之處所避難。
  6. 操作人員應隨時與電廠保持聯絡，尤其颱風動態之聯繫。
  7. 操作人員應將操作情況及路況報告電廠。

(二) 陸上颱風警報發佈後

  1. 本廠 #1.2 機繼續運轉，調整池 (水庫) 水位保持在 157.5 公尺以下。
  2. 洪水來臨時 (依排洪 (砂) 操作規則執行操作)，七座排洪門均依序 #3、#2、#1、#4、#5、#6、#7順序開啟，以調節水位供發電。
  3. 配電線或柴油機之電源任一發生故障，應即全開排洪門及排砂門停止取水，若電源全部故障時，即利用手動操作。

三、水庫 (調整池) 崩塌時

    水壩 (庫) 崩塌之可能有重大地震，颱洪期之不良操作引起或天災地變、以及人為破壞等。

  1. 任何時期水壩 (調整池)崩塌時、均依本廠水壩排洪 (放水) 操作規則及安全措施辦法聯絡有關單位。
  2. 溪畔壩 (調整池) 或沈砂池，發生山崩時應迅速停止送水，並設法通知發電廠。
  3. 於廠區應以擴大器廣播水庫排放水或崩塌情況，如必要時派車沿線廣播。
  4. 平時水壩下游各河床通路裝設警告牌，禁止人員下河。
  5. 如情況緊急，水壩值班人員有生命危險時，應設法逃生並以 (VHF) 與電廠聯絡。
  6. 將災害情況報告調度處及廠長，並通知運轉組派員支援。

四、備註

    本規程僅適於緊急時之重大地震、超級颱風及水庫 (壩) 崩塌時之緊急操作，而本廠所訂之各災害預防措施及颱 (洪) 預防對策，或地震後巡視檢查處理之規定仍然適用，運轉人員應依規定辦理。

註：本「重大地震、超級颱風、壩崩塌時緊急操作規則及標準」，為台灣電力公司立霧發電廠現所遵行，民國82年3月5日。


附錄四　閘門啟閉法規

    各水庫或大型攔河堰之閘門操作啟閉有一定的標準，本附錄摘錄部分資料以供參考。

A4.1　曾文水庫各水門啟用標準時間及方法
A4.2　牡丹水庫各水門啟閉標準時問與方法
A4.3　臺灣省鯉魚潭水庫運用規則
A4.4　白河水庫各水門啟用標準時間及方法
A4.5　石岡壩溢洪道及排砂道閘門啟閉標準時間及方法
A4.6　烏山頭水庫各水門啟用標準、時間及方法
A4.7　德元埤水庫各水門啟用標準、時間及方法
A4.8　虎頭埤水庫各水門啟用標準、時間及方法


A4.1　曾文水庫各水門啟用標準時間及方法

  1. 曾文水庫係在曾文溪上游柳籐潭附近建造大壩後形成，其作用在於攔蓄曾文溪水量，供灌溉、公共給水、發電之用，除大壩外尚設有電廠、河道放水口、溢洪道、東口導水堰等結構物，並配合烏山頭水庫之東口進水口與烏山頭水庫串聯營運。
  2. 曾文水庫設有下列水門：
(一) 進水口閘門 |
電廠進水口閘門 河道放水口閘門 | 最大取水量 五六 CMS 最大放水量一六Ο CMS
(二) 溢洪道排洪閘門三座 | 最大排水量合計九、四七Ο CMS
(三) 東口排砂閘門 | 在烏山頭水庫東口進水口之下游。
  3. 各閘門啟用時間及標準如次：
  1. 電廠進水口閘門：由曾文水庫取水供曾文發電廠及灌溉、公共給水之用。經常全開，於長期停止發電或庫水含沙量過大時關閉之。
  2. 河道放水口閘門：設於電廠進水口閘門之下，於曾文發電廠不能發電及水位低於發電最低水位時，放水供灌溉及公共給水之用；在緊急時期亦做為補助溢洪道、排砂及沖除電廠尾水道淤砂之用。本閘門在上述任何一種情況需要時啟用。
  3. 溢洪道排洪閘門：供調節及控制曾文水庫水位，於下述情況下啟用：
  1. 在颱風時期(中央氣象局或空軍氣象中心發佈海上颱風警報後八小時)，曾文水庫水位超過標高二二五公尺時，即予啟用，以降低水庫水位至標高二二五公尺。本項調節性啟用之放水量最小為三ΟΟ CMS，最大為二、二五Ο CMS。
  2. 在颱風時期，水庫水位未超過標高二二五公尺，但水庫進水量達到附表一之流量時啟用之。其啟用方法為第一小時之排洪量為三ΟΟ CMS，第二小時後逐漸增為二、二五Ο CMS，嗣後每小時按水庫進水量及水位情況調整水量一次，但每一小時調整水量之增加數不超過一、五ΟΟ CMS；在尖峰流量通過水庫前，放水量以不大於進水量為原則，尖峰流量通過水庫後，倘需繼續放水時，放水量以不大於進水量五ΟΟ CMS之水量洩放，但以不違反水利法施行細則第一二七條之規定為原則。
  3. 無颱風警報情況下，水庫進水量達到附表二之流量時啟用之。其啟用方式與第二款同。
  4. 除本條１、２、３款情形外，水庫水位超過標高二三Ο公尺時啟用之其啟用之放水量最小為三ΟΟ CMS，最大為二、二五Ο CMS。
  5. 本閘門在每年十一月至次年五月間，每月試運轉一次，六月至十月間，每週試運轉一次，但水庫水位在標高二一一公尺至二一五公尺間時不試運轉。水庫水位在標高二一一公尺以下時，試運轉至全開全閉。水庫水位在標高二一五公尺以上時，則開啟至放水量為九ΟΟ CMS即關閉之。
  4. 東口導水堰排砂閘門：於曾文溪東口處之河床水位超過標高八七•四公尺；或東口進水口有泥砂、什草、流木等淤塞，影響取水時啟用之。
  4. 水門操作方法如次：
  1. 電廠進水口閘門：本閘門設有電動操作裝置，啟閉時在進水口控制室內操作。本閘門啟用後，使庫水經發電後放回曾文溪至東口後全部引入烏山頭水庫，其啟閉係屬經常性，故除在必要地點設置警告牌示外，啟用時不另通知外界。
  2. 河道放水口閘門：本閘門設有電動操作設備，啟閉時在進水口控制室操作。本閘門之啟用方法與電廠進水口同。
  3. 溢洪道排洪閘門：本閘門設有電動遠方操作裝置，啟閉時在溢洪道控制室操作。本閘門之啟用以三座閘門同時等量運用為原則，但必要時亦得使用一門或二門單獨運轉。本閘門啟用時，在啟用一小時前由臺灣省曾文水庫管理局通知臺南縣曾文水庫警察隊，利用警動電話通知臺南市警察局及臺南縣警察局玉井分局，分轉有關單位通知下游兩岸附近民眾注意走避。
  4. 東口導水堰排砂閘門：本閘門設有電動自控操作裝置，必要時亦得在現場操作。本閘門主要係配合溢洪道排洪閘門同時運用，在非配合溢洪道排洪閘門操作時，啟用前先鳴警報，通和下游附近民眾注意走避。

附表一　颱風時期曾文水庫溢洪道排洪閘門啟用標準

水庫進水量 | (CMS) | 100 | 300 | 600 | 1,000 | 1,500 | 2,000
水庫水位 | (標高公尺) | 225 | 224 | 223 | 222 | 221 | 220
水庫進水量 | (CMS) | 3,000 | 4,000 | 5,000 | 6,000 | 7,000
水庫水位 | (標高公尺) | 219 | 218 | 217 | 216 | 215

附表二　非颱風時曾文水庫溢洪道排洪閘門啟用標準

水庫進水量 | (CMS) | 500 | 1,000 | 1,500 | 2,000 | 3,000 | 4,000
水庫水位 | (標高公尺) | 230 | 229 | 228 | 227 | 226 | 225


A4.2　牡丹水庫各水門啟閉標準時問與方法

一、. | 牡丹水庫位於屏東縣四重溪上游，攔河建造壩高65公尺之土壩蓄水，以供應屏東南端六鄉鎮之一般用水、核三廠、墾丁國家公園、特種營區、船舶及五里亭機場等處之公共用水、以及恆春地區之旱作灌溉用水，水庫正常高水位標高142公尺。
二、 | 本水庫設有下列水門：
 | (一) | 溢洪道閘門：設於洩槽入口，共三座，控制溢洪流量。
 | (二) | 取排水設施取水塔部份：
 |  | 1. | 取水口阻水閘門：設於取水塔入口，分上層及下層二座，控制三個取水口之取水；取水口由上而下分稱為一、二、三號孔。上層阻水閘門控制一號及二號孔，下層阻水閘門控制二號及三號孔。
 |  | 2. | 輸水隧道入口擋水閘門：設於輸水隧道入口，在輸水隧道、出口部份排水道備用閘門或放水口備用閘門需要維修時關閉。
 | (三) | 取排水設施出口部份： 本水庫輸水隧道下游端分為緊急排水道與公共給水及農業用水放水口等二個出口，緊急排水道與公共給水及農業用水放水口設有下列閘閥：
 |  | 1. | 排水道控制閘門：設於緊急排水追出口，控制水庫緊急排水量及初期蓄水期放水量。
 |  | 2. | 排水道備用閘門：設於排水道控制閘門稍上游處,供控制閘門保養或故障維修時阻水，並於必要時取代該控制閘門。
 |  | 3. | 放水口控制閥門：設於公共給水及農業用水放水出口，控制公共給水及農業用水放水量。
 |  | 4. | 放水口備用閘門：設於放水口控制閥門稍上游處,供控制閥門保養或故障維修時阻水，並於必要時取代該控制閥門。
三、 | 各水門之設計流量、型式及規格：
 | (一) | 控制放水門之設計流量：
 |  | 1. | 溢洪道閘門：每座每秒1200立方公尺，三座共計每秒3600立方公尺。
 |  | 2. | 排水道控制閘門：每秒52立方公尺。
 |  | 3. | 放水口控制閥門：每秒4立方公尺。
 | (二) | 各水門之型式及規格：
 |  | 1. | 溢洪道閘門：均為弧型閘門，寬12.0公尺X高15.38公尺
 |  | 2. | 取水口阻水閘門：均為傾斜式固定輸閘門，上層阻水閘門為寬2.4公尺x高2.7公尺，下層阻水閘門為寬2.4公尺x高2.873公尺
 |  | 3. | 輸水隧道入口擋水閘門：傾斜式固定輪閘門，寬2.4公尺X高4.432公尺。
 |  | 4. | 排水道控制閘門及備用閘門：均為垂直滑動式高壓閘門，寬1,8公尺X高1.8公尺。
 |  | 5. | 放水口控制閥門：固定錐套管式伸縮型何本閥，內徑為0.8公尺。
 |  | 6. | 放水口備用閘門：垂直滑動式環滑閘門，開口直徑0.8公尺。
四、 | 各水門啟用標準時間：
 | (一) | 溢洪道閘門：平時處於關閉狀態
 |  | 1. | 操作時機：
 |  |  | (1) | 洪水期間洩洪。
 |  |  | (2) | 初期蓄水期間控制水位上升率之必要排水。
 |  |  | (3) | 水庫發生緊急情況時之排水。
 |  | 2. | 安全規則：
 |  |  | (1) | 防洪操作時，本閘門開啟前一小時應發佈洩洪警報，實施其它操作時，須在排水道控制閘門全開後方可開啟。
 |  |  | (2) | 三座閘門應同時開啟。
 |  |  | (3) | 本閘門開度以保持水流起躍為原則，水流起躍後若水位仍快速增加，即實施防洪操作。
 |  |  | (4) | 本閘門應在水位不足以使水流起躍時關閉。緊急排水時除外，可在水位降至溢流堰頂後關閉。
 |  |  | (5) | 中央氣象局已發佈海上颱風警報，且水庫集水區內已開始降雨時即實施防洪操作，使水庫水位不得高於水庫上限水位標高一三七﹒二公尺。
 |  |  | (6) | 防洪操作時距採用半小時。
 |  |  | (7) | 防洪操作時，在閘門開啟後，參照其流量率定曲線及水位上升速度推算入流量。洪水期間峰前段任何時距走出流量按前一時距入流量之大小排放；若當時水庫水位無法排放該流量時，閘門全開，以自由溢流方式排放。
 |  |  | (8) | 調整閘門開度時，應同時遵守水利法施行細則第一百二十四條之規定；有閘門之水庫於洪水期間，其最高放水流量不得大於流入水庫之最高流量。水庫放水流量之增加率，不得超過該水庫流入量之最高增加率。
 | (二) | 取水口阻水閘門：
 |  | 1. | 操作時機：視水庫水位及水質來操作啟閉各取水口。
 |  |  | (1) | 水庫水位高於標高130公尺時，可從一、二、三號孔中任擇一孔取水。
 |  |  | (2) | 水庫水位介於標高130公尺與116公尺之間，僅可從二、三號孔取水。
 |  |  | (3) | 水庫水位低於標高116公尺以下時，僅可從三號孔取水。
 |  | 2. | 安全規則：排水道控制閘門開啟時，二座取水口阻水閘門均應保持全開。
 | (三) | 輸水隧道入口擋水閘門：平時處於開啟狀態。
 |  | 1. | 操作時機；在輸水隧道、排水道備用閘門或放水口備用閘門需要維修時始關閉。
 |  | 2. | 安全規則：本閘門必須在上下游水頭平衡狀態下操作：
 |  |  | (1) | 下游排水道及放水口均關閉時始可關閉。
 |  |  | (2) | 下游排水道及放水口均關閉，並俟隧道充水完成後始可開啟。
 | (四) | 排水道控制閘門：平時處於關閉狀態。
 |  | 1. | 操作時機：
 |  |  | (1) | 水庫初期蓄水期間控制水位上升率之必要排水。
 |  |  | (2) | 水庫發生緊急情況時之放水。
 |  | 2. | 安全規則：
 |  |  | (1) | 本閘門開啟時二座取水口阻水閘門均須在全開啟位置。
 |  |  | (2) | 本閘門開啟前一小時應發佈放水警報。水庫發生緊急狀況時除外，可在發佈放水警報後即開啟。
 |  |  | (3) | 本閘門由關閉至開啟需時約二十分鐘，開啟過程不限制開度。
 |  |  | (4) | 輸水隧道入口擋水閘門操作時，本閘門須處於關閉狀態。
 | (五) | 排水道備用閘門：平時處於開啟狀態。
 |  | 1. | 操作時機：
 |  |  | (1) | 在排水道控制閘門保養或故障維修時關閉。
 |  |  | (2) | 必要時取代排水道控制閘門。
 |  | 2. | 安全規則：
 |  |  | (1) | 排水道控制閘門保養或維修完成，本閘門重新開啟前須先關閉控制閘門，並充水於本閘門與控制閘門之間，於上下游面水壓平衡下操作。
 |  |  | (2) | 取代控制閘門操作時，須遵守控制閘門之安全規則
 | (六) | 放水口控制閥門：平時調整維持適當開度。
 |  | 1. | 操作時機：依下游公共給水及農業用水水量調整開度。
 |  | 2. | 安全規則：
 |  |  | (1) | 輸水隧道入口擋水閘門操作時，本閥門須處於關閉狀態。
 |  |  | (2) | 本閥門開啟時取水口阻水閘門須有一座在全開啟位置。
 | (七) | 放水口備用閘門：平時處於開啟狀態。
 |  | 1. | 操作時機：
 |  |  | (1) | 在放水口控制閥門保養或故障維修時關閉。
 |  |  | (2) | 必要時取代放水口控制閥門。
 |  | 2. | 安全規則：
 |  |  | (1) | 放水口控制閥門保養或維修完成，本閘門重新開啟前須先關閉控制閥門，並充水於本閘門與控制閥門之間，於上下游面水壓平衡下操作。
 |  |  | (2) | 取代控制閥門操作時，須遵守控制閥門之安全規則
五、 | 各水門之操作方法：
 | (一) | 溢洪道閘門：本閘門係以鼓輪鋼索式電動吊門機操作，可在水庫運轉室操作，也可在橋面現場操作。
 | (二) | 取水口阻水閘門：本閘門係以固定型鋼索捲揚電動吊門機操作，可在水庫運轉室遙控操作，也可在吊門機平台現場操作。
 | (三) | 輸水隧道入口擋水閘門：本閘門係以固定型鋼索捲揚電動吊門機操作，可在水庫運轉室遙控操作，也可在吊門機平台現場操作。
 | (四) | 排水道控制閘門：本閘門係以油壓吊門機操作為主，可在水庫運轉室遙控操作，也可在閘閥室現場操作。閘閥室另備有手動操作設備。
 | (五) | 排水道備用閘門：本閘門係以油壓吊門機操作為主，可在水庫運轉室遙控操作，也可以在閘閥室現場操作。閘閥室另備有手動操作設備。
 | (六) | 放水口控制閥門：本閥門係以電動驅動器及螺桿傳動機構操作為主，可在水庫運轉室遙控操作，也可在閘閥室現場操作。閘閥室另備有手動操作設備。
 | (七) | 放水口備用閘門：本閘門係以電動馬達驅動吊門機操作為主，可在水庫運轉室遙控操作，也可在閘閥室現場操作。閘閥室另備有手動操作設備。


A4.3　臺灣省鯉魚潭水庫運用規則

第四章　水門啟用標準、時間及方法

第 | 十三 | 條 | 實施緊急排水時，緊急排水道閘門全開排水，以迅速降低水庫水位。前項排水放水量不得使警戒區河道水位上升率超過每半小時○•四公尺。但連續一小時後，不在此限。實施第一項排水應至水庫水位不構成大壩安全威脅時為止。實施第一項排水時，抽水站應停止抽水。
第 | 十四 | 條 | 陸上颱風警報發布後，中水局有關人員應駐在辦公廳待命，並隨時將水庫水位變化情形及降雨報告主管機關。
第 | 十五 | 條 | 本水庫水位標高，接近滿水位標高二百九十八公尺且進流量較大時，應向新開國小及附近居民發布水庫水位上漲警報，並通知轄區內苗栗縣警察局、大湖分局、校林派出所及大湖鄉公所，迅速轉知水庫下游居民注意安全。
第 | 十六 | 條 | 本水庫溢洪或緊急施放水量超過二十秒立方公尺時，溢流或放水開始一小時以前，應起動警報系統向下游景山溪河床警戒區發布放水警報，並將預定放水時間及放水量通知轄區內苗栗縣警察局、苗栗分局、三義分駐所、鯉魚派出所，迅速轉知下游居民，並通知經濟部水利處、苗栗縣政府、三義鄉公所、臺中農田水利會等各有關防汛作業單位。
第 | 十七 | 條 | 本水庫遇天然災害或其他緊急情況，需施行緊急放水，無法預先通知時，得立即通知後放水之。


A4.4　白河水庫各水門啟用標準時間及方法

1. | 白河水庫係在急水溪系白水溪上游木屐寮河谷建造大壩後形成，其作用在於攔蓄白水溪水量，供灌溉，自來水，工業用水及兼防洪調節之用。除大壩外，尚設有出水工，溢洪道等結構物，以資蓄水、出水及洩水之營運。
2. | 白河水庫設有下列水門：
 | (1) | 出水工閘門：
 |  | i. | 白水溪出水工閘門：最大出水量三.九二秒立方公尺。
 |  | ii. | 糞箕湖出水工閘門：最大出水量四.六五秒立方公尺。
3. | 各閘門啟用時間及標準如次：
 | (2) | 溢洪道排洪閘門：供調節及控制白河水庫水位，於下述情況下啟用：
 |  | i. | 雨季期間 (通常六月至十月)，水庫水位達到計畫滿水位標高一○九.○○公尺而繼續有進水量時啟用之，以降低水庫水位至標高一○八.八○公尺為原則，但視實際需要保持一○九公尺。本項調節性啟用之放水量最小為一二秒立方公尺，最大為五○秒立方公尺。
 |  | ii. | 颱風時期或遇到豪雨情況下，水庫進水量達到洪水控制線如表5-4所列之進水流量及水位時，即予啟用，其啟用方法為第一半小時之排洪量為二四秒立方公尺，而在一小時內逐漸增至五○秒立方公尺，嗣後按水庫進水量及水位情況適時調整放水量 (但每次調整水量之增加數不超過五○秒立方公尺)，在尖峰流量通過水庫前，放水量以不大於進水量為原則，尖峰流量通過水庫後，放水量逐漸減少，降低水庫水位至標高一○八.八○公尺為原則，但視實際需要保持一○九公尺。
4. | 各水門操作方法如次：
 | (2) | 溢洪道排洪閘門：本閘門設有電動操作設備，啟閉時在溢洪道附設機箱操作，本閘門之啟用以三座閘門同時等量運用為原則，但必要時亦得使用一門或二門單獨運轉。本閘門每年第一次啟用時，在啟用二小時前，由水庫管理單位通知臺南縣警察局白河分局，分轉有關單位通知水庫下游兩岸附近民眾注意，嗣後如係調節性啟用者，不再另行通知，惟颱風時期洩洪量增至一○○秒立方公尺以上時，緊急通知新營防汎連絡中心，透過廣播系統轉知急水溪兩岸居民注意。

附表一　颱風時期白河水庫溢洪道閘門啟用標準

水庫 水位 (標高公尺) | 水庫 進水量 (CMS)
108.80 | 50
108.70 | 100
108.60 | 150
108.45 | 200
108.30 | 250
108.10 | 300
107.95 | 350
107.80 | 400
107.60 | 450
107.40 | 500
107.20 | 550
106.95 | 600
106.70 | 650
106.40 | 700


A4.5　石岡壩溢洪道及排砂道閘門啟閉標準時間及方法

1. | 石岡壩位於臺中縣石岡鄉石岡村大甲溪河床上，為閘門控制式混凝土重力壩，其功用為調蓄尖峰發電尾水及存蓄中游流量，以供下游臺中地區灌溉及公共、工業用水之需。
2. | 石岡壩共設有下列閘門：
   (1) | 溢洪道弧型閘門十八門 (每門寬八.○公尺、高六.○公尺)，其最大排洪量共計一三、○○○秒立方公尺。
   (2) | 排砂道弧型閘門二門 (每門寬八.○公尺、高六.○公尺)，其最大排水量共計一、一五二秒立方公尺。
   (3) | 進水口調節閘門二門 (每門寬三.五公尺、高三.○公尺)，緊急閘門一組 (每門寬四.○公尺、高四.○公尺)。
3. | 各閘門啟閉規定：
   (1) | 溢洪道閘門之啟閉：
      i. | 汎期 (每年六月一日起至十月十五日止) 石岡水庫上游進水量豐富時，除為保持南幹線引水所需水位 (水庫水位在標高二六二.○○公尺左右) 之蓄水外，其餘水量依水利法施行細則第一百二十四條規定洩放之。
      ii. 汎期發生枯水時：
  1. 德基水庫在正常運用下，石岡水庫上游進水量有逐漸減少趨勢時，參照氣象資料研判認有需要時，得將石岡水庫水位提高至二六四.○○公尺以上，但不得超過標高二六七.一○公尺。
  2. 經過上項 (1) 之狀況後，上游進水量逐漸恢復至接近下游各標的需水量時，參照氣象資料石岡水庫仍得儘量蓄水，但仍不得超過標高二六七.一○公尺。
      iii. | 枯水期 (十月十六日起至翌年五月三十一日止) 石岡水庫之正常滿庫水位定為標高二六七.一○公尺，警戒水位定為標高二六七.一五公尺，水位達二六七.二○公尺時，應按水利法施行細則第一百二十四條之規定，開啟溢洪道閘門洩洪。
      iv. | 每一閘門均備有人工操作電動開關及規定水位自動開關二種操作設備，電動設備可就地操作，亦可在控制室內遙控操作。
      v. | 溢洪道閘門由左岸起向右岸依序編號，其開啟原則上以四門為一組 (但亦可單獨開啟)，其編組為第八、九、十、十一號為第一組，六、七、十二、十三號為第二組，四、五、十四、十五號為第三組，二、三、十六、十七號為第四組，一、十八號為第五組，洩洪開啟閘門時，先由第一組完全開啟後，再繼續開第二組，其餘依此類推。
      vi. | 溢洪道閘門除依前列各條規定開啟閘門外，水庫水位達二六七.一五公尺時，警報器應鳴響，水位達二六七.二公尺時，應即開啟閘門。
4. | 石岡水庫預定洩洪前四小時，電話通知下游臺中縣大甲、豐原、清水各警察分局及臺中農田水利會，以資防範。


A4.6　烏山頭水庫各水門啟用標準、時間及方法

1. | 烏山頭水庫建於官田溪上游三腳埤附近，其主要目的為蓄水供為嘉南地區八萬餘公頃農田灌溉之用。至曾文水庫完成後配合串連運營，並兼為公共給水及工業用水，其水源取自曾文溪經東口由隧道引入水庫，除大壩外，設有溢洪道、送水口設施。
2. | 烏山頭水庫設有下列水門：
 | (1) | 進水口閘門：最大取水量五六.六秒立方公尺。
 | (2) | 溢洪道：溢洪道入口寬一二一.○公尺，出口寬一八.○公尺，係自然滿水，溢洪道最大排洪量一、五○○秒立方公尺。
 | (3) | 送水口設施：蝴蝶閥二座及針型閥六座，最大放水量一四四.○秒立方公尺，現在約六二.○秒立方公尺。
3. | 各閘門啟用時間及標準如次：
 | (2) | 溢洪道：在洪汎期 (包括颱風時期) 或平時因降雨如烏山頭水庫水位超過標高五八.一八公尺時自然溢洪。


A4.7　德元埤水庫各水門啟用標準、時間及方法

1. | 德元埤水庫係在溫厝廓溪上游建造制水閘門後，攔蓄溫厝廓溪水量，供灌柳營鄉一帶農田，除設制水閘門外，尚設有取水抽水機室裝有六○馬力三台、三○馬力一台及五馬力、一馬力各一台。
2. | 德元埤水庫設有下列水門：
 |  | 制水閘兼排洪閘門：寬六公尺、高五公尺共五門及附設五馬力電動吊門機五應，最大排洪量五三二秒立方公尺。
3. | 閘門啟用時間及標準如次： 本閘門係供調節控制德元埤水庫水位於下述情況下啟用：
 | (1) | 在雨季颱風季節 (即六月一日至八月三十一日) 水庫水位超過標高一三.五公尺時，即予啟用以降低水位至標高一三.五公尺，調節啟開高度及門數視水庫進水量之大小隨時調整閘門高度及門數，但排洪量以不超過進水量原則下洩洪。
 | (2) | 枯水時期 (即自九月一日至翌年五月三十一日) 水庫蓄水位超過一四.一二公尺時，即予啟開降低水庫水位至標高一四.一二公尺，啟開閘門之高度、門數係視水庫進水量之多少而定。
4. | 制水閘門操作方法如次：
 | (2) | 閘門之啟用先以三門同時同等量運用為原則，而兩側二門為顧及水流沖擊力破壞保護工起見盡量避免使用，倘若三門全開後尚不夠排洪時始啟開兩側二門，但必要時亦得使用一門單獨使用運轉。


A4.8　虎頭埤水庫各水門啟用標準、時間及方法

1. | 虎頭埤水庫係在新化鎮礁坑子虎頭山建造土壩而成，收集鹽水溪支流蓄水供應新化鎮一部分農田灌溉之用，除土壩外，並設有溢洪道及放水閘暗渠等結構物。
2. | 虎頭埤水庫設有下列水門：
 | (2) | 溢洪道：設有寬一.六公尺，高二.○公尺，閘門十門，自然溢流九二○公尺，最大大排洪量七八.七秒立方公尺。
3. | 各閘門啟用時間及標準如次：
 | (2) | 溢洪道閘門：為調節或控制水庫水位，以下述情況下啟用。
 |  | i. | 在洪水期 (自六月一日至八月三十一日止) 為保持水量水庫水位定為標高三六.四○公尺，倘閘門全開不足排洩時，由自然溢洪道排出。
 |  | ii. | 在枯水時期 (九月一日至翌年五月三十一日止) 水庫水位定為標高三七.○公尺，如水位超出標高三七.○公尺時，啟用閘門，使水位降低至水位標高三七.○公尺。
4. | 各水門操作方法如次：
 | (2) | 溢洪道：在必要時排洪時以人力操作啟閉。


研究人力

工作人員

參與教授：周乃昉副教授

專責研究人員：鄭子璉

協同研究人員：吳依芸、鄭志偉、吳嘉文


檔案下載

下載水庫防洪運轉電子書 水庫防洪運轉電子書： operate.chm


8.1　系統分析

8.1.1　系統分析法

    何謂系統？系統乃一組功能性的成份，循許多型式的程序相互作用在一起，部份成份在作用的過程中具有輸入及輸出的特性。系統的運作須遵循物理、生態及其他自然科學的法則。以水庫防洪系統為例，包括輸入的洪水入流量，水庫調節洪水之功能，對閘門之人為控制以放出特定的洩洪輸出量。系統分析(Systems Analysis)在工科領域又稱系統工程(Systems Engineering)，實施上為一種從許多可行的替代方案中選出最佳方案的藝術或科學，內涵包括大量的工程措施以達成決策者的系統整體最佳目標，而同時又受到許多如法令，道德，經濟，資源，政治及社會壓力的限制。因此系統具有包羅廣泛的科際整合特性，分析上需有電腦計算及數學分析的配合，以科學性的定量方法，提供系統內各種成份相互作用結果的資訊，以做為下決策的合理基礎。

8.1.2　系統分析實施步驟

    一般而言實施上可分成下列六個步驟：

  1.
  2. 確定問題。闡述需求，包括時空特性及系統的邊界，穿過邊界的外在輸入與輸出變量及系統內部的變量。
  3.
  4. 問題分析的目標，亦即簡單地指出分析的目的何在。例如最大效益、最低成本、最可靠或最小風險、最大效率或環境保護，一般均具科際整合的特性。
  5.
  6. 定量表示系統的分析目標。例如以貨幣數量衡量經濟性，以生化需氧量或溶氧量衡量環保程度，或對目標(供水)的偏差量。此類量度中往往包含具有取捨性質的多目標特性在內。
  7.
  8. 定義可行的替代實施方案。例如水庫的每日放水量有多種選擇，一般均須透過描述系統內部作用特性之模式 (Model) 進行分析，措施上包括政治性與非政治性的。既有模式可協助判定系統有關的資料以利搜集與分析。分析程序上包括模式的檢定及驗證，必要時須進行模式參數的敏感性分析 (Sensitivity Analysis) 以掌握最重要的參數。
  9.
  10. 找出最佳的替代方案。方法有試誤法，優選法，取捨分析 (Trade-off Analysis)，多目標分析法。特性上有局部最佳及整體最佳，風險及可靠度等。
  11.
  12. 回顧，回饋及修正。系統是動態的，最佳方案為在擬達成某項目標的前提下分析而得，系統目標改變則最佳方案自然亦隨之而變。故往往需回溯前面不同的分析步驟，檢核最佳方案是否仍合理。明確指出最佳方案之限制，假設及分析過程中可能之近似簡化。

8.1.3　模式

    模式為一組法則或規定，用以適當地描述為某特定目的之系統內必要成份的相互作用與反應。故系統分析需透過模式的協助方能進行。下圖為一模式的示意圖：

系統之成份在圖中包括：

u | = |
 | = | 獨立的決策或控制變量，為設計或操作時系統可控制的輸入量。
x | = |
 | = | 系統狀態，為一種特殊的因變量，其值隨系統上一時段(或階段)的狀態而變，掌握此值即可不需考慮過去時段不同控制措施下的系統變化。
x(0) | = | 起始情況 (狀態)。
r | = |
 | = | 獨立的不可控制輸入變量，可能為序率變量。
a | = |
 | = | 參數，其值相當固定，代表系統的某種特性，一般而言不受 u 及 r 值的影響。
b | = | 邊界條件。為系統限制的一種形式，可為物理性、技術性、法律性或財務性者。
y | = |
 | = | 特定的因變量，用以衡量系統目標表現情況的輸出變量。

8.1.4　模式種類

    模式的類別上有判斷型、物理型、類比型、數值型及混合型等。選用能適當描述系統之模式均與所欲從事的分析有關，對系統分析而言，因須進行大量可行替代實施方案的分析，故最常以數值或數學模式來描述系統，透過此類模式的分析，可以不須對實體系統進行試驗。數值模式由一些數學關係式、邏輯運算所組成，用以預測系統在特定輸入下的相關輸出量。此類數學模式又可分為：

  1.
  2. 代數型。如下之代數關係式：
  3. (8.1.4-1)

    例如在水庫操作上為表示水量守衡的連續方程式：

    (8.1.4-2)

    (蓄水量)

    (放水量)

    (蒸發量)

    (入流量)

    狀態變量

    決策變量

    因變量

    不可控制的輸入量
  4. 微分、積分或微分-積分型。
  5. (8.1.4-3)

    實際分析上常將之差分化以利分析。

  6. 定率或序率型。例如以機率表示歷史的入流量特性，以進行成本或效益的期望值分析。
  7.
  8. 理論型式或經驗型。例如來自質量守衡的連續方程式：
  9. (8.1.4-4)

    或經驗型式的合理化公式：

    (8.1.4-5)

  10. 靜態型與動態型。指系統隨時間演進與否。
  11.
  12. 物理型或行為型。例如用以預估用水需求變化需採用行為型模式。
  13.
  14. 集塊型或分佈型。例如單位歷線分析法，或史丹福集水區模式。

以下為模式二例：

例一：

  • (8.1.4-6)
    •

    • 　　式中，

  • 　 = 已知的起始蓄水量 ；

    ；

    ；

    ；

       = 月蒸發係數，為一參數；

    = 水庫水面積。

    •

    • 例二：

  • (8.1.4-7)
    •

    • 　　式中， [image] 目標供水量。

        就上述二例中所用到的變量，依模式成份之定義可綜合如下：

  • ，放水量，為獨立(非系統內部)的可控制輸入變量；

    ，獨立不可控制的輸入變量， [image] 為外在變量；

    ，亦稱系統狀態變量，為一因變量；

    ，起始情況，此地為水庫起始蓄水量；

    ，每月之蒸發係數，為一參數；

    ，邊界條件；

    •

    • 　　模式之主體或變量間的作用關係有下列三式：

  • (8.1.4-8)

    (8.1.4-9)

    (8.1.4-10)

    •

    • 8.1.5　模擬與優選分析

        找出最佳替代方案的分析方法，及相關所用以分析的模式，可概分為模擬與優選二類。模擬模式用以回答描述性的「假如…，則…」型式問題，其優點為能精確地預測與進行細部的模式分析；故富彈性且具有廣泛的可接受性。但缺點為不能直接求得問題的最佳解；如果有許多可能的替代方案需要分析，則須以試誤法進行模擬，一般而言分析成本甚高。實例上有：HEC-1至 HEC-6；QUAL-IIE；SWMM；HSP；SSARR；SEA AR；Thomas-Fiering 等模式。

        優選模式亦含有某種程度的模擬在內，其意義上為採用一種有系統的方法去找出最佳的管理或操作方案，而不需以試誤法去考慮或分析所有的可行方案。優點為能指出最佳解，同時可自動產生其他狀況下的最佳替代方案。缺點為模式架構受限於計算方法，一般在實體系統的模擬上均不甚詳細，另方面對規劃管理者而言較不具直覺上的意義。其分析的型式均表成一標的函數及對最佳解的一些限制式如下：

    1.
    2. 標的函數：
    3. (8.1.5-11)
    4. 限制式：
  • (8.1.5-12)
    •

    • 式中 f(x,u) 即模式中的輸出變量函數 y，其值為一純量。而 g 函數即為某種型式的模擬模式。一般常用的優選技術 (Optimization，或數學規劃法) 有：線性規劃，網流模式，動態規劃，非線性規劃，序率規劃，多目標或多準則優選分析法等。

    8.1.6　系統分析在水庫管理及水庫操作之應用

        下表列出系統分析在水庫管理及操作上的應用特性：

    項 目 | 管 理 | 操 作
問 題 | 在既有設施下，調節系統以達成最佳營運，例如最小衝突。 | 在既有設施下，短期內儘可能達成整體的營運管理目標。
範 疇 | 中期至長期：5至30年；分析時距為月、季或年；空間範圍為全流域或局部流域。 | 短時程，如一日至一年；分析時段為分、時、日或月；局部流域或個別設施。
營運目標 | 符合多種規劃標的；可靠度或風險；最大經濟報酬；可靠供水量或發電量。 | 使與管理目標之偏差量最小；安全、效率、可靠。
量度標準 | 經濟；生化等。 | 絕對偏離量，或偏離的最小二乘方量。
實施方案 | 整合一複雜營運系統內之調節時程；使用長期氣候預報。 | 在管理指標的整體基礎上，進行對個別設施的即時 (Real-time) 調節。
分析模式 | 動態且較詳細；若能使用較詳細的序率模式最為理想；中尺度至大尺度；在時段為月、季或年下，分析得系統內所有設施的營運決策。 | 最為詳盡。例如：採用變量流模式；最理想者為具有即時資訊處理的序率模式，能作預測與控制；完全動態的分析得到在短時段內詳細的決策。

    度的複雜系統，或在各項標的競爭用水及水權優先的衝突情況。


8.2　線性規劃

8.2.1　線性規劃基本原理

    系統分析常應用數學規劃（mathematical programming）法以求取優選策略，也就是在所有可行方案中，選取可達到最好目標者。規劃法中的線性規劃是20世紀中期開始發展的科學，線性規劃模式中的所有方程式及函數都是線性的，所以應用最為廣泛。線性規劃有個非常高效率的解題方法，稱為單純法（simplex method），可用來解決任何尺度線性規劃的問題。

    此下以一水庫為符合供水合約要求之營運分析為例，介紹線性規劃之應用。如圖所示之系統：

    考慮下游地區的週期性用水需求可以表示成下式：

(8.2.1-1)

式中，

t | = | 時段指標；
 | = | 年需水總量；
 | = | 各時段之用水係數。

    系統營運上的其他限制條件包括：

(1) [image] (8.2.1-2)

(2) [image] (8.2.1-3)

(3) [image] (8.2.1-4)

(4) [image] 已知；

(5) 所有變量均 [image] 。

上述諸式中，

T | = | 分析時段總數；
 | = | 水庫蓄水量 [image] ；
 | = | 水庫起始蓄水量；
 | = | 營運分析的期末蓄水；
 | = | 水庫入流量；
 | = | 水庫蒸發量，須經疊代計算；
， | = | 水庫的最大及最小蓄水量；
 | = | 放水量 [image] ；
 | = | 缺水量；
 | = | 超供水量；

而且 [image] ，亦即此二水量僅有一量有值，另一量必定為 0。

    根據不同的管理目標，水庫營運分析的標的函數可能有下列三種選擇：

1. 標的函數 #1 ： 希望相對於目標供水量的總缺水量為最小。

(8.2.1-5)

2. 標的函數 #2 ： 使總缺水量為最小。

(8.2.1-6)

3. 標的函數 #3 ： 儘量減低最大的供水偏差量

(8.2.1-7)

    上述之標的函數 #3 具有平均供水偏差的效果，相當於一平滑化 (Smooth) 之標的函數如下式：

(8.2.1-8)

    此式將「懲罰」較大的缺水量值，但相對於標的函數 #3，需先進行線性化的處理，方能應用線性規劃求解。

    茲採用標的函數 #3 進行分析，其可行解的限制條件可整理如下：

(8.2.1-9)

(8.2.1-10)

(8.2.1-11)

所有變數 [image] (8.2.1-12)

(8.2.1-11) 式亦可寫成下列二式：

(8.2.1-13)

(8.2.1-14)

    問題中諸變量在分析上之類別為：

  1. 已知變量有： 、 [image] 、 [image] 、 [image] 、T、 [image] (=0)、 [image] 。
  2. 未知目標函數值：C = 為最大的供水偏差量。
  3. 未知的因變量有： 、 [image] 。
  4. 未知的決策變量有： 。

對一3時段的營運分析問題，將 (8.2.1-7)、(8.2.1-9)、(8.2.1-10)、(8.2.1-13)、(8.2.1-14) 諸式表成矩陣型式如下表，即可以線性規劃求解：

MIN | 0 | 0 | 0 | 0 | 0 | 0 | 1 | = | Z
變數: | X1 | X2 | X3 | X4 | X5 | X6 | X7 |  |
 | Q1 | V2 | Q2 | V3 | Q3 | V4 | C |  | b
 | 1 | 1 |  |  |  |  |  | = | I1 - EVAP1 + V1
 |  | -1 | 1 | 1 |  |  |  | = | I2 - EVAP2
 |  |  |  | -1 | 1 | 1 |  | = | I3 - EVAP3
 |  | 1 |  |  |  |  |  |  | Vmax
 |  |  |  | 1 |  |  |  |  | Vmax
 |  |  |  |  |  | 1 |  |  | Vmax
 | 1 |  |  |  |  |  | 1 |  | D1
 |  |  | 1 |  |  |  | 1 |  | D2
 |  |  |  |  | 1 |  | 1 |  | D3
 | 1 |  |  |  |  |  | -1 |  | D1
 |  |  | 1 |  |  |  | -1 |  | D2
 |  |  |  |  | 1 |  | -1 |  | D3

上表中的已知值均出現在方程式右方 (Right Hand Side, RHS)，線性規劃將求得方程式左方所有未知變量的最佳解與最小之標的函數值。

    線性規劃法使用簡便，計算效率高，商用的電腦套裝軟體，例如LINDO、MINOS等極為普遍，超過半數以上的水資源規劃與管理問題皆可套用線性規劃求解。但線性規劃的缺點及限制則有：

  1. 對隨時段動態演進的問題，上表會形成寬鬆矩陣 (Sparse Matrices) ，而線性規劃若以使用普及的簡繁法 (Simplex Method) 求解，其計算時間隨矩陣之行數與列數乘積成二次方增加，故有計算時效的問題。
  2. 方程式中的非線性項必須先經線性化處理，或以連續線性近似法分析，但對非凸型的函數則可能難以求得整體最佳解 (Global Optimum)。
  3. 不易明確地納入風險及不確性的分析在內。
  4. 對整數值的變量或離散決策型態的問題並不適合，此二類問題宜採用整數規劃或動態規劃分析。

8.2.2　線性規劃連續趨近法

    並非所有規劃的問題都能適用線性規劃模式，當一個或多個線性規劃的假設不成立時，就只好改用其它數學規劃模式，譬如，整數規劃或非線性規劃。惟線性規劃亦可用連續趨近法來處理限制式中的非線性項，線性規劃連續趨近法為疊代法的一種，其求解程序係利用一階泰勒級數展開法，將非線性項近似取為線性項，並定出一起始可行解代入分析，再由分析所得結果疊代至上述起始可行解中，直到分析所得結果與起始可行解近似為止。

    例如在水庫防洪運轉分析中，主要之非線性函數為溢洪道的放水堰流公式，並不能直接運用於線性規劃分析，因此可運用線性規劃連續趨近法處理。首先將此非線性方程式做一階泰勒級數展開：

(8.2.2-1)

式中 [image] 為 [image] 的假設近似值。

??由於上式將非線性方程式近似為一次的線性方程式，因此可將此式置入線性規劃模式中加以遞迴分析，將分析得出的 [image] 值疊代回原式中的 [image] 值中，再對整體線性規劃模式加以求解，重覆此步驟直至 [image] 為止，此時分析所得的結果即為系統的最佳防洪操作策略。