徐昇網自動分析

電子郵件地址： | qvb3377@ms5.hinet.net devil@mail.hyd.ncku.edu.tw
Web 位址： | http://feitsui.hyd.ncku.edu.tw/TLCheng/

最後修改日期：1999年12月15日


程式使用說明

執行步驟

  1. 以執行測試範例為例，用開啟舊檔將資料設定檔 (TM2Test.txt) 開啟。
  2. 俟開啟完畢後選擇工具列上之功能，即可分析加權因子。
    1. 徐昇多邊形網：選擇工具列上的 繪製徐昇網 「繪製徐昇網」的圖示即可。
    2. 高度平衡多邊形網：選擇工具列上的 繪製高度平衡多邊形網 「繪製高度平衡多邊形網」的圖示即可。
    3. 高程中點分析：選擇工具列上的 高程中點分析 「高程中點分析」的圖示即可。
  3. 欲分析其他雨量站組合的情形可點選工具列上的 回復原圖 「回復原圖」的圖示再重新執行上一步驟即可。

本程式附屬之徐昇網螢幕保護程式為水利工程師展現專業形象的最佳選擇

徐昇網螢幕保護程式，分析資料來自於 scrThiessen.ini ，資料格式與樣本檔格式相同，分析不設任何限制，在系統許可下，可使用所有可用的記憶體進行分析，並可將個人的實例置入 scrThiessen.ini 中，徐昇網螢幕保護程式將依序將每循環所有解集合逐一亂數選取展示，在安裝本模式時，會自動把下面兩個程式一起安裝至 Windows\SYSTEM 目錄中：

徐昇網.scr

scrThiessen.ini

並可觀看螢幕保護程式，以評估本模式是否適用， 新螢幕保護程式 支援 Windows 內建密碼保護功能，並提供曾文溪流域及 30 站雨量站做範例

程式優點說明

以數學幾何方式演算極為迅速且不失真

以 Pentium 233 MMX 計算上述頁首動畫圖形的實例約需 7 秒 (雨量站 9 站，流域多邊形 688 點，共交集計算 18 次) ，完全採用幾何方式分析，較 ArcView 3.x 以格網分析需 1 ~ 4 小時 (依格網密度而定，過密會因記憶體不足當機) 快速。

兩多邊形交集分析亦採用幾何方式分析，較 ArcView 3.x 以格網分析精確，分析後的多邊形點數僅增加交點座標，不似 ArcView 3.x 以格網分析會產生階梯狀之失真邊界及多邊形點數因階梯狀而暴增。

可繪製高度平衡多邊形網及進行高程中點分析

以 Pentium II 300 計算上述實例約需 10 秒 (雨量站 9 站，流域多邊形 688 點，共交集計算 18 次) ，完全採用幾何方式分析，並支援中央大學太空及遙測中心所提供的數值高程二進位資料檔 (*.img) 。

支援 ESRI Shapefile (ArcView/ArcInfo) 圖檔格式，可減少數化座標所需時間

可 匯入 、 匯出 ArcView 所採用的 Shape File (*.shp) ，並配合產生 Shape Index (*.shx) 及 dBASE IV (*.dbf) 格式之資料庫檔，可減少數化多邊形所需時間，配合 ArcView 進行多方面之運用

另可將 ArcView 圖檔格式的多邊形座標資料透過流域多邊形圖層匯入，匯出存成一般文字檔，可配合特定研究修正座標系統

完整使用電子計算機之有效位數

程式內部先進行參考點座標計算，將所有點及多邊形座標依參考點座標平移，使計算分析時能完整利用倍精度變數的有效位數，提高交集分析計算精度，在目前所有計算分析中，程式僅發生進位誤差，徐昇加權因子分析總誤差皆小於 10 e-14

提供計算所有可能組合的徐昇多邊形網，適合規劃階段及防洪運轉即時操作時運用

本部分配合經濟部南區水資源局曾文水庫管理中心 ( 曾文水庫防洪運轉資訊系統 ) ，在防洪運轉即時操作時，有可能發生電傳雨量站一站或多站故障情形，導致過去規劃的九站徐昇加權因子無法分析平均降雨，必須依現況立即重新演算徐昇加權因子，人工作業需耗時甚久無法配合，本計算模組可在 10 秒內配合立即演算運用，或離線時先計算所有可能組合徐昇加權因子後存檔運用

支援 Win32 系統內建向量圖檔格式 (加強型向量圖檔，EMF) ，可貼上或插入 Office 系列軟體，便於報告製作

可匯出 Windows 所採用的 Enhanced Metafile ，配合 Word 、 PowerPoint 可無段放大縮小不失真，並可直接貼至 Office 系列進行多方面之運用

樣本範例為曾文水庫集水區之 徐昇多邊形網 、 高度平衡多邊形網


樣本檔說明

依樣本檔內容修改，樣本檔分成三大節區，依各節區內容分別加以說明

[Polygon1]

節區內設定流域多邊形資料節區，

Name=BasinSectionName 本項目指定資料節區

Number=BasinPointNumber 本項目指定資料有效個數

Polygon=BasinSectionName 本項目前暫無使用

例

[Polygon1]
Name=TWBasin
Number=21
Polygon=True

[BasinSectionName]

節區內為流域多邊形座標資料節區，採自由格式，僅需以空白將 x 座標及 y 座標隔開即可，節區名由 [Polygon1] Name 項指定

例

[TWBasin]
120.5323082498526 23.25254612862227
120.5549116153516 23.21713851730454
120.6003617943275 23.24606676875179
120.6412877640277 23.22589713065387
120.6707822765463 23.26227206343362
120.7102034152955 23.32330468645687
120.7397985691007 23.36402986262950
120.7622472887054 23.40433591596885
120.7968318147704 23.41875625330122
120.8127586275368 23.45408627833955
120.8196736679276 23.49044598084182
120.7950039611349 23.51818760343012
120.7416747737618 23.50002590060771
120.6894861052333 23.48010418176180
120.6529497820292 23.44175656260913
120.6349524361496 23.40497508245456
120.6023304662271 23.39853139066862
120.5757324364844 23.36754434320274
120.5329873084870 23.32069933629255
120.5309568771136 23.25979550961010
120.5334447864686 23.25668991953130

[RainStation]

雨量站資料節區，節區內採格式輸入

站名[1-12]

站號[13-24]

雨量站座標採可變長度定義 ( X , Y )

X 由前括號﹝(﹞至逗號﹝,﹞之間的數值表示

Y 由逗號﹝,﹞至後括號﹝)﹞之間的數值表示

例請參考 (GISTest.TXT)


更新程式說明

0.1.7 版新增高度平衡多邊形計算及雨量站網高程中點分析，支援 Win32 系統 EMF 格式

新增高度平衡多邊形計算及雨量站網高程中點分析

站網高程中點分析依 DTM 原始二進位圖檔進行分析，以兩雨量站連線剖面上平均高程中點為高程中點

支援 Win32 系統內建向量圖檔格式 (加強型向量圖檔，EMF) ，可貼上或插入 Office 系列軟體，便於報告製作

可匯出 Windows 所採用的 Enhanced Metafile ，配合 Word 、 PowerPoint 可無段放大縮小不失真，並可直接貼至 Office 系列進行多方面之運用，其中匯出成為 EMF 檔以所有的圖形為輸出範圍，複製則以畫面範圍為輸出範圍

0.1.6 版修正完整放大功能，修正雨量站上圖形移動之座標支援，支援 ESRI Shapefile 格式

更新螢幕保護程式支援 Windows 內建密碼保護功能，並提供曾文溪流域及 30 站雨量站做範例

修正透過按下滑鼠左鍵拖拉達到放大圖形，按下滑鼠右鍵可返回原視窗，支援三角網、徐昇網及交集完成的多邊形放大縮小

先前版本當滑鼠在雨量站上圖形移動時，座標並不會隨同傳回正確值，目前已修正完畢

支援 ESRI Shapefile (ArcView/ArcInfo) 格式

流域多邊形資料可從 ArcView 檔 (*.shp) 匯入

三角網、徐昇多邊形網、交集多邊形網匯出至 ArcView 檔 (*.shp、*.shx、*.dbf)

流域多邊形、三角網、徐昇多邊形網匯出至文字檔

依據使用者反應部分修正交集的小錯誤

依據使用者反應需求，增加由使用者自行決定分析所有可能解的存檔檔名

增加分析階段程式對螢幕維護的部分，亦增加確認終止計算的部分

若使用者未選擇欲分析所有可能解的作用雨量站，則以圖面內所有雨量站進行分析，若使用者選擇作用雨量站，則僅以選擇內的部分進行所有可能解分析

使用者應特別注意選擇雨量站數，若使用者選擇作用雨量站數為 n ，則所有可能解的數量為 2^n-1 ，假設一組解分析約需 10 秒，則總需執行時間為 10*(2^n-1) 秒

修正參考點座標計算方式，提高交集分析計算精度，在目前所有計算分析中，徐昇加權因子分析總誤差皆小於 10 e-14

以曾文水庫集水區為例，數化面積 482.6676 平方公里 (km^2) ，九個徐昇網交集面積累加後與總面積只誤差 1.4468 平方公釐 (mm^2) ，誤差比例為 3 e-15

0.1.5 版修正部分多邊形交集失敗及加入簡單的放大功能

配合未來兩多邊形聯集、差集等分析的程式撰寫，將兩多邊形交集現用程式全面改寫，並修正部分多邊形交集失敗程式，加速多邊形交集分析

新增可透過按下滑鼠左鍵拖拉達到放大部分圖形，按下滑鼠右鍵可返回原視窗，但尚不支援三角網、徐昇網及交集完成的多邊形放大縮小，僅支援流域邊界、雨量站放大縮小，可先點選雨量站放大後才執行繪製徐昇網

0.1.4 版因配合台灣地區二度分帶座標過大且增量小而加以調整

將全部程式由原先採用容許誤差為絕對精度 10e-10 變更為相對精度 10e-10 ，並於計算時改採相對座標，於實際輸入輸出時才採用絕對座標。

在模式中使用到容許誤差的函式：

判斷某任意點是否在任意線段上﹝利用直線方程式、利用空間相關位置﹞

是否兩任意點為同一點

配合本部分另外發展從 ArcView 的檔案 (*.shp) 中擷取 Polygon 點座標屬性資料

適用 ArcView 2.x ~ 3.x

將程式植入 GetShpPoint.xls ，可將點座標直接列於 Excel 的表格中，以便複製或存檔

本部份尚未納入安裝程式中，未來將另建網頁說明並提供下載，若有需求可先與我聯絡，將透過電話先以口頭方式說明

本系所師生可利用網路芳鄰 \\Tsengwen\GetShpPoint\ 下載

配合本部分另外發展從 AutoCAD 中擷取 Polygon 點座標屬性資料

適用 AutoCAD R11 以後版本

將 TP.Lsp 程式載入 AutoCAD 中，可透過點選模組選擇所需的 Polygon 並將點座標寫入文字檔以 ASCII 格式儲存

本部份尚未納入安裝程式中，未來將另建網頁說明並提供下載，若有需求可先與我聯絡，將透過電話先以口頭方式說明

配合台灣地區二度分帶座標過大，造成原定義輸入檔格式不夠精密儲存雨量站座標位置，目前改成不限定長度方式輸入，以座標的 (x, y) 前括號、逗號、後括號來定位

移除對 SysInfo.OCX 的引用，直接透過 Windows API 去取得電腦資訊

0.1.3 版修正部分多邊形交集失敗的程式。

0.1.2 版加入分析所有可能解的能力，並將分析結果存成 All.out 。

另新增徐昇網螢幕保護程式，分析資料來自於 scrThiessen.ini ，資料格式與樣本檔格式相同，分析不設任何限制，在系統許可下，可使用所有可用的記憶體進行分析，並可將個人的實例置入 scrThiessen.ini 中，並評估本程式是否適用，徐昇網螢幕保護程式將依序將每循環所有解集合逐一亂數選取展示，在安裝時，會把下面兩個程式安裝至 Windows\SYSTEM 目錄中：

徐昇網.scr

scrThiessen.ini

0.1.1 版完成開放式的徐昇網修正，當外心位於無限遠處，仍可順利完成分析。


支援

若在執行上發生錯誤，請利用 Alt+PrintScreen 將螢幕拷貝下來，並連同資料檔註明版本一起 E-Mail 給我，我會盡快處理！

測試版本只能計算 10 個雨量站及 21 點以內的多邊形，上述頁首動畫圖形之範本為正式版本所繪製，下載的測試版本包含上述曾文水庫集水區 (TWGIS.TXT) 的樣本檔及測試的樣本檔 (GISTest.TXT) ，測試版本可以執行 GISTest.TXT 及 TM2Test.txt，其中 TM2Text.ecp 為 TM2Test.txt 之高程中點檔，請參考使用人員注意。

執行自己的範例可以參考 TM2Test.txt 的格式修改。

如何取得正式版本

1. 贊助研究經費

雨量站數 | 多邊形點數 | 贊助金額
10 | 21 | 免費下載測試版
5 | 150 | 5,000
10 | 400 | 20,000
20 | 1,000 | 50,000
50 | 2,500 | 100,000
不設限制或其他組合 |  | 另議

2. 由國立成功大學水利及海洋工程學系暨研究所協同研究

請 E-Mail 給 鄭子璉 ，或與 周乃昉 教授聯絡 (聯絡電話：+886-6-275-7575-63269)

3. 集水區徐昇加權因子及高度平衡加權因子各種組合協助計算

請 E-Mail 給 鄭子璉 ，或與 周乃昉 教授聯絡 (聯絡電話：+886-6-275-7575-63269)

修改支援與進度

若要求特定的功能可是程式不提供怎麼辦？

若您有特別的需求，我可依您的需求進行修正與調整。但在本研究中是沒有任何經費贊助的，因此您需要提供一點點修改的費用﹝就像是修改褲管一樣﹞，另外要說明的是雖然您提供修改的費用，但是版權還是屬於我的，而且照您需求進行修正與調整會加入新的版本中供人下載，讓大家都有機會享用到你的需求，而不是您所獨享的。

未來版本預定加入功能

雨量站資料從 ArcView 檔匯入 (完成度 90 %，正在考慮輸入介面該怎樣定)

交集多邊形匯出至文字檔 (完成度 90 %，正在想檔案格式該怎樣定)

修正危險圓問題 (已完成演算法推算)

加入高度平衡多邊形法 (Height balance polygons method)，預定於暑假期間進行本項研究： 目前已完成之程式執行畫面

註：目前高度平衡多邊形法已經完成了，但是因為本研究成果有投稿到 1999 中華地理資訊學會年會暨學術研討會，篇名「高度平衡多邊形法之數值計算」，所以最近在趕文章內容及打字，請網友耐心等候，等我把這個部分先處理完成


下載

程式下載 (download)

按此圖案可下載徐昇網自動分析 | 測試版本： | Thiessen 0.1.7 Beta |
 | 螢幕保護程式： | 螢幕保護程式 | 可直接在 Windows 98 上執行


相關參考文獻

  1. 周乃昉、鄭子璉，「徐昇多邊形網的自動化計算」，八十四年電子計算機於土木水利工程應用論文研討會論文集，中壢，第 465-476 頁， 1995 。
  2. ESRI, "ESRI Shapefile Technical Description - An ESRI White Paper", July 1998.
  3. 鄭子璉、周乃昉，「 多邊形交集分析在徐昇加權因子計算之探討 」，第十屆水利工程研討會論文集，臺灣，台中，第 I39 - I46 頁，民國 88 年 7 月。
  4. 鄭子璉、周乃昉、胡文盛，「 高度平衡多邊形法之數值計算 」，1999 中華地理資訊學會學術研討會，臺灣，台中，民國 88 年 12 月。

註：螢幕保護程式相關技術請參閱 培基語言 網頁 螢幕保護 篇。