曾文水庫防洪運轉資訊系統操作手冊

國立成功大學

水利及海洋工程學系暨研究所

中華民國八十八年五月


第一章　曾文水庫防洪運轉資訊系統

    在本研究中電腦化作業項目依研究內容分離為三部份獨立進行，水庫進水量推算及預估、水庫最佳放水策略分析及下游河道水位或流量預估，惟此三個模擬分析模式均由各研究人員獨立進行，各模式分析求得資料彼此無法直接進行演算分析，因此需配合所有運算分析部分進行整合系統之發展，俾使所有計算程序得以順利分析完成。

    在本研究中發展環境採用 Win32 環境相容之作業系統， Win32 環境相容之作業系統有 Windows 95/98 與 Windows NT 4.0/5.0 等兩種作業系統，透過 Win32 環境所提供的圖形介面環境將使操作介面在開放上所需的時間更短，並且對於操作人員在執行分析運算時可從視覺上直接瞭解，而在短時間內可進行決策及判斷。

    在開發模組系統採用之工具為 Visual BASIC 5.0 中文專業版及 Visual Fortran 5.0 專業版搭配使用， Visual BASIC 在圖形介面上開發較為容易，透過 Visual BASIC 的視覺導向設計可在使用者介面開發上更為便捷，而 Visual BASIC 為事件驅動的語言，可依據使用者的不同點選情況下進行分析。 Visual Fortran 採用 ANSI Fortran 90/95 相容語法， Fortran 語言在數值分析上較簡便及快速，且一般土木水利工程師對於 Fortran 語言較為熟悉，在數值計算上便於發展系統。

1.1　系統軟硬體需求

    為確保防洪運轉資訊系統持續運作，在現場實際運作應有兩組軟硬體設施，一組為主要操作系統，另一組為備份操作系統，在各時段操作完成後，可透過內部網路系統將資料備份至備份系統，若遇主系統發生故障，除應立即修復外，並可立即將分析工作移轉至備份系統操作，確保防洪運轉資訊系統持續運作。

1. 硬體基本配備

    基本硬體需求為 Microsoft Windows 98 中文版及 Microsoft Excel 97 中文版能運作順暢，考慮維持基本執行效率上，擬定基本硬體配備如表 1.1.1。

2. 硬體升級考慮事項

    在硬體損壞後更新其零組件時，或其零組件在採購其配備與價格優勢較基本配備為佳時，應考慮因素列於表 1.1.2。

3. 軟體需求

    在防洪運轉資訊系統中使用到 Microsoft Excel 及 Lindo Systems Inc. Lingo ，應購買上述兩項軟體以取得合法使用版權。

表 1.1.1　硬體基本配備

項目 | 最低需求 | 說明
中央處理器(CPU) | Pentium II 233 | 以 Pentium II 233 執行可確保每一操作階段執行所需時間在 5 分鐘內。
硬式磁碟機(HD) | 剩餘 400 MB 以上 | 安裝防洪運轉資訊系統前應保有 400 MB 以上之硬碟空間，系統使用 20 MB，資料使用保留 180 MB，至少需保留 200 MB 大小供作業系統使用，以確保作業系統運作之順暢。
動態記憶體(DRAM) | 32 MB/70 ns | 建議以 64 MB 60 ns 可在 Microsoft Excel 部分操作更為順暢。
顯示卡(VGA) | WinFast S680/4MB | 建議螢幕解析度維持 800x600 以上。
光碟機(CD-ROM) | 有 | 安裝防洪運轉資訊系統時使用。
滑鼠、鍵盤等 | 有 | 以操作便利為原則。
網路卡 | 有 | 備份各時段資料使用。
不斷電系統(UPS) | 有 | 保護電腦電路、維持電力供應。

表 1.1.2　硬體升級考慮配備

項目 | 硬體升級考慮事項
中央處理器(CPU) | 本系統在發展時以單一 CPU 為使用對象而發展程式及編譯，因此不需考慮多 CPU 之硬體，以單一 CPU 能更高速執行為升級目標，但必須內含浮點輔助運算器以提昇運算速度。
硬式磁碟機(HD) | 作業系統使用量遠較本系統為大，應提供作業系統 200 ~ 400 MB 的硬式磁碟空間以供作業系統記憶體切換、暫存檔使用，確保作業系統運作之順暢，操作資料應適當備份至唯讀光碟上。
動態記憶體(DRAM) | 在 Microsoft Windows 98 中文版最大至 128 MB 就已充分足夠，在 Microsoft Windows NT 中文版最大至 256 MB 就已充分足夠，必要時可考慮執行時間較短 (ns) 的記憶體。
顯示卡(VGA) | 在 Microsoft Windows 環境中，螢幕更新速度會影響作業系統執行速度，因作業系統會等待螢幕顯示完成後方進行下一個計算動作，因此硬體升級時應考慮顯示卡是否具有視窗加速之功能，以視窗加速功能的效果為主要評估項目，顯示卡上的 SRAM 依目前電子技術建議以 16 MB 為上限。
光碟機 | 考慮備份操作資料可選擇大容量、速度快之可讀寫光碟，例如 DVD-RW 。
滑鼠、鍵盤等 | 以操作便利為原則。
網路卡 | 一般使用以 100 M 的網路卡已十分充足使用。
不斷電系統(UPS) | 以維持曾文水庫管理中心電力中斷後，防洪運轉室切換至發電機所需之最大轉換時間為最低需求。

1.2　安裝系統

    本計畫中採用標準的安裝程式來安裝「曾文水庫防洪運轉資訊系統」。安裝系統可透過工具列上的執行或檔案總管來完成，假定採用工具列上的執行來安裝，如圖 1.2.1 ，d:\setup 為安裝程式所在的路徑，打入開啟項目後，利用滑鼠在確定鈕上按一下。

圖 1.2.1　執行安裝程式

    當按下確定鈕後，安裝程式將先開始複製部分基本安裝程式到硬碟，以便進行後續的交談式對話安裝，俟複製完畢後進入歡迎畫面。如圖 1.2.2 ，安裝程式會建議盡量將不需要的程式關閉，並將共用的最新版元件安裝到系統目錄中，若有程式正在使用舊版的元件，則會因該元件被系統使用中而導致安裝程式失敗，在安裝時最好不要開啟其他應用程式，繼續可利用滑鼠在確定鈕上按一下。

圖 1.2.2　進入安裝程式歡迎畫面

    當按下確定鈕後，安裝程式將接著詢問使用者安裝目錄是否正確，預設是 Windows 98/NT 的 Program Files\曾文水庫防洪運轉資訊系統\ 目錄下，若要改變安裝的目錄，可利用「改變目錄」的按鈕來選定要更改或新建立的目錄。在程式安裝目錄設定完畢後，可利用滑鼠按下大的安裝鈕進行系統的安裝，如圖 1.2.3 。隨即安裝程式將系統安裝到指定的目錄，並將安裝的進度顯示在螢幕上，如圖 1.2.4 。俟安裝達到百分之一百後會依序建立程式群組、捷徑，最後顯示系統已成功完成安裝，如圖 1.2.5 。

圖 1.2.3　確認系統安裝目錄

圖 1.2.4　系統安裝進度

圖 1.2.5　系統安裝完成並成功安裝

1.3　移除系統

    若要移除曾文水庫防洪運轉資訊系統，並可利用『控制台』『新增/移除程式』來完成反安裝的工作，如圖 1.3.1 ，在列表中選擇「曾文水庫防洪運轉資訊系統」並按下『新增/移除』鈕，則安裝程式會自動進行系統的反安裝，如圖 1.3.2 。

    為確認是否正確操作移除動作，反安裝程式會詢問是否確定移除系統，如圖 1.3.3 ，若要放棄移除系統，此時可選擇『否』，若確認移除動作，此時可選擇『是』，當完成移除系統，會展示如圖 1.3.4 的畫面。

圖 1.3.1　選擇移除曾文水庫防洪運轉資訊系統

圖 1.3.2　移除曾文水庫防洪運轉資訊系統

圖 1.3.3　詢問是否確定移除系統

圖 1.3.4　成功完成移除系統

1.4　啟動系統

    安裝完成後，會在開始工具列產生一個捷徑，往後執行本系統只要在開始工具列上點選「曾文水庫防洪運轉資訊系統」即可，如圖 1.4.1 ，或可經由檔案總管執行視窗來啟動「曾文水庫防洪運轉資訊系統」。

圖 1.4.1　透過開始工具列執行曾文水庫防洪運轉資訊系統

1.5　結束系統

    以滑鼠點選系統視窗右上角的 [image] 鈕，或由系統選單『檔案』、『結束』來終止系統執行，若此時專案參數已更新卻未進行存檔，系統會詢問是否要更新專案參數資料，若要更新可按確定鈕，否則按取消鈕。


第四章　曾文水庫防洪運轉資訊系統檔案

4.1　相關檔案列表及說明

表 4.1.1　主要執行檔及參數檔列表與說明

檔名或目錄名 | 說明
830801\ | 範例目錄
880619\ | 範例目錄
DAMRUN.exe | 水庫防洪運轉資訊系統執行檔
Damrun.ini | 水庫防洪運轉資訊系統參數檔
Flood\ | 下游河道變量流演算目錄
Flood\flood.exe | 下游河道變量流演算執行檔
Flood\section.txt | 下游河道斷面編號檔
GIS\ | 曾文溪流域地理資訊資料目錄
GIS\TWAll.WET | 曾文水庫電傳雨量站徐昇加權因子組合
GIS\TWGIS.txt | 曾文溪流域數化邊界及下游控制點數化資料
Grapher\ | 繪圖檔目錄
Grapher\tsengwen.GRF | 曾文水庫集水區平均降雨、水庫水位、水庫放水量歷線
Inflow\ | 水庫進水量分析目錄
Inflow\inflow.exe | 水庫進水量分析執行檔
Operate\ | 水庫最佳操作策略目錄
Operate\ELtoVal.txt | 水庫水位容積曲線
Operate\Resoper.exe | 水庫最佳操作策略主程式
Template\ | 分析時所運用之樣本檔目錄
Template\I.DAT | 水庫下游河道斷面樣本檔
Template\IBC.DAT | 水庫放水量樣本檔
Template\Prv.int | 水庫最佳操作策略參數設定樣本檔
Template\Template.xls | 曾文水庫雨量水位輸入樣本檔

表 4.1.2　原始碼列表與說明

檔名或目錄名 | 說明
*.vbw, *.frx | 各原始檔案在螢幕上位置之紀錄資訊
damrun.vbp | 專案檔
frmAbout.frm | 版權說明介面
frmBasicGIS.frm | 集水區邊界及下游控制點展示介面
frmChart.frm | 水庫水位、水庫放水量歷線展示介面
frmDataGrid.frm | 格狀輸出介面（在先前版本使用、目前版本未用）
frmDocument.frm | 水庫水位容積曲線
frmMain.frm | 主程式執行介面
frmRunoff.frm | 降雨逕流展示介面
frmSplash.frm | 起始執行展示介面
GISTools.bas | 地理資訊模組
Project.frm | 雨量專案管理
StartUp.bas | 起始執行模組及共用程式模組

4.2　檔案格式說明

4.2.1　曾文溪流域數化邊界及下游控制點數化資料

    依 [GIS\TWGIS.txt] 檔內容分成三大節區，依各節區內容分別加以說明。

1. [Polygon1]

表 4.2.1　Polygon1 節區各參數說明

[Polygon1] | 節區內設定流域多邊形資料節區 | 範例
Name=BasinSectionName | 本項目指定資料節區 | Name=TWBasin
Number=BasinPointNumber | 本項目指定資料有效個數 | Number=203
Polygon=Balloon | 本項目前暫無使用 | Polygon=True

2. [BasinSectionName]

    節區內為流域多邊形座標資料節區，採自由格式，僅需以空白將 x 座標及 y 座標隔開即可，節區名由 [Polygon1] 中 Name= 項指定。

    範例：

[TWBasin]
220155.5625 2599730.75
219516.40625 2599262.5
[略]
221355.796875 2598918.75
220155.5625 2599730.75

3. [RainStation]

    雨量站資料節區，節區內採格式輸入。

表 4.2.2　 RainStation 節區檔案格式說明

項目 | 說明
站名 | 第 1-12 可輸入站名
雨量站座標 | 採可變長度定義 ( X , Y ) ， X 由前括號﹝(﹞至逗號﹝,﹞之間的數值表示，Y 由逗號﹝,﹞至後括號﹝)﹞之間的數值表示

    範例：

[RainStation]

站名 | 二度分帶座標
西港大橋 | (167491.0000,2557746.0000)
高速公路橋 | (172058.0000,2559265.0000)
麻善大橋 | (173952.0000,2563671.0000)
縱貫鐵路橋 | (179282.0000,2563054.0000)
曾文溪橋 | (182162.0000,2561613.0000)
北勢洲橋 | (182856.0000,2557715.0000)
二溪大橋 | (186552.0000,2557149.0000)
走馬瀨橋 | (191484.0000,2559636.0000)
豐里橋 | (193136.0000,2558080.0000)
中正橋 | (195354.0000,2559950.0000)
紹興吊橋 | (195623.0000,2564238.0000)
曾文一橋 | (195979.0000,2564830.0000)
曾文二橋 | (196452.0000,2565541.0000)
曾文三橋 | (197992.0000,2566370.0000)
曾文五橋 | (197873.0000,2567435.0000)
曾文水庫 | (202619.0000,2572122.0000)


第二章　曾文水庫防洪運轉資訊系統專案管理

2.1　開啟新專案

    「曾文水庫防洪運轉資訊系統」採用專案管理之觀念進行分析，圖 2.1.1 是啟動執行並點選『檔案』選單的說明，若是新建立之專案可選用『建立』來開啟新專案。

    圖 2.1.2 是建立新專案的對話視窗，新建立之專案檔名預設採用曾文水庫之縮寫及操作當日之國曆年月日為預設檔名，若需採用其他檔名或目錄可在此對話盒中操作，建議依各專案獨立開啟一新目錄，便於日後資料管理與維護。圖 2.1.3 是新專案開啟後的系統設定畫面，相關系統各參數設定將在 2.3 節中說明。

圖 2.1.1　曾文水庫防洪運轉資訊系統檔案選單

圖 2.1.2　開啟新專案檔名輸入

圖2.1.3　開啟後新專案的對話窗

2.2　開啟舊專案

    「曾文水庫防洪運轉資訊系統」採用專案管理之觀念進行分析，圖 2.1.1 是啟動執行並點選『檔案』選單的說明，進行中或已完成的專案可以以『開啟』選單開啟已存在之專案。

    如圖 2.2.1 ，是開啟已存在專案的對話視窗，圖中開啟的檔案為一測試範例，雨量在資料是以專案方式儲存，依附各專案檔所在目錄儲存，將欲開啟的資料檔點選後，以滑鼠在開啟舊檔上點選一下，即執行開啟動作。圖 2.2.2 是新專案開啟後的系統設定畫面，相關系統各參數設定將在 2.3 節中說明。

圖 2.2.1　開啟已存在專案檔名輸入畫面

圖 2.2.2　開啟後已存在專案的對話窗

2.3　設定專案參數

    專案對話視窗中，依各相關設定值輸入，如圖 2.3.1 中，依中央氣象局在暴雨或颱風前所預估的總降雨量輸入，依序輸入預測可能的降雨延時、降雨開始時間、及暴雨或颱風的命名；其中降雨開始時間應依格式 [西元年/月/日 時:分:秒] 輸入，系統會自動判別輸入資訊並轉換成正確日期格式更新顯示在降雨開始時間這一格。在氣象局預測全日降雨量這格中只接受數字及小數點輸入，在氣象局預測全日降雨時段數這格中只接受數字輸入，以上兩格不接受全形文字及其他按鍵，若發生系統無反應時，請檢查是否處於中文輸入下，若為中文輸入請切換回英數輸入。

    在檔案列表中，若為空集合則顯示『目前沒有指定任何相關檔案』，若要新增雨量資料檔可以由右側按鈕上選擇『新增』，系統會跳出新增檔案對話盒，如圖 2.3.2 ，新建立之資料檔名預設採用操作之縮寫及操作當日之國曆年月日為預設檔名，若需採用其他檔名或目錄可在此對話盒中操作，建議依各日期設定檔名，便於日後資料管理與維護。若要開啟已存在的雨量資料檔可以由右側按鈕上選擇『加入』，系統會跳出開啟檔案對話盒，如圖 2.3.3 ，若重複加入或加入錯誤的雨量資料檔，可由右側按鈕上選擇『刪除』，系統會刪除專案中對資料檔的引用，但並不刪除資料檔，選擇刪除時，系統會跳出確認刪除檔案引用對話盒，如圖 2.3.4 。

    而顯示之檔案順序由上而下則代表時間優先順序由前而後，考慮建檔檔名可能與時間沒有關聯的情況下，必須以人工操作來確認各資料檔的先後順序，若需調整，可以以右側按鈕上選擇『上移』、『下移』調整。

圖 2.3.1　相關系統參數設定

圖 2.3.2　新增檔案對話盒

圖 2.3.3　選擇加入已存在的雨量資料檔

圖 2.3.4　移除對資料檔案的引用

圖 2.3.5　調整檔案先後順序

2.4　儲存專案

    若要儲存目前的參數設定，可由下側按鈕上選擇『存檔』，如圖 2.3.1 。

2.5　結束專案

    以滑鼠點選專案管理對話盒右上角的 [image] 鈕即可結束專案，若已修改專案內容而尚未存檔，系統會詢問是否要更新專案參數資料，若要更新可按確定鈕，否則按取消鈕，如圖 2.5.1 。

圖 2.5.1　確認專案存檔對話盒


第三章　曾文水庫防洪運轉資訊系統運作

3.1　水庫進水量預估

1. 資料的輸入與修正

    在檔案列表降雨資料檔檔名以滑鼠進行雙觸擊，可自動進入 Microsoft Excel 進行雨量修正或新增，如圖 3.1.1 ，在 Excel 表格中輸入各電傳雨量站小時降雨量資料，若發生某電傳雨量站故障，則該格雨量資料採不輸入處理，圖 3.1.1 中假設三角南山電傳雨量站在第 18 時以後發生故障的情形。

    雨量輸入修正完畢後，應一併輸入相對同時間的水庫水位及各放水量的情形，如圖 3.1.2 ，圖中假設僅有曾文電廠放水的情形。修改完畢後關閉 Microsoft Excel 即可返回整合系統。

2. 更新徐昇加權因子

    根據已完成修正的降雨量組合情形，應修正配合的徐昇加權因子，在專案對話盒下方按下『更新』鈕，即可針對專案內所有的雨量資料檔進行分析，根據已輸入完成之雨量資料分析，若無該電傳雨量站雨量資料則視為該電傳雨量站故障，即從資料庫中選取其所對應的徐昇加權因子組合，在此部份計算採用背景進行，畫面上不會有任何顯示，分析完成後會將各時段各雨量站所對應之徐昇加權因子填入雨量資料檔內的徐昇加權因子表格中，可開啟降雨資料檔觀看，如圖 3.1.3 。

3. 執行水庫進水歷線分析及推估

    在專案對話盒下方按下『分析』鈕，即會立即分析現有雨量資料檔內之平均降雨，分析完成後進行全期降雨歷線及水庫進水歷線的推估，分析完畢後會產生表格式的計算輸出及圖形輸出， 上半部展示觀測降雨及推估降雨所合成的雨量組體圖，下半部展示水庫進水歷線推估的部分，如圖 3.1.4 。

圖3.1.1　輸入各電傳雨量站小時降雨量資料

圖 3.1.2　水庫水位與放水量輸入

圖 3.1.3　更新後的徐昇加權因子表

圖 3.1.4　預估水庫集水區的平均降雨與水庫進水量

3.2　水庫最佳放水策略分析

    如圖 3.2.1 中在功能表選單『分析』下選擇『防洪運轉策略』，會跳出如圖 3.2.2 之操作介面，按下『分析』鈕後將會做線性疊代分析最佳放水策略，疊代分析過程如圖 3.2.3 ，疊代過程中的效率係數會即時顯示，當效率係數大於 0.995 時，即視為收斂，終止疊代。

    分析完成後如圖 3.2.4 ，按下『結束』鈕後將返回整合系統，即會展示如圖 3.2.5 ，系統展示水庫進水歷線、放水操作歷線及水庫水位歷線。

圖 3.2.1　防洪運轉策略功能表

圖 3.2.2　最佳策略分析模式參數設定

圖 3.2.3　疊代過程執行畫面

圖 3.2.4　計算完成後最佳策略分析模式

圖 3.2.5　水庫水位歷線與水庫放水策略歷線

3.3　下游河道變量流演算

    在功能表選單『繪圖』下選擇『曾文溪流域區』，會跳出如圖 3.3.1 之操作介面，系統可以透過滑鼠圈選範圍放大所需區域，選擇欲分析之流量站以滑鼠左鍵點選，若想要取消選擇欲分析之流量站以滑鼠右鍵點選，如圖 3.3.2 。

    以滑鼠點選所欲分析之下游控制點後，以滑鼠進行雙觸擊，即進行下游變量流演算，計算分析過程如圖 3.3.3 ，計算分析結果如圖 3.3.4 ，操作範例選擇展示走馬瀨橋、西港大橋之流量歷線。

圖 3.3.1　曾文溪流域及其水位控制點

圖 3.3.2　曾文溪流域及其水位控制點放大圖

圖 3.3.3　下游變量流演算演算

圖 3.3.4　下游各控制站流量歷線圖


編寫人員

計畫主持人：周乃昉、蔡長泰、游保杉

專責研究人員：鄭子璉、林淑真、蔡智恆

協同研究人員：邊孝倫、黃偉麟、吳依芸、鄭志偉、林智信