第一章　曾文水庫暨曾文溪流域水情蒐集分析查詢系統

1.1　系統軟硬體需求

1.2　安裝自動擷取資料設定

1.3　移除自動擷取資料設定

1.4　啟動自動擷取資料設定

1.5　設定Surfer軟體權限

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第一章 | 前一章 | 後一章

系統開發及維護：水海科技系統研發驗證工作室 鄭子璉 (Tzu-Lien, Cheng)


1.1　系統軟硬體需求

    系統軟硬體需求可能受市場軟硬體版本更新及委辦單位實際採用軟硬體影響，本節視撰稿最新情況予以更新，提供委辦單位參考。

    水情蒐集分析查詢系統分離為兩個獨立部分，分別為自動擷取資料及網頁查詢展示。發展環境採用與Windows 2000 Server搭配SQL Server 2000開發版，自動擷取資料採用Visual BASIC 6.0中文企業版撰寫開發，網頁查詢檔案採用Visual Studio .Net 2003撰寫開發，採用Visual Studio .Net 2003開發僅因該軟體完整連結相關線上手冊供開發時參考，委辦單位於平時瀏覽或修改原始碼時，可採用Office XP所附贈之Microsoft Script Editor 編輯器，此軟體即為前述軟體之精簡版。

1.1.1　系統硬體需求

    考慮建置成本下，水情蒐集分析查詢系統可與現有資料庫系統合併服務，但應考慮現有資料庫及資料伺服器間是否會互相干擾，由於目前電腦成本低廉，仍建議另行購置。為確保防洪運轉決策支援系統持續運作，建議在現場實際運作應採兩組軟硬體設施，一組為主要操作系統，另一組為備份操作系統，備份系統可由目前運轉中心展示電腦擔任，可降低硬體購置成本。

1. 硬體基本配備

    依目前市場可購置硬體推估，資料蒐集分析查詢系統基本硬體需求為 Microsoft Windows 2000 Server 中文版及 Microsoft SQL 2000 Server 中文版能運作順暢為原則，考慮維持基本執行效率上，擬定基本硬體配備如表 1.1-1。

2. 硬體升級考慮事項

    在硬體損壞後更新其零組件時，或其零組件在採購其配備與價格優勢較基本配備為佳時，建議基於系統整體效能提高為考慮原則予以更換。

1.1.2　系統軟體需求

    水情蒐集分析查詢系統應安裝Microsoft Windows 2000 Server以上版本及Microsoft SQL Server 2000以上版本。由於資料伺服器上需定時擷取資料，應另安裝網路校時程式，以利自動校時，可參閱表1.1-2。

    研究中所發展之相關模組均編譯成執行檔，並協助委辦單位安裝，故原始碼之編譯及編輯程式非屬必備，不列入軟體清單，原始碼均將存成ASCII格式，可採任一支援該格式之編輯程式瀏覽。

表1.1-1　資料蒐集分析查詢系統硬體需求

項目 | 最低需求 | 說明
中央處理器 (CPU) | P4 2G MHz 以上 | P4 2G MHz 為目前市面桌上型電腦接近最低硬體等級。
硬式磁碟機 (HD) | 剩餘容量 2 GB 以上 | 安裝防洪運轉分析系統前應保有 10 GB 以上之硬碟空間，資料庫在儲存運轉資料會逐漸增長，且系統進行運用時，亦需硬碟空間做為虛擬記憶體，應隨時注意剩餘容量，並維持安裝後系統硬碟及資料儲存硬碟剩餘容量各1GB以上，若小於此值時，應考量移除歷史資料或更新系統儲存設備。
動態記憶體 (DRAM) | 512 MB 以上 | 建議採用 1 GB 可在 Windows 2000 Server 部分操作更為順暢。
顯示卡 (VGA) | 支援視窗加速 32MB 以上 | 建議螢幕解析度維持 1024 x 768 以上，顯示卡記憶體最好不要與系統共用或分享。
光碟機 (CD-ROM) | 有 | 安裝系統時使用，建議選用燒錄機可定期備份使用。
滑鼠、鍵盤等 | 有 | 以操作便利為原則。
網路卡 | 100 Mbps | 自動擷取資料南水局既有資料庫使用。
網路卡 | 100 Mbps | 自動擷取資料氣象局及防洪運轉系統存取使用。
不斷電系統 (UPS) | 有 | 保護電腦電路不受突波損毀，維持電力供應至發電機啟動運轉為止。

表1.1-2　防洪運轉決策支援系統套用既有套裝軟體

項目 | 軟體使用狀況
Microsoft Office XP 以後版本 | 本研究所採用之文件、資料及圖檔，均採本套軟體相容格式建置。
Golden Software Surfer 8.0 以後 | 本項軟體供系統背景繪製等雨量線圖使用，建議採用本項套裝軟體 8.0 以上版本。
Microsoft Data Access Components 2.8 以後版本 | 本項軟體為系統資料庫增強物件之一，依軟體授權許可第一款第一項，可免費隨應用軟體之一部份而一併加以轉散佈或交由第三者轉散佈之，因此本項軟體不需額外購買，可隨本系統安裝光碟或上網(http://www.microsoft.com/taiwan/)免費取得。
Microsoft Office Web Components 10.0 | 本項軟體為繪圖元件，同時供兩系統繪圖使用，係為Office XP內建物件之一，依軟體授權許可允許企業內部網路傳送此元件，因此本項軟體不需額外購買，由於本項軟體目前並不前向相容，且暫時無最新相容版本，故須限定使用10.0版，可上網(http://www.microsoft.com/taiwan/)免費取得。
MSDE 2000 SP3a 以後版本 | 若暫不購置SQL Server 2000，可採免費版本 MSDE 2000取代，唯其資料庫大小不得超過2 GB，且不含操作介面進行資料庫操作，操作介面可透過SQL Server 2000試用版安裝client端取得，本項軟體不需額外購買，可隨Office XP安裝光碟、本系統安裝光碟或上網(http://www.microsoft.com/taiwan/)免費取得。
ntpClock 1.21 以後版本 | 於防洪運轉期間多數功能均定時自動執行，故應達成時間上之精準，建議採用網路校時程式為時間與頻率國家標準實驗室提供之國家時間同步服務，其時間與經濟部標準檢驗局標準鐘及117報時台同步，時間誤差在1毫秒內，可隨本研究安裝光碟或上網(http://www.stdtime.gov.tw/)免費取得。

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第一章 | 前一節 | 後一節


1.2　安裝自動擷取資料設定

    水情蒐集分析查詢系統核心程式為網頁程式，必須手動安裝至系統網頁服務目錄。「自動擷取資料設定」程式採用標準的安裝程式來安裝。可透過工具列上的執行或檔案總管來完成，假定採用工具列上的執行來安裝，如圖1.2-1，L:\temp\setup\GetData\setup.exe為安裝程式所在的路徑，打入開啟項目後，利用滑鼠在確定鈕上按一下。

圖1.2-1　執行安裝程式

    當按下確定鈕後，安裝程式將先開始複製部分基本安裝程式到硬碟，如圖 1.2-2，以便進行後續的交談式對話安裝，俟複製完畢後進入歡迎畫面。如圖 1.2-3，安裝程式會建議盡量將不需要的程式關閉，並將共用的最新版元件安裝到系統目錄中，若有程式正在使用舊版的元件，則會因該元件被系統使用中而導致安裝程式失敗，在安裝時最好不要開啟其他應用程式，繼續可利用滑鼠在確定鈕上按一下。

圖1.2-2　正在複製檔案

圖1.2-3　進入安裝程式歡迎畫面

    當按下確定鈕後，安裝程式將接著詢問使用者安裝目錄是否正確，預設為 Windows Server 2000 的「C:\Program Files\GetData\」目錄下，若要改變安裝的目錄，可利用「改變目錄」的按鈕來選定要更改或新建立的目錄。在程式安裝目錄設定完畢後，可利用滑鼠按下大的安裝鈕進行系統的安裝，如圖1.2-4。隨即安裝程式將系統安裝到指定的目錄，並將安裝的進度顯示在螢幕上。俟安裝達到百分之一百後會依序建立程式群組、捷徑，此時若無需變更，可直接按下繼續，如圖1.2-5，最後顯示系統已成功完成安裝，如圖1.2-6。

圖1.2-4　確認系統安裝目錄

圖1.2-5　系統安裝程式群組

圖1.2-6　系統安裝完成並成功安裝

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第一章 | 前一節 | 後一節


1.3　移除自動擷取資料設定

    若要移除曾文水庫防洪運轉決策資訊系統，並可利用『控制台』『新增/移除程式』來完成反安裝的工作，如圖1.3-1，在列表中選擇「自動擷取資料設定」並按下『變更/移除』鈕，則安裝程式會自動進行系統的反安裝。

    為確認是否正確操作移除動作，反安裝程式會詢問是否確定移除系統，如圖1.3-2，若要放棄移除系統，此時可選擇『否』，若確認移除動作，此時可選擇『是』，當完成移除系統，會展示如圖1.3-3的畫面。

圖1.3-1　選擇移除曾文水庫防洪運轉決策資訊系統

圖1.3-2　詢問是否確定移除系統

圖1.3-3　成功完成移除系統

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第一章 | 前一節 | 後一節


1.4　啟動自動擷取資料設定

    安裝完成後，會在開始工具列產生一個捷徑，往後執行本系統只要在開始工具列上點選「自動擷取資料設定」即可，如圖1.4-1，或可經由檔案總管執行視窗來啟動「自動擷取資料設定」。本模式應常駐系統自動執行，建議放入啟動模組執行。

圖1.4-1　透過開始工具列執行自動擷取資料設定

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第一章 | 前一節 | 後一節


1.5　設定Surfer軟體權限

    若未正確設定Surfer軟體權限，在ASP網頁中將無法正確顯示，基本上通常不能執行的錯誤訊息是權限不足，如說如圖1.5-1所示。

圖1.5-1　未正確設定權限無法執行

    當在開發階段時，若是發生沒有使用權限: 'CreateObject' 這類錯誤，而其他元件又可以用，主要是這個目標元件權限要修正。

    首先是預設權限，如果IIS採用匿名存取，則會使用IUSR_servername的權限(servername 是伺服器的電腦名，之後不再重複說明) ，因為是屬於Guests群組，所以可能會在伺服器的電腦上不能寫入檔案，比如說Word開啟時，會在工作目錄及暫存目錄開啟暫存檔，而IUSR_servername在伺服器電腦上是沒有暫存目錄的，所以問題會更複雜。解決不能沒有權限存取的方法主要分成兩種，一種是調高IUSR_servername的權限，使他在伺服器電腦上能存取檔案，但是一方面危險，一方面須浪費硬碟等。另一種方式是替伺服器的目標元件建立代理使用者，建立代理使用者就是在系統中建立或挑選一個足夠權限的使用者，以他的名義執行該元件，管理的時候，最好另建立一個，在伺服器電腦上建立一具有足夠權限之帳號AutoOperate來執行。設定步驟如下：

1. 執行 dcomcnfg.exe

2. 修改安全性設定。如果要省事，或是使用到很多元件，可以修改預設值，若是不喜歡修改預設值，也可以先執行步驟 5 選定元件後，單獨設定該元件的安全性。

3. 設定存取權。在這裡把 servername 遮掉了以減少可能被攻擊機會，需要透過新增按鈕將使用者 IUSR_servername 及 IWAM_servername 設定允許存取。

4. 設定啟動權。需要透過新增按鈕將使用者 IUSR_servername 及 IWAM_servername 設定允許存取。

5. 選擇目標元件，選擇Surfer。

6. 設定代理執行人，設定AutoOperate帳號及密碼，不過要記住，若代理執行人密碼更改時，一定要來這個對話盒改，否則會無法執行。

7. 其他權限設定。Surfer元件必須由ASP動態產生檔案，透過檔案總管設定那個目錄供IUSR_servername這個帳戶存取，此時該目錄應設定此屬性。

    Surfer是透過支援Automation的軟體繪製等雨量線，需由ASP產生純文字檔當輸入檔，所以才需要設定這個屬性。相關權限設定完畢後，系統就可以執行你所要的元件了。如圖1.5-2等雨量線已可繪製。

圖1.5-2　完成權限設定後可正確執行系統

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第一章 | 前一節 | 後一節


第二章　自動擷取資料設定

2.1　時間設定

2.2　資料庫存取設定

2.3　氣象局資料檔存放設定

2.4　其他操作功能

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第二章 | 前一章 | 後一章


2.1　時間設定

    自動擷取資料設定會定時自動分析與搜尋相關資料庫及檔案，非必要應避免人工手動操作，以降低重複匯入資料的情形，以小時為單位之各項功能均會檢查資料庫內是否已有既有資料，有既有資料採更新方式，無資料時則採新增方式，然其他操作則採用刪除資料庫內相關資料後，直接新增資料以提高執行效能。

    各項功能均有類似下列區塊，其中StartTime指每小時整點後自動啟動執行之位移時間，如下例，指每整點一分自動執行，SetpTime指每次自動執行成功後之間隔時間，如下例設定，將在六分、十一分、…到五十六分自動執行。

[w2k2_Source]
StartTime=00:01:00
SetpTime=00:05:00
Status=65536

    Status為該項功能定時自動擷取狀態，啟動模式時讀取，關閉模式時更新，若關閉模式時定時自動擷取設定為關閉，則下次啟動時會引用關閉之設定，直至啟動被按下為止，如圖2.1-1。

圖2.1-1　氣象局雨量自動擷取設定在啟動狀態

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第二章 | 前一節 | 後一節


2.2　資料庫存取設定

    各資料庫存取設定均類似下列區塊，Server為SQL Server網路上的伺服器名稱，Database為資料庫名稱，ListTable為資料項目列表之表名，DataTable為目標存取資料表名稱，其中，中括號所包含之符號為日期格式，針對存取資料之時間進行自動轉換，yyyy表西元年，mm表月份，&Hm;表示月份採16進位轉換，TemplateTable為樣本資料庫，當發生資料時間需新增資料庫時，將依據樣本資料庫自動產生，UserName為存取資料庫之使用者帳號，Password為存取資料庫之使用者密碼。

[Rain_Target]
Server=(local)
Database=Rain
ListTable=list
DataTable=hr_[yyyy]
TemplateTable=hr_樣本
UserName=xxxxxxxx
Password=xxxxxxx

註：帳號密碼屬業務機密，操作說明不顯示，設定檔內採明碼設定

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第二章 | 前一節 | 後一節


2.3　氣象局資料檔存放設定

    氣象局之雨量與颱風資料須透過FTP擷取，相關設定如下，IP為FTP伺服器位置，可採用domand name或實體IP，username為氣象局提供之登入帳號，password為氣象局提供之登入密碼，port為該FTP協定通訊時所採用之通訊阜，path為該伺服器上之目錄名稱，FileFormat為欲擷取檔案檔名之格式，日期轉換同前節所述，DownloadPath為擷取下來之檔案所存放路徑，可採(AppPath$)來組合成相對路徑或直接使用絕對路徑，日期轉換同前節所述，AppTitle為連線產生時，通知FTP伺服器登入之軟體名稱。

[cwb_FTPServer]
IP=dcsdat1.cwb.gov.tw
username=xxxxxxx
password=xxxxxx
port=21
path=/wcb
FileFormat=h4[&Hm;ddhh]0.txt
DownloadPath=E:\歷年計畫\中央氣象局\即時小時雨量\[yyyy]\[mm]
AppTitle=南區水資源局連線至中央氣象局精靈

註：帳號密碼屬業務機密，操作說明不顯示，設定檔內採明碼設定

    颱風資料與雨量資料不同，雨量資料配合時間採自動檔名，可依雨量檔名精準取得特定時間之檔案，颱風資料採固定檔名，每次抓取時，僅能取得最新資料，且中央氣象局之檔案時間無法做為資料時間判斷的依據，故於資料庫內建立檔案對照表擷取資料，當氣象局檔案之大小或時間不同時，視為新資料進行擷取，並考慮擷取時可能發生該資料正在寫入中，導致所擷取得資料並非完整資料情形者，將自動重新擷取，如圖2.3-1所示。

圖2.3-1　資料庫內氣象局檔案對照表

    擷取得到之檔案，依「存放路徑」設定存放入子目錄，若無該子目錄，則自動建立該子目錄，依類別存放於不同子目錄，並依照事件、資料時間重新為資料檔命名並組合保留之原始檔名，以利判別原始檔名，如圖2.3-2所示。

圖2.3-2　自動依檔案內容及時間歸類到不同目錄

    本年度颱風資料並不建立展示介面，颱風資訊及文字資料則自動匯入資料庫內，若無發佈颱風警報之颱風，則僅將可得之颱風資訊納入，若發佈颱風警報之颱風，則颱風警報單上所有文字及未刊載之額外資訊，均匯入資料庫供往後相關分析參考，如圖2.3-3所示。

圖2.3-3　所有氣象局公佈資訊均匯入資料庫內

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第二章 | 前一節 | 後一節


2.4　其他操作功能

    若發生氣象局伺服器故障，但可從其他方式取得雨量資料時，可手動匯入雨量資料，並選擇一至多個需匯入之雨量檔後，按下開啟即可，如圖2.4-1所示。

    其中需注意事項為：

  1. 本項匯入資料並不會預先刪除資料庫內既有資料，應先確認資料庫內無重複資料後再透過手動匯入。
  2. 本項匯入資料匯入完成後，並不會自動執行雨量品管及平均雨量計算，若需進行資料品管，應手動啟動。

圖2.4-1　手動匯入雨量資料

    若手動匯入資料後須進行雨量品管或平均雨量重新計算，應由手動重算功能執行，經選定開始時間至結束時間後，選擇開始即可，如圖2.4-2所示。

    其中需注意事項為：

  1. 雨量品管或平均雨量重新計算均需各別設定執行。
  2. 在定時自動擷取資料時，當發生氣象局雨量匯入資料庫後，將自動執行雨量品管，並依據品管結果計算平均雨量，其中，若發生曾文水庫資料無法取得時，將忽略南水局曾文水庫集水區電傳雨量站，平均雨量則僅計算氣象局雨量站所組合之平均雨量。
  3. 當曾文水庫集水區電傳雨量站完成自動擷取時，將自動執行曾文水庫集水區各分區平均雨量計算，包含徐昇加權因子及高度平衡加權因子。

    進水量自動推估將於整點各水庫取得水位後自動計算，可手動關閉此項功能。進水量自動推估時，若該時刻無放水資訊，將自動沿用前時刻之放水量作為該時刻之放水量，若前時刻亦無放水量，則不使用放水資訊，因此自動推估可能受有無放水資訊影響而錯估，若發生錯估時，可由手動重算重新推估設定時段內之水庫進水量。

圖2.4-2　手動設定雨量品管或平均雨量計算

    各時間資料擷取定時自動偵測執行，若在未達到定時自動執行前，需提前手動偵測執行時，可點選目前時刻，即自動偵測執行最新狀態，如圖2.4-3所示，此動作包含自動偵測，故不會重複匯入資料，但偵測時需透過網路檢查伺服器，將增加網路流量。

圖2.4-3　手動立即偵測與執行資料擷取

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第二章 | 前一節 | 後一節


第三章　水情蒐集分析查詢與展示

3.1　系統登入與登出

3.2　資料查詢方式

3.3　雨量查詢

3.4　水位查詢

3.5　操作過程查詢

3.6　列印操作

3.7　通訊錄查詢與操作

3.8　其他查詢與操作

3.9　流域水情快速查詢

3.10　資料新增與修改

3.11　颱風降雨事件查詢

3.12　匯出成為 Office 文件

3.13　線上輔助說明

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一章 | 後一章


3.1　系統登入與登出

    系統統一經帳號密碼授權登入，如圖3.1-1所示，登出系統時，點選系統右上角登出功能，或直接關閉瀏覽器亦可，如圖3.1-2所示，其中若帳號或密碼任一項空白時，自動改以參觀者(guest)登入系統，若以參觀者登入系統，各項查詢均僅能查詢當日，不得查詢歷史資料，且不得使用或查詢通訊錄資料庫。

    若閒置時間超過20分鍾，將自動登出系統，當點選任何功能時，均將自動導回系統登入畫面，重新輸入帳號密碼。

圖3.1-1　執行系統登入畫面

圖3.1-2　執行系統登出畫面

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.2　資料查詢方式

    資料查詢包含三種選擇方式，颱風或降雨事件選擇、日報表兩種時距選擇及自定時間範圍選擇，颱風或降雨事件選擇會自動由資料庫讀出颱風列表，包含氣象局即時已發布海上陸上颱風警報之颱風，如圖3.2-1所示，先點選颱風豪雨事件後，點選下拉式選單，即可由列表中選取颱風豪雨事件。

圖3.2-1　颱風豪雨事件查詢

    日報表查詢可選擇以0點到24點或是上午9點到隔日上午9點兩種，如圖3.2-2所示，先點選日報表後，可由下拉式選單選擇時間間距，並點選開始日期後，可選擇日期。

圖3.2-2　日報表查詢

    日期年份選擇設定可先由上下翻轉符號中，逐次選擇前一年或後一年，亦可直接由數字之文字盒直接輸入，此處採用西元年份，如圖3.2-3所示。

圖3.2-3　西元年份選擇

    日期月份選擇設定僅由下拉式選單，選擇目標月份，或由左、右鍵號選擇前一月份或後一月份，如圖3.2-4所示。

圖3.2-4　日期月份選擇

    日期選擇設定則由當月月曆直接點選，其中若需快速返回當日月曆時，可點選今天返回，當點選任一日期後，將變更日期為選定之日期，若點選關閉或直接關閉對話盒，將放棄以選擇之年份及月份，恢復成原先日期，如圖3.2-5所示。

圖3.2-5　日期選擇

    自訂查詢可自由選擇開始時間及結束時間，但結束時間必須在開始時間之後，最小可選擇單位為小時，日期選擇同前述設定，不再重複，當選擇自訂查詢後，小時下拉式選單則自動由灰色轉變為黑色，並可點選下拉選擇。其中上述三種查詢方式，均適用於報表展示及繪圖展示，圖3.2-6所示為繪圖展示時變更時間範圍。

圖3.2-6　自定時間範圍查詢

    在降雨量、運轉操作另再依子集水區區分，由左方下拉式選單點選子集水區，或點選地圖圖示後，以地圖選單選取子集水區，曾文水庫集水區預設採南水局雨量站分析，若需瀏覽氣象局雨量站，則必需透過下拉式選單點選，如圖3.2-7、圖3.2-8。

圖3.2-7　點選地圖圖示

圖3.2-8　地圖選單選取子集水區

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.3　雨量查詢

    雨量查詢時間設定部份已於上節說明，後續不再重複說明相關查詢時間設定部份，雨量查詢時，會動態由資料庫讀取雨量及平均雨量資料，若所選擇時間無資料時，則自動以空白顯示，若有資料，則依該站該時刻雨量品管結果，自動顯示相對應文字顏色與背景顏色，如圖3.3-1所示，水山及大棟山兩雨量站在2001/9/17 6:00時之觀測雨量並未通過品管要求。

圖3.3-1　雨量查詢

    由於雨量站數過多，一頁無法完整顯示所有雨量站之資料，因此依集水區分區將其分為九種選擇，由右方下拉式選單選擇集水區，其中除曾文水庫集水區外，均顯示氣象局所屬雨量站，氣象局所屬雨量站在曾文水庫集水區部分的查詢，則加註氣象局於後，如圖3.3-2所示。

圖3.3-2　曾文水庫集水區氣象局所屬雨量站查詢

    等雨量線查詢時，需點選時間上之超連結，各時段第一次點選時，會動態由資料庫讀取雨量分析計算後，匯出為圖檔，爾後將直接展示該時段圖檔，以減少伺服器計算所需時間，如圖3.3-3及圖3.3-4所示。

圖3.3-3　點選查詢等雨量線

圖3.3-4　顯示等雨量線圖

    雨量組體圖查詢時，需累計上之超連結，會動態由資料庫讀取雨量畫出圖檔，如圖3.3-5及圖3.3-6所示。

圖3.3-5　點選雨量組體圖查詢

圖3.3-6　雨量組體圖展示

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.4　水位查詢

    水位查詢時，會動態由資料庫讀取所有水位站水位資料，若所選擇時間無資料時，則自動以空白顯示，若有資料，則依該站該時刻水位品管結果，自動顯示相對應文字顏色與背景顏色，如圖3.4-1所示。

圖3.4-1　水位資料查詢

    水位歷線查詢時，需點選平均上之超連結，會動態由資料庫讀取水位畫出圖檔，並繪製該站斷面、計畫洪水位供參考，如圖3.4-2，各水位站範例依序如圖3.4-3至圖3.4-12所示，其中山美水位站無斷面測量資料，故無背景圖，玉峰橋在支流上，採曾文溪與菜寮溪匯流口斷面取代，山美、新美以納莉颱風期間水位變化為例，下游河段採1999/8/13二日間，曾文水庫在無降雨期間試放水量300 cms、650 cms之水位變化為例，玉峰橋則選擇有資料之時段為例。

圖3.4-2　點選水位歷線圖查詢

圖3.4-3　山美水位站水位歷線圖

圖3.4-4　新美水位站水位歷線圖

圖3.4-5　中正橋水位站水位歷線圖

圖3.4-6　走馬瀨橋水位站水位歷線圖

圖3.4-7　玉峰橋水位站水位歷線圖

圖3.4-8　北勢洲橋水位站水位歷線圖

圖3.4-9　曾文溪橋水位站水位歷線圖

圖3.4-10　麻善橋水位站水位歷線圖

圖3.4-11　西港橋水位站水位歷線圖

圖3.4-12　國姓橋水位站水位歷線圖

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.5　操作過程查詢

    操作過程查詢時，會動態由資料庫讀取所選擇集水區之平均雨量、水位、進水量及放水量，若所選擇集水區非水庫集水區，則自動忽略水位及放水量，若所選擇之時間無資料時，則自動以空白顯示，若有資料，則依該站該時刻品管結果，自動顯示相對應文字顏色與背景顏色。圖3.5-1至圖3.5-12為依序為曾文水庫、南化水庫及烏山頭水庫之運轉過程、平均雨量組體圖、水位歷線及運轉過程圖。

圖3.5-1　曾文水庫運轉操作過程查詢

圖3.5-2　曾文水庫平均雨量組體圖

圖3.5-3　曾文水庫水位歷線圖

圖3.5-4　曾文水庫運轉過程圖

圖3.5-5　南化水庫運轉操作過程查詢

圖3.5-6　南化水庫平均雨量組體圖

圖3.5-7　南化水庫水位歷線圖

圖3.5-8　南化水庫運轉過程圖

圖3.5-9　烏山頭水庫運轉操作過程查詢

圖3.5-10　烏山頭水庫平均雨量組體圖

圖3.5-11　烏山頭水庫水位歷線圖

圖3.5-12　烏山頭水庫運轉過程圖

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.6　列印操作

    查詢時點選右上方列印，即可呼叫列印視窗列印，如圖3.6-1為雨量查詢時點選列印視窗，此時會叫出預覽列印供使用者先行預覽，若需列印則點選左上放列印按鈕，列印完後會自動關閉，若需關閉則點選上方關閉按鈕。

圖3.6-1　雨量日報表預覽列印

    列印圖形時，亦將自動顯示預覽列印視窗，如圖3.6-2所示，然圖形適合採用橫向列印，故可透過印表機設定將列印方向改為橫向列印，如圖3.6-3所示，亦可透過預覽列印比例調整在螢幕上看到畫面之大小，如圖3.6-4所示。

圖3.6-2　水位歷線預覽列印

圖3.6-3　變更預覽列印設定為橫向列印

圖3.6-4　變更預覽列印預覽比例

    若需變更圖形顏色、樣式、字型或填色時，可點選右上角關閉鈕後，點選欲變更圖元按滑鼠右鍵，叫出設定視窗，如圖3.6-5所示。各項設定均可透過對話盒及選項修改，如圖3.6-6所示。變更與設定完成後，透過選單可重新呼叫預覽列印視窗，如圖3.6-7所示，依變更後結果列印如圖3.6-8所示。

圖3.6-5　滑鼠右鍵叫出設定視窗

圖3.6-6　變更填色漸層方式

圖3.6-7　重新呼叫預覽列印功能

圖3.6-8　變更後繪圖預覽列印

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.7　通訊錄查詢與操作

    通訊錄查詢時，預設僅列出機關代號1 ~ 10之人員及單位，如圖3.7-1所示。

圖3.7-1　通訊錄列表查詢

    若需查詢詳細聯絡資料，可點選人名之超連結，將顯示詳細聯絡資料，如圖3.7-2所示，若需編輯或刪除，可點選相關超連結，其中，編輯與更改屬特殊屬性，視該使用者是否具有相關權限，如圖3.7-3所示。

圖3.7-2　聯絡人詳細資料查詢

圖3.7-3　修改聯絡人詳細資料

    若需新增聯絡人，可在圖3.7-1點選新增聯絡人之超連結，其中，新增聯絡人屬特殊屬性，視該使用者是否具有相關權限，如圖3.7-4所示。

圖3.7-4　新增聯絡人

    若需設定關鍵字查詢聯絡人，可輸入關鍵字查詢，如圖3.7-5所示。

圖3.7-5　設定關鍵字查詢通訊錄

    此外，本系統支援Outlook及Outlook Express通訊錄格式，可自動轉換格式匯入個人電腦通訊錄，以利平時業務往來聯絡之用，點選圖3.7-2聯絡人圖示後，會詢問是否允許下載開啟，如圖3.7-6所示，點選開啟後，會依電腦內預設通訊錄處理程式開啟通訊錄，本例為Outlook，如圖3.7-7所示，若需匯入Outlook，則點選儲存後關閉，若要放棄匯入Outlook，則直接點選右上方關閉鈕關閉。

圖3.7-6　詢問是否下載個人名片檔

圖3.7-7　個人名片檔開啟視窗

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.8　其他查詢與操作

    本系統配合相關需求及操作介面將本文件轉換為線上手冊格式，可透過系統查詢相關功能使用，如圖3.8-1所示。系統錯誤訊息如圖3.8-2所示。

圖3.8-1　線上手冊查詢畫面

圖3.8-2　系統錯誤訊息查詢畫面

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.9　流域水情快速查詢

    本系統另建立地圖型態查詢網頁，可同時顯示流域內三座主要水庫即時水情或歷史水情，如圖3.9-1所示。點選歷線圖可放大瀏覽，如圖3.9-2所示。直接點選各子集水區可放查詢子集水區運轉報表，如圖3.9-3、圖3.9-4所示。

圖3.9-1　主要水庫水情快速查詢

圖3.9-2　放大檢視點選之水庫運轉歷線

圖3.9-3　直接點選子集水區

圖3.9-4　查詢點選之子集水區運轉報表

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.10　資料新增與修改

    本系統支援線上人工手動新增資料與修改資料。

    若您在登入所使用的帳號與密碼具有資料新增權限，則在無資料的時段將以 - 顯示，如圖3.10-1所示。並且您可以點選後新增資料，如圖3.10-2所示。

    請注意，您若新增資料，則該筆新增資料之品質管理將被標示為人工匯入。

圖3.10-1　以滑鼠點選新增資料

圖3.10-2　輸入新增資料內容

    本系統在權限定義上，修改資料需較高權限方可修改，您若具有新增資料權限，不代表您亦有修改資料權限。

    若您在登入所使用的帳號與密碼具有資料修改權限，則各筆資料均可以滑鼠點選修改，如圖3.10-3所示。並且您可以點選後修改資料，如圖3.10-4所示。

    請注意，您若修改資料，則該筆修改資料之品質管理將被變更為人工匯入，原先之品管資料將被覆寫。

圖3.10-3　以滑鼠點選修改資料

圖3.10-4　輸入修改資料內容

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.11　颱風降雨事件查詢

    本系統支援即時及歷史颱風降雨事件查詢，點選降雨事件查詢後，將顯示資料庫內之颱風降雨事件列表，如圖3.11-1所示。

圖3.11-1　颱風降雨事件列表

    若屬颱風資訊，將可透過右方超連結文字查詢歷時與即時之颱風路線圖，並顯示最後一筆颱風資訊簡要內容，如圖3.11-2所示。

圖3.11-2　即時颱風路線與內容資訊

    另可分別查詢系統由氣象局即時擷取之各項颱風警報資料列表，此列表包含海上颱風警報發布前之相關資訊及解除海上颱風警報後相關資訊，當氣象局有持續發布觀測資料時，系統均自動匯入資料庫，如圖3.11-3所示。

圖3.11-3　颱風警報資料列表

    若需查詢某時刻之颱風警報詳細資料，可點選該時刻上之超連結，即可顯示詳細之颱風警報資料，海上颱風警報前，六小時發佈一次，海上颱風警報發布後，三小時發佈一次，海上陸上颱風警報發布後，每小時發佈一次，並自動合併數個預報檔，將氣象局颱風警報12、24、48及72小時預測位置合併納入，如圖3.11-4所示。各時段氣象局對本流域發布總降雨量上限、下限資料須由人工輸入，需擁有防洪運轉權限以上之使用者，才可在此表內輸入。

圖3.11-4　颱風警報資料列表

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.12　匯出成為 Office 文件

    本系統支援將表格會出成為 Office 文件，目前支援對象有 Word 、 Excel 及 PowerPoint 三種。

匯出成 Word 文件

圖3.12-1　點選右上角 Word 圖示

圖3.12-2　Internet Explorer 詢問處理方式

圖3.12-3　以 Word 開啟表格

圖3.12-4　使用 Word 預覽列印

匯出成 Excel 文件

圖3.12-5　點選右上角 Excel 圖示

圖3.12-6　Internet Explorer 詢問處理方式

圖3.12-7　Internet Explorer 以內崁 Excel 開啟表格

匯出成 PowerPoint 文件

圖3.12-8　點選右上角 PowerPoint 圖示

圖3.12-9　Internet Explorer 詢問處理方式

圖3.12-10　Internet Explorer 以內崁 PowerPoint 開啟表格

圖3.12-11　PowerPoint 投影片播放完畢

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


3.13　線上輔助說明

    本系統支援線上輔助說明，您在各網頁操作時，若有需要說明，可點選工具列中右方輔助說明圖示，如圖3.13-1所示。點選該圖示後，即可連結到該功能之說明，如圖3.13-2所示。

圖3.13-1　以滑鼠點選新增資料

圖3.13-2　輸入新增資料內容

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

第三章 | 前一節 | 後一節


曾文水庫暨曾文溪流域防洪運轉決策支援系統

    防洪運轉決策資訊系統下各子模式係由水利專業人員各自獨立開發，亦有多個既有模式可供選用，由於考量必須容納既有模式且水利專業人員可能無法配合開發元件，宜採程序(Process)整合方式完成系統整合與建置。Windows為多工系統，除直接在系統內改寫過之模式可直接在程序內執行外，外部程序均由主程序呼叫子模式後進入無窮等待，直至子模式程序結束後，主程序才繼續執行下一步驟分析。

    在考慮系統彈性及未來擴充能力，各部份計算模組系統均須分類並可依序得自動執行或手動執行，系統所建構之企業邏輯則建入主模式中，由模式執行時才動態呼叫不同子模式執行，示意如表8所示。在定時自動執行時，由表中各執行項目依序自動執行，當某流域或某供水系統有較新的方法時，可增加新一組模式代號分析，必要時得變更預設選項為新模式進行分析，因此任一流域之特定資料分類最多可有約21億種模式可擴增進入本系統，此外，考量可能購置既有模式或擴增功能模式配合本系統，將各模式增加執行步驟納入管理，若該模式針對本系統獨立發展，可僅有單一步驟，包含資料庫之存取與寫回，若為不支援資料庫或另行購置之軟體，可於模式執行前後增加資料庫與該模式資料檔轉換模組後，將此功能納入擴增於本系統，此外，執行步驟最多可有約21億步，若另行購置模式需經多個模組分析時，則可於步驟中持續增加項目已完成目的，若另行購置模式屬於跨流域或跨資料類別之整合性模式，則於第一次執行時，寫入完整步驟，其他資料分類或流域則僅需單一步驟匯入該資料分類所需之資料即可。

    在防洪運轉決策資訊系統啟動時，先顯示起始畫面，之後顯示專案選擇畫面，即進入快速選單畫面，專案在執行時採定時自動運算所有狀況，必要時現地人員可自行設定或變更條件後自動繼續完成分析，如圖所示。模式將所有子模組封裝為無介面之運算，所有運算過程均顯示狀態列，若該項功能正在執行時，將閃爍該項功能按鈕，使使用者能夠注意到該項功能執行中，計算完畢時，轉為灰色按鈕，代表不需再執行。

圖 1　起始快速選單

圖 2　執行中快速選單

雨量預報及平均雨量計算

降雨逕流分析

曾文水庫運轉操作策略

水庫下游河道洪水演算

線上輔助說明

自動輪撥展示

    由於全區曾文溪流域防洪運轉資訊十分繁多，故建立簡易之輪撥展示，讓系統自動定時更換顯示，空間資料採由時間在前向後播放，等雨量線採時間自動輪撥，依序由事件開始時間每10秒逐時撥放至事件結束時間；時間資料則輪流播放不同集水區，運轉過程歷線依集水區分區採空間自動輪撥，依序由曾文水庫集水區每5秒逐區撥放至烏山頭水庫集水區，若有足夠顯示器或單槍投影機，可分別在不同螢幕持續撥放，以利快速掌握水情。

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

雨量預報及平均雨量計算 | 降雨逕流分析 | 曾文水庫運轉操作策略 | 水庫下游河道洪水演算 | 線上輔助說明


雨量預報及平均雨量計算

    當觀測雨量匯入資料庫後，自動進行資料品管分析，完成後選取通過品管之雨量站組推估各子集水區平均雨量。

    當點選或自動執行到雨量預報時，採用蔡孝忠所改進之颱風定量降雨氣候預報模式推估，由於部分雨量站歷史資料不足，雨量預報模式僅推估32站雨量站，並執行各子集水區平均雨量計算，整場颱風雨量預報需約需10秒。

    計算完成後可由雨量報表按鈕查詢降雨量與繪製雨量組體圖，報表製作與雨量組體圖均由水情蒐集分析查詢與展示系統處理，如圖所示，其中缺空攔為未預報之雨量站。

圖 1　曾文水庫集水區雨量站及平均雨量列表

圖 2　菜寮溪集水區雨量站及平均雨量列表

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

曾文水庫暨曾文溪流域防洪運轉決策支援系統 | 降雨逕流分析


降雨逕流分析

    當點選或自動執行到降雨逕流分析時，依序執行各子集水區各模式降雨逕流分析，南化水庫及烏山頭水庫屬自然溢洪水庫，此時一併進行水庫演算，推算溢洪水量。若目前這個時段有發電放水或針對供水標的放水，則假定供水行為持續至防洪運轉結束推估，再進行溢洪水量分析。計算完成後可由流量報表按鈕查詢平均降雨量與逕流量，繪製雨量組體圖，如圖所示。

圖 1　南化水庫集水區平均雨量與逕流量列表

圖 2　烏山頭集水區平均雨量與逕流量列表

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

曾文水庫暨曾文溪流域防洪運轉決策支援系統 | 雨量預報及平均雨量計算 | 曾文水庫運轉操作策略


曾文水庫運轉操作策略

    當點選或自動執行到曾文水庫運轉操作策略時，本功能會自動準備及產生優選模式所需要之檔案，並自動執行優選模式分析。計算完成後可由右方運轉過程按鈕查詢平均降雨量、水庫水位與水庫進水量及最佳放水量，如圖所示，其中由於模式僅分析最佳放水總量，故各水門未來放水量為空白，各子集水區運轉過程歷線。

圖 1　曾文水庫運轉過程推估表

圖 2　曾文水庫運轉過程推估歷線

圖 3　南化水庫集水區不同時刻子集水區運轉過程歷線

圖 4　曾文溪三區集水區不同時刻子集水區運轉過程歷線

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

曾文水庫暨曾文溪流域防洪運轉決策支援系統 | 降雨逕流分析 | 水庫下游河道洪水演算


水庫下游河道洪水演算

    點選或自動執行到水庫下游河道洪水演算時，本功能會自動執行變量流分析，計算完成後可由水位報表按鈕查詢各水位站水位，各水位站水位歷線可透過報表查詢繪製，如圖所示，未計算之斷面水位為空白。

圖 1　水位站水位過程報表

圖 2　北勢洲橋水位歷線

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

曾文水庫暨曾文溪流域防洪運轉決策支援系統 | 曾文水庫運轉操作策略 | 線上輔助說明


線上輔助說明

    系統支援線上輔助說明，在各網頁功能操作時，可隨時點選輔助說明圖示，即可連結到該功能之說明，或利用輔助說明鍵[F1]得到HTMLHelp協助，如圖所示。

圖 1　線上手冊說明自動導向查詢畫面

圖 2　線上手冊HTMLHelp電子書查詢畫面

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

曾文水庫暨曾文溪流域防洪運轉決策支援系統 | 水庫下游河道洪水演算


額外需求元件與程式

說明

原始檔引用系統公用元件（非 VB 6 內建），優選模式需配合 Lindo 6.1 方可執行，請下載安裝。

元件說明

項目 | 模式分類 | 說明
Microsoft Internet Explorer 6.0 SP1 | 共用 | 此程式運用於瀏覽系統、並升級相關系統元件，使系統函式庫支援穿越防火牆能力，並使系統瀏覽器支援 PNG 圖檔格式，可至下面網頁參照免費取得方式： http://www.microsoft.com/windows/ie_intl/tw/
Office XP Web Component (OWC) | 共用 | 此元件運用於系統繪圖展示，於安裝 Office XP 時即自動安裝完成，若未安裝 Office XP ，可至下面網頁參照免費取得方式： http://tlcheng.no-ip.com/TLCheng/Basic/vbs/WebChart/client.htm 本項軟體為繪圖元件，同時供兩系統繪圖使用，係為 Office XP 內建物件之一，依軟體授權許可允許企業內部網路傳送此元件，因此本項軟體不需額外購買，由於本項軟體目前並不前向相容，且暫時無最新相容版本，故須限定使用10.0版，可上網(http://www.microsoft.com/taiwan/)免費取得。
Microsoft Data Access Components (MDAC) 2.8 以後版本 | 共用 | 本項軟體為系統資料庫增強物件之一，依軟體授權許可第一款第一項，可免費隨應用軟體之一部份而一併加以轉散佈或交由第三者轉散佈之，因此本項軟體不需額外購買，可隨本系統安裝光碟或上網(http://www.microsoft.com/taiwan/)免費取得。
Script Control 1.0 | 共用 | 此元件運用於系統繪圖展示動態指令，隨 IE 版本更新，只要 IE 版本在 5.0 以後，系統即內建此元件，應採用 IE 6.0 SP1，或可由上述網址下載。
Microsoft SQL Server 2000 Desktop Engine (MSDE 2000) SP3a 以後版本 | 伺服器 | 若暫不購置SQL Server 2000，可採免費版本 MSDE 2000取代，唯其資料庫大小不得超過2 GB，且不含操作介面進行資料庫操作，操作介面可透過SQL Server 2000試用版安裝client端取得，本項軟體不需額外購買，可隨Office XP安裝光碟、本系統安裝光碟或上網(http://www.microsoft.com/taiwan/)免費取得。 若為新安裝可採用最新版本 MSDE 2000 Release A
Lindo 6.1 | 優選 | 優選模式需配合 Lindo 6.1 方可執行，請下載安裝，下載路徑位置為http://www.lindo.com/lnd61.exe。

註：共用係指兩模式，優選係指優選模式。

基本條件

應安裝於 Win32 相容作業系統

請參閱

IE 首頁 | OWC 首頁 | MDAC 2.8 下載首頁 | Script 首頁 | MSDE 2000 Release A 下載首頁 | Lindo 首頁


匯出圖檔格式比較

說明

模式可輸出三種圖檔格式，分別為 png、gif 與 jpg，針對不同圖檔匯出成果分別列表與展示比較如後，經綜合比較得知，本模式輸出圖形以採 png 格式較佳，兼具檔案較小及美觀優勢。

圖檔格式

檔名 | 格式 | 位元組 | 說明
grapher.png | PNG | 8,333 | 適用於美工插畫、線條稿，標誌符號等這種有大塊相同顏色的圖案，如本例。 無版權問題，為無失真壓縮，沒有256色的限制，並支援256階的透明效果，靠這三點就可完全取代 GIF ，但不支援動畫效果，舊版本軟體多數不支援，要新版本軟體才支援。
grapher.gif | GIF | 21,487 | 適用於美工插畫、線條稿，標誌符號等這種有大塊相同顏色的圖案，如本例。 有版權問題，目前學術使用可免付版權費，支援動畫效果，為無失真壓縮，有 2、4、16、256 色限制，本模式僅能輸出 256 色，超過 256 色需進行減色運算將總顏色降至 256 色。
grapher.jpg | JPG | 68,025 | 適用於全彩、漸層或色彩連續變換之圖案，如相片。 無版權問題，為破壞性壓縮，壓縮比越大，檔案越小，但圖形失真情況越嚴重，若背景或填色大量採用照片或圖樣貼圖時，則以本格式較為合適。

grapher.png

grapher.gif

grapher.jpg

系統開發及維護：水海科技系統研發驗證工作室 鄭子璉 (Tzu-Lien, Cheng)


曾文水庫運用要點

曾文水庫運用要點

中華民國九十一年十月一日經授水字第○九一二○二一三五七○號令頒

第一章　總則

一 、 經濟部 (以下簡稱本部)為調蓄及有效運用曾文水庫(以下簡稱本水庫)所攔蓄曾文溪水源，以達成供應家用及公共給水、農業用水、水力用水、工業用水與防洪等功能，特訂定本要點。
二 、 本水庫以本部水利署南區水資源局（以下簡稱南水局）為管理機關，負責管理運用。
三 、 本水庫位於嘉義縣曾文溪主流柳籐潭上游，其運轉主要設施如下：
      （一）大壩
      （二）溢洪道
      （三）取出水工
      （四）電廠
      （五）東口導水堰
四 、 本水庫之運用係以年用法為基準，並以產生水利事業之最高綜合效益為目的調配各功能實際需要。
五 、 本要點之名詞定義如下：
      （一）年用法 自每年枯水期後水庫水位最低時期蓄水利用，至次年枯水期結束為止。
      （二）蓄水運用週期 自每年六月一日起至次年五月底止。
      （三）蓄水利用運轉 以水庫蓄水調節供應家用及公共給水、農業用水、水力用水或工業用水功能之需要。
      （四）防洪運轉 颱風或豪雨期間，經由溢洪道或其他放水設施放水之運轉。
      （五）緊急運轉 在發生特殊洪水或災變，危及水庫安全，情況危殆，嚴重威脅公眾生命及財產之安全時，所採取之因應運轉。
      （六）水庫運用規線 為執行蓄水利用運轉，依水庫水位或蓄水量劃定界線，以表示水庫存蓄水量之豐枯情形。
      （七）上限 一年中本水庫有效蓄水量處於豐盈狀態之最低水量。
      （八）下限 一年中本水庫與烏山頭水庫有效蓄水量之和處於缺水狀態之水量。
      （九）嚴重下限 一年中本水庫與烏山頭水庫有效蓄水量之和處於嚴重缺水狀態之水量。
      （十）基準供水量 一年中本水庫各用水標的依下限以上至上限未滿之年平均蓄水量情況，所擬定之各旬計畫基準分配供水量。
      （十一）颱風情況 中央氣象局發布海上陸上颱風警報，且本水庫集水區列入警戒區域時。
      （十二）豪雨情況 中央氣象局發布本水庫集水區豪雨特報或因颱風引進西南氣流之豪雨時。
      （十三）緊急情況 發生可能危及壩體安全的各種內在及外在因素，其情形如下：
1. | 水庫水位陡升。
2. | 壩身含水量近於完全飽和。
3. | 壩體或基礎產生管湧陷穴或遭淘蝕。
4. | 壩體滲流水夾雜泥砂或其他可疑之懸浮物。
5. | 壩體及其下游出現大量滲流，或排水滲流終止。
6. | 壩體發生或感受強度達五級以上之地震，造成壩址沉陷、龜裂，或壩體不均勻變位、滑動。
7. | 壩體之上、下游坡面滑動。
8. | 水庫邊坡崩坍或因暴風形成破壞性湧浪，造成壩體的侵蝕破壞。
9. | 溢洪道閘門操作機械故障。
10. | 溢洪道或出水工等大壩附屬結構物損壞。
11. | 壩體或附屬結構物有進一步破壞之可能性。
12. | 水庫觀測儀器讀數異常。
13. | 其他危及大壩安全之狀況。
      （十四）洪峰流量　一次洪水過程中，最大之瞬時流量。
      （十五）洩洪量　防洪運轉時，經由溢洪道及其他放水設施放水之總放水量。
      （十六）調節性放水 防洪運轉時，在水庫水位趨近滿水位時，經由溢洪道或其他放水設施預先排放水量以調節水庫水位之放水。

第二章　蓄水利用運轉

六 、 本水庫蓄水利用運轉應與臺灣省嘉南農田水利會(以下簡稱水利會)之烏山頭水庫相互配合運用。
七 、 本水庫洩放之水，除供楠西、玉井地區家用及公共給水及下游水權人使用外，均由東口導水堰攔截，經東口進水口導至烏山頭水庫調節後，由嘉南農田水利會按家用及公共給水、農業用水與工業用水功能之計畫需要放供。
八 、 本水庫蓄水利用運轉應依據水庫運用規線執行。
      前項運用規線在各旬初之水量規定如附表一。
九 、 本水庫有效蓄水量利用運轉，應依下列規定辦理：
      （一）蓄水量超過上限時，得視各標的需要，超量供應其需要或洩放，使降至上限水準為止。
      （二）蓄水量在上限與下限之間時應按各標的基準供水量供應。
      （三）蓄水量在下限與嚴重下限之間時家用及公共給水按基準供水量供應，農業用水與工業用水水量則按基準供水量之百分之七十五供應。
      （四）蓄水量在嚴重下限以下時家用及公共給水按基準供水量之百分之八十供應，農業用水與工業用水水量則按基準供水量之百分之五十供應。
      （五）依第(一)款至(四)款規定縮減各標的用水，水庫蓄水仍不敷分配使用時，應視當時情況依各標的縮減方式再縮減分配供應，或由南水局、嘉南農田水利會、自來水公司及其他用戶協商辦理。
      （六）依第(三)款至第（五）款各標的用水不同打折率之差異水量以移用水量補注之。
十 、 本水庫洩放供應家用及公共給水、農業用水與工業用水之水量，應經由曾文發電廠發電後放出。但不能或不宜經曾文發電廠放水及發電放水不足農業用水需要時，得由永久水道放水口放水。
十一 、 本水庫有效蓄水量在上限以下洩放水量時，不得使東口導水堰溢流。但逾上限，且烏山頭水庫已滿或特殊情況洩放水量無法進入烏山頭水庫時，得在東口導水堰溢流。
      本水庫之放水應維持烏山頭水庫之水位在標高四十五公尺以上，並應防止溢流。但為調節性放水、實驗、緊急情況等特殊者不在此限。
十二 、 南水局與嘉南農田水利會應在水庫運用年度開始前共同協商擬定年度供水計畫。
十三 、 曾文發電廠應配合家用及公共給水、農業用水與工業用水所需水量運轉發電，所發電量按合約售予臺灣電力股份有限公司。
十四 、 本水庫給水以供應嘉義縣、嘉義市、臺南縣及臺南市地區內所需家用及公共給水與工業用水之原水為限，影響農業用水時協議計價補償；公共給水之原水，應售予臺灣省自來水股份有限公司。但該公司尚未供水地區，得由本水庫供給原水；工業用水之原水，以不妨礙自來水公司給水計畫為原則，由南水局專案報本部核准後供應之。
      給水用戶應與南水局簽訂供水契約後由本水庫按約供水。移用他標的分配水量時，應先徵詢該標的同意並預先擬定移用水計畫，送南水局及嘉南農田水利會參考配合運用或輸送。如供水需利用嘉南農田水利會之設施時，應洽得嘉南農田水利會同意。

第三章　防洪運轉

十五 、 本水庫防洪運轉，應依下列規定執行：
      （一）颱風或豪雨情況時，水庫水位超過標高二百二十五公尺或水庫水位及水庫進水量達到附表二之水庫水位及水庫進水量，得開始防洪運轉，但水庫進水量及水庫水位達到同點第二款之情事時，應開始防洪運轉。
      （二）非颱風或豪雨情況時，水庫水位超過標高二百二十七公尺或水庫水位及水庫進水量達到附表三之水庫水位及水庫進水量，應開始防洪運轉。
十六 、 防洪運轉時，水庫之放水量應依下列規定：
      （一）在洪峰流量未過前，洩洪量超過二千二百五十秒立方公尺時，洩洪量之增加率應小於水庫進水流量之最高增加率，洩洪量應小於最大進水流量。水庫水位超過標高二百三十公尺，或水庫水位及水庫進水量達到附表四之設計洪水情況時，即以最大容許放水量放水。
      （二）洪峰流量過後，水位低於標高二百三十公尺，洩洪量不得大於進水流量加上附表五之可增放水量，且不得大於進水流量之洪峰流量。
十七 、 本水庫有下列情事之一時，應停止防洪運轉：
      （一）洪峰流量已過，水庫水位未超過標高二百二十七公尺且水庫水位及水庫進水量低於附表六之水庫水位及水庫進水量。
      （二）依十五點第(一)款規定開始之防洪運轉，洪峰流量未過，水庫水位未超過標高二百二十五公尺且水庫水位及水庫進水量低於附表二之水庫水位及水庫進水量。
      （三）依第十五點第(二)款規定開始之防洪運轉，洪峰流量未過，水庫水位未超過標高二百二十七公尺且水庫水位及水庫進水量低於附表三之水庫水位及水庫進水量。
      （四）依第十五點第(一) 款開始之防洪運轉，於颱風或豪雨情況解除後，進水流量及水庫水位無同點第(二)款及緊急情況之情事。
十八 、 南水局應於溢洪道洩洪開始一小時前，由該局將洩洪量迅速向下游地區發布洩洪警報，並以電話及傳真通報經濟部水利署及轄區內台南縣市政府、消防局、警察機關、第六河川局及嘉南農田水利會，迅速轉知下游居民，開始洩洪運轉之第一小時，並應以最低容許洩洪量洩放，以示警告。
十九 、 防洪運轉時，洩洪量達五千五百秒立方公尺時，曾文發電廠應停止發電。
二十 、 防洪運轉時，為排除進水口附近淤砂，得使用永久水道放水口放水。
二十一 、 東口導水堰排砂閘門有下列情事之一時，應予開啟：
      （一）沖除泥砂或淤積之雜物。
      （二）防洪運轉。
      （三）因地區性陣雨使到達東口導水堰之流量超過東口進水口之最大容許進水量。
      （四）依第十一點第一項但書規定在東口溢流時。
      （五）、供應下游用水。
二十二 、 本水庫有下列情況得實施調節性放水，惟其洩洪量不超過九百秒立方公尺：
      （一）在颱風情況或豪雨情況水庫水位超過二二五公尺或蓄水量超過運用規線上限時。
      （二）在非颱風情況或豪雨情況水庫水位超過二二七公尺或蓄水量超過運用規線上限時。

第四章　緊急運轉

二十三 、 大壩或水庫環境可能或已發生緊急情況危及壩體安全，應實施緊急運轉降低水位並檢查維護。
二十四 、 緊急運轉時，得實施調節性放水，並依第十六點之規定操作溢洪道閘門。
二十五 、 緊急運轉之放水量視緊急狀況而定，除有潰壩之虞者外，洩洪量不得超過二千二百五十秒立方公尺。
二十六 、 本水庫有潰壩之虞時，應立即發布警報與洩洪，於不危及壩體安全之範圍內，儘速降低水庫水位。
二十七 、 南水局於不妨礙本水庫家用及公共給水、農業用水、水力用水、工業用水與防洪等功能範圍內，得報請本部核定增加其他用途。
      在颱風季節末期為顧及各標的用水需要，得參酌實際情況機動處理運轉事宜。


在 Internet Explorer 中無法顯示 HTML Help 內容及索引清單或框架無法正確顯示

原因

HTML Help 中的弱點可能會允許遠端執行程式碼 (896358)

  1. 在 2005 年 1 月 12 日微軟發佈 安全性公告 MS05-001 ：890175
  2. 在 2005 年 6 月 15 日微軟發佈 安全性公告 MS05-026 ：896358

    3. 註：MS05-026已包含MS05-001

狀況

  1. 在安裝過此安全性更新後，將導致在 Internet Explorer 中看不見 HTML Help 內容清單或是索引清單， Windows 預設值將變更為僅允許瀏覽本機清單。
  2. 此外， HTMLHelp 的框架功能將會被關閉，使得僅能在目前框架中瀏覽，InfoTech 通訊協定的 URL 網址將被禁用。

受影響的作業系統

  1. WinNT： Windows 2000/XP/2003 （含 64 bit 版本）

    2. 註：Windows NT 4 在允許安裝 Internet Explorer 6 SP1 (IE 6) 的版本則受此影響

  2. Win9x： Windows 98/SE/Me

是否可啟用本機電腦區域以外的信任 HTML Help 說明檔內容？

可以。可以啟用本機電腦區域以外的 HTML Help 說明檔內容，並允許特定網站或安全性區域呈現 HTML Help 說明檔內容。

啟用方法

  1. 設定允許網站

    2. 本方法無操作介面，不建議採用。

    MS05-001
    機碼：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\HHRestrictions
    字串：UrlAllowList
    值：http://localhost/;http://tlcheng.no-ip.com/
    註：其中各網站以分號隔開

    MS05-026
    機碼：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions
    字串：UrlAllowList
    值：http://localhost/;http://tlcheng.no-ip.com/
    註：其中各網站以分號隔開

  2. 設定安全範圍

    3. 建議採用設定安全範圍，並透過 IE 網際網路設定來調整信任的網站。

    MS05-001
    機碼：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\HHRestrictions
    DWORD：MaxAllowedZone
    值：2

    MS05-026
    機碼：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions
    DWORD：MaxAllowedZone
    值：2

    其中各值所代表的意義：
    MaxAllowedZone | 本機 | 近端內部網站 | 信任的網站 | 網際網路 | 限制的網站
0 | 允許 | 封鎖 | 封鎖 | 封鎖 | 封鎖
1 | 允許 | 允許 | 封鎖 | 封鎖 | 封鎖
2 | 允許 | 允許 | 允許 | 封鎖 | 封鎖
3 | 允許 | 允許 | 允許 | 允許 | 封鎖
4 | 允許 | 允許 | 允許 | 允許 | 允許
  3. 啟用跨框架瀏覽

    4. MS05-026 會附帶增加此限制，此說明目前並無法直接在 MS05-026 說明網頁查得，請參閱896905
    機碼：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\HHRestrictions
    DWORD：EnableFrameNavigationInSafeMode
    值：1
    註：其中各網站以分號隔開

  4. 若是使用 WinNT (Windows 2000/XP/2003) 可匯入本站提供之註冊資訊檔，本檔將 MaxAllowedZone 設定為 2 ，並啟用跨框架瀏覽，匯入資訊檔時，建議先觀看確認內容無額外資訊後，再匯入你的電腦，以防止網路傳輸可能被人惡意竄改。ms05-026.reg

瀏覽本站之線上說明檔

若您選擇啟用方式為 1 ，請將本站網址納入，若您選擇啟用方式為 2 ，請將本站加入信任的網站即可。

註冊檔變更後，須關閉 Internet Explorer 後重新開啟，或由捷徑啟動新的執行個體，修改之項目才會作用。

其他

注意，HTMLHelp ActiveX 之執行權限仍受限於 IE 於各網路區域的安全性設定而決定是否執行，此次新增之安全性功能主要為禁止跨站連接，亦即，若設定為 2 的情形下，由 HTMLHelp 內建跳出視窗功能欲連線至網際網路時，仍將被阻擋，不論網際網路是否允許 ActiveX 執行，但目錄、索引清單之連接為網頁連接，非跳出式視窗，故不受影響。

基本條件

應安裝於 Windows 2000 Server 以後之相容作業系統

請參閱

MS05-001 | MS05-026 | 896358 | 896054 | 896905 | HTMLHelp安全說明


檔案下載

電子書下載

下載使用說明電子書 使用說明電子書：tsengwen3.chm


所有圖檔列表

說明

所有圖檔列表。

圖檔說明

項目 | 圖樣 | 說明
過濾條件 |  | 過濾條件圖樣。
基本條件 |  | 基本條件圖樣。
請參閱 |  | 請參閱圖樣。
樹狀結構 |  | 樹狀結構圖樣。
動畫按鈕 |  | 動畫按鈕圖樣。